Skip to:
Content
Pages
Categories
Search
Top
Bottom

Need users to be able to posts without posts being approved

  • I have the bbpress plugin installed in my custom theme and everything works great, except that I can’t get users to post topics and replies without me approving it all the time. I need some kind of control where if approved once there’s no need for approving every time. For some reason, I’m not getting that, i read a in a few places and seen that it could be done, but its not working for me. Everytime it says it’s pending and the admin needs to approve it. I changed the role to a user and tried even forum moderator and I’m able to moderate but when i create a new topic or reply using that role it’s still needs to be approved. I even used a plugin called bbPress Moderation and it still doesn’t do what it says. How can I change this?

Viewing 25 replies - 1 through 25 (of 30 total)
  • I think the two of you need to compare your settings, installed plugins etc, you both have what the other is looking for and with some luck you will both solve each others problems.

    @apena916 see https://bbpress.org/forums/topic/admin-approval-email-for-new-topic/
    @shilpi18th see https://bbpress.org/forums/topic/need-users-to-be-able-to-posts-without-posts-being-approved/

    I don’t understand why you want me to compare the other post, that has totally nothing to do with what I’m trying to do. The link you sent me to is talking about notifying admin that there’s a comment to approve. The problem I have is that I need users to post topics and replies on my forum without me having to approve all of them, or maybe just approve one time so after that I don’t need to approve anymore topics and replies from a user.

    The behavior you are seeing is by design what the ‘bbPress Moderation’ plugin

    From https://wordpress.org/extend/plugins/bbpressmoderation/

    > “To help reduce spam in bbPress forums, this plugin will change the
    > status of new topics and replies to ‘pending’. Any pending
    > topics/replies will be shown as ‘Awaiting Moderation’ until the
    > administrator approves publishes them.”

    Or did you install this plugin to try and resolve the issue but with the plugin disabled you are still seeing this behavior?

    What happens when you disable all other plugins on your WordPress install?


    John James Jacoby
    Keymaster

    @johnjamesjacoby

    I’m a little confused by what netweb is telling you to do. The bbPress Moderation plugin is actually the thing that ENABLES the behaviour you’re experiencing. Without that plugin, your users should be allowed to create topics and replies on their own without any intervention from you or anyone else.

    Deactivate the bbPress Moderation plugin, deactivate bbPress, activate bbPress. That should reset all of bbPress’s role and capability mapping, in the event something is broken.

    What i’m experiencing was even before I installed bbPress Moderation. When I installed bbPress alone i still needed to approve all the posts, when the problem persisted then I installed the bbPress Moderation just to see if it allowed what it said, which is after one time approved I wouldn’t have to approve again, but it never fixed the problem, I still had to approve every post So I did what you said and disabled the bbPress Moderation and I’m still getting the same problem, with or without the plugin all posts goes to ‘Pending’ and I have to approve every single one of them which gets really annoying. I disabled bbPress and re-enabled it and still nothing. I even found a function that I tested on functions.php, the function has this included thinking it would force the users capability to publish.

    $role = get_role( 'subscriber' ); // gets the editor role
    $role -> add_cap( 'publish_topics' ); //-> is actually greater than symbol, this forum is not showing it
    

    but that didn’t work, i feel like there’s an option that never got set in my database, i even restored the plugin and its not working. I just don’t understand why its not working for me, or nothing is being set in capability mapping

    • This reply was modified 7 years, 9 months ago by apena916.
    • This reply was modified 7 years, 9 months ago by apena916.
    • This reply was modified 7 years, 9 months ago by apena916.

    I also forgot to mention that I have Buddypress installed also, but I don’t have the Discussion Forums set on the Buddypress setting. So that should work apart, right?

    One of my users is having the exact same problem, except it’s only one of my users, everyone else is fine. My forums have been running for over a month with no problems, but suddenly this user can’t publish posts without me approving it in dashboard. It becomes marked as “Pending Review”. The only thing that sets her account apart is the number of edits she makes is much higher than anyone else, because she opens a news topic and frequently updates the opening post with new information.

    EDIT: I am using bbPress 2.1

    Sorry for the double post, but I took control of the account and I’m not able to reproduce the error from my session. Her password was reset. Perhaps there is some security setting or browser issue causing wordpress to flag users for reviews? I don’t know much about PHP/MySQL and WordPress so what I’m saying might be stupid…


    grex22
    Participant

    @grex22

    I think I’m seeing a related issue as described at this thread:

    Really, really odd behavior with sticky posts

    The most prolific user in my forum will make a post which seems to want to make itself a draft after a couple of days. It’s quite odd. Once I go in and “Publish” the topic again, it starts behaving normally. What the heck?


    Team Startbit
    Participant

    @vivacityinfotechjaipur

    I also need user to post on a forums without admin approval from backend.Anyone can help me!!


    kalughodakiya
    Participant

    @kalughodakiya

    just remove
    add_action( ‘bp_before_activity_post_form’, ‘bp_registration_hide_whatsnew_start’ );
    add_action( ‘bp_after_activity_post_form’, ‘bp_registration_hide_whatsnew_end’ );

    this from the bp-registration-options/includes/core.php
    you can post to activity without admin approve


    kalughodakiya
    Participant

    @kalughodakiya

    Or use this in your theme functions.php file
    add_action( ‘wp_head’, ‘remove_my_action’ );
    function remove_my_action(){
    remove_action(‘bp_before_activity_post_form’, ‘bp_registration_hide_whatsnew_start’);
    remove_action(‘bp_after_activity_post_form’, ‘bp_registration_hide_whatsnew_end’);
    }


    ginaginagina
    Participant

    @ginaginagina

    Did anyone get this solved on their end? I’m also having a major problem where none of my users can post topics or replies without me having to approve them and all permissions seem to be in place for them. I can not — for the life of me — figure out why the heck they can’t post. Would love to hear a solution!


    rngeer
    Participant

    @rngeer

    I am now having the same issue as well with a member that posts daily and cannot figure out how to get her back to where her posts don’t need to be moderated.


    thierrytregaro
    Participant

    @thierrytregaro

    Same here. Also opened a thread in Requests & Feedback (https://bbpress.org/forums/topic/any-way-to-remove-moderation/). This moderation thing is just killing me. Got no message from anyone involved in dev team…


    creativersis
    Participant

    @creativersis

    Same herr. I had the Moderation plugin on before the newest update. Now I deactivated it but all the topics and replies are still held for moderation. There must be something with the newest bbpress update bc that started happening after the update.


    Chuckie
    Participant

    @ajtruckle

    I can confirm that a basic post with no attachments (reply) is going to pending. It did not before and would like this resolved please. I wish I could help.

    Tied very closely to this is my other discussion where I have shown the code that displays moderation feedback to the user for new topics but the same code is missing for replies. It needs to be there. The user must be told there post has gone to the moderation queue. We have the code and phrases in the files. We just got to drop them into the replies mechanics (except it should go after the post and before the edit control.

    Tied very closely with this is that by design the admin staff should be sent an email if a post goes to moderation without the need for external plugins. Atleast an option to do so.

    Great plugin!


    Chuckie
    Participant

    @ajtruckle

    I had a lost at the differences between 2.5.4 and 2.6.1 for when it comes to moderation and I saw the new function. It is interesting that it refers to these hooks:

    bbp_bypass_check_for_moderation

    bbp_bypass_check_for_blacklist

    Apparently you can use these hooks and if they return true it will stop performing the moderation check. I don’t know how to implement these hooks, and I am not telling anyone they should implement them. Moderation is a good thing when ti works as intended.

    I had a look at my own WordPress Settings | Discussion Settings which is where I understand this gets all the behaviour from and my blacklist and whitelist are empty anyway. But I do have another checkbox ON:

    Comments must be approved

    I had that on because in my website posts where comments are allowed I wanted control. I don’t know if it is this checkbox that is the cause of every topic and reply needing moderation.

    That said, in the same settings page in WP it has options for sending out an email whenever a comment goes into moderation and that is not honoured. So maybe none of these settings are taken into account?


    JoyrideK9
    Participant

    @joyridek9

    I’m also having this same problem! Finally realized that was the issue after an entire day trying to determine why replies were not showing up. Needed to be approved. Have no idea how to fix?? Will try the Discussion setting to see if that helps.


    JoyrideK9
    Participant

    @joyridek9

    Ah – I did not have that check box marked for comments needing approval. BUT I believe the problem I’ve been having is due to the Comment Moderation if it contains links! We use links a lot so this is likely the culprit.


    Chuckie
    Participant

    @ajtruckle

    Read the whole discussion. There is a snippet to switch off moderation. Can you see it?


    rngeer
    Participant

    @rngeer

    Yes, the person having issues posts a few links in hers. Where is that setting?


    Chuckie
    Participant

    @ajtruckle

    Add this to your child theme functions.php or use a snippet plugin:

    // ==============================================================
    // Switch off bbPress Forum moderation
    add_filter( 'bbp_bypass_check_for_moderation', '__return_true' );
    // ==============================================================

    rngeer
    Participant

    @rngeer

    Awesome, will give it a try. Thank you.


    Robin W
    Moderator

    @robin-w

    @ajtruckle- thanks

Viewing 25 replies - 1 through 25 (of 30 total)
  • You must be logged in to reply to this topic.
Skip to toolbar