Skip to:
Content
Pages
Categories
Search
Top
Bottom

Any way to remove moderation ?


  • thierrytregaro
    Participant

    @thierrytregaro

    As every post with picture/link or quote is now waiting for approval, this new moderation thing is just a nightmare.

    So far, using GD Toolbox Report function to let users report posts in need of moderation (and a very secure anti-spam^^). And this was perfect for my needs.

    Now, forum is almost unusable with dozens posts per hour to approve only because some member quoted another. Or added a picture. Discussions are a nightmare to follow with posts validated too late, with many other answers in between. And, of course, users posting many times in a row because their posts wasn’t added to discussion.

    My community is too active to ask for moderators to validate posts. This is a non-sens for my usage : posts are legit until proven not.

    So : is there any way to remove this moderation option ?
    Or i’ll have to remove bbpress. After many years of service and so much time to improve my forums, time may have come to make that switch to Discourse… And, yes, it may be a conflict with Toolbox tools. But there’s no way I use bbpress without GD addon.

Viewing 25 replies - 1 through 25 (of 32 total)

  • Chuckie
    Participant

    @ajtruckle

    I didn’t realise this had changed. My users can put one image but not three images. Maybe there could be some moderation settings to say how many.

    Does the user get notified if their post needs to be moderated?

    I agree though that once approved it needs to be in the correct place in the time line.


    thierrytregaro
    Participant

    @thierrytregaro

    looks like there’s no notification. Not to user. Not to moderators.

    And same “approval” procedure for topics users create or edit.

    Cmon, maybe that’s a good options for some forums. But for active communities, this is just a pile of s…

    This has to be moved to an option. With settings.
    Whatever, had to approve 173 post and 18 topics today. And it’s only 5:30 PM here… And it’s a not very active day, no way I can face it on a monday.


    Chuckie
    Participant

    @ajtruckle

    Well, I wish I could support php development but I don’t know enough about the project.

    It stands to reason that a user needs to be provided feedback if their post has gone to moderation else they will wonder.

    I had a user trying to put two or three images. It just didn’t work for him. I found them in pending list. So user feedback would be high on the list if not too hard. Ideally.

    With thresholds for when items are marked as pending etc. Icing on the cake?

    Doable?


    Chuckie
    Participant

    @ajtruckle

    I have looked at it more and it does actually tell you the “topic” is in moderation:

    https://www.dropbox.com/s/3poekjgqibpnuv2/Moderation.jpg?dl=0

    But if you make a “reply” and have two images in it you do not get the moderation warning.

    So the mechanics must be there for showing the moderation feedback for replies as well as topics. Correct?

    And as mentioned, I would be grateful if I could allow two or 3 images before moderation kicks in. It would be great.

    Thanks ever so much for your hard work. Hope the above information helps.

    Andrew


    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Since the problem appears to be with a third party plugin, you’re unlikely to get a lot of support from the bbPress development team here for code that isn’t theirs.

    In addition, you have not clearly stated what the actual problem is. You have clearly stated your complaints and how you feel about them, but you haven’t included instructions on how to replicate your problem.

    Naturally, these forums are using bbPress, and we aren’t having the same moderation issues that you are. That doesn’t mean there isn’t something wrong, simply that no one knows where to look unless you can show them.


    thierrytregaro
    Participant

    @thierrytregaro

    sorry to disagree. This is not a 3rd party plugin issue but a feature from bbpress that should be optional. Or, at least, that admin should be able to not use.

    You do not fight spam with manual approve. I got days with over a thousands spams, GL doing it one by one LOL. Spamming is anti-spam business, not forum job (using server anti-spam + CleanTalk, maybe I had to remove one post this whole year. Out of 300k posts).

    Today, I had to approve over 350 posts. Some of wich I had no clue why any piece of code could think of it as spam. And that included topics I, as admin, moved from one forum to another.

    Whatever, migrating to Discourse is on its way and should be up tomorrow (it is but not public). There’s no way I can use a manually validating forum anymore. Those 5 years with bbpress were fun (in spite of some epic crashes).


    Chuckie
    Participant

    @ajtruckle

    @johnjamesjacoby

    Please look at the associated, more active discussion on this subject. There are lots of users who now have to approve every post. I have provided comments in that discussion instead.

    I suggest you review that discussion. True, there are complaints, which are all to easy to roll of the tongue, but the point it things have changed. I don’t want to repeat my feedback so please see the other thread.

    I personally need to find a way to control things going into pending. It should only do so if it thinks it needs moderation. Not all posts. The other discussion I found the function that changed the way posts are moderated so so thing must be askew there.

    If your forum is working ok then are you on WordPress 5.3? What are your WordPress discussion settings set to for moderation? It might be an idea to become a admin on one of our sites. Best way to test because I expect this is a common solution.

    See: https://bbpress.org/forums/topic/need-users-to-be-able-to-posts-without-posts-being-approved/


    Chuckie
    Participant

    @ajtruckle

    Here is a result of my particular situation. I think a feature in bbPress is now working correctly whereas it did not before.

    If you go to your WordPress Settings | Discussion area there is an option to tell it when to flag a message for moderation based on the number of links. Mine was set to 2. This is why the users post was flagged. It had 3 links.

    When I tried 2 links it still when to pending. When I tried with 1, it was accepted. I increased my limit to 4 and now it will accept 3 links. So that is one reason.

    The second reason is inserting images (using MCE toolbar). It will not let the user insert more than one image into the post (unless they are admin). I do not know how to increase this as I would also like it to be capped at 4 but there are no settings provided for images. I think the same will apply for videos.


    Robin W
    Moderator

    @robin-w

    I’m just looking at that code are to try and understand it.

    Yes, admins and moderators skip the moderation rules.

    Thanks for the useful testing of the first part – ie the links.

    Images and videos are just links as far as I can see, so should obey the same rules as above and be included in the count.

    so 1 links, I video and 1 image = 3 links.

    can you retest based on that and see if just 1 image is going into pending, or if it is the combination.


    Robin W
    Moderator

    @robin-w

    If you want to remove moderation, I think this will do it

    add_filter( 'bbp_bypass_check_for_moderation', '__return_true' );

    Put this in your child theme’s function file – or use

    Code Snippets

    If someone could test and report back, that would be useful. I have no time availability to do this 🙂


    thierrytregaro
    Participant

    @thierrytregaro

    Thanks for the time/code but closed bbpress this morning and moved to discourse. Lost the perfect integration with wordpress but this is a way more convenient way for me to handle a community maybe too big for bbpress


    Chuckie
    Participant

    @ajtruckle

    @robin-w I can confirm that:

    add_filter( 'bbp_bypass_check_for_moderation', '__return_true' );

    switches off moderating because I was able to insert 5 images as a normal user. So that is one item ticked off the list – how to switch off moderation.

    I will now check the other.


    Robin W
    Moderator

    @robin-w

    thanks


    Chuckie
    Participant

    @ajtruckle

    @robin-w

    I am struggling with your other request. Something isn’t right. I have moderation still switched ON …

    If I try to insert a video (only one video) as a non-admin and hit enter the video won’t play. When I edit the post the content looks like this:

    <video controls="controls" width="300" height="150">
    **source src="pathtovideo/pts-test-video.mp4" type="video/mp4" /**</video>

    bbPress has escaped the < and > symbols.

    If I log back in as admin and perform the same task. I get a functional video link:

    <video controls="controls" width="300" height="150">
    <source src="pathtovideo/pts-test-video.mp4" type="video/mp4" /></video>

    I know it is a side issue but I don’t understand how to fix that and until I do I can’t complete the testing you wanted.


    Robin W
    Moderator

    @robin-w

    yes, the function strips HTML tags nearer the end – can you just confirm what steps you are taking to add the video – is this in the default text area?

    as a by the by, the function if looking for http|ftp|https so if that is in your source path, it will count, if not it should not


    Chuckie
    Participant

    @ajtruckle

    I am using the TinyMCE Insert Video plugin. I paste the URL into that. It works fine for admin. It is only non-admin.

    My functions.php has some tags added to the array defined in here:

    add_filter( 'bbp_kses_allowed_tags', 'ntwb_bbpress_custom_kses_allowed_tags' );

    Snippet:

    		'video'      => array(
    			'controls' => true,
    			'width'    => true,
    			'height'   => true,
    			'source'     => array(
    				'src'    => true,
    				'type'	 => true
    			)
    		)

    There must be a way for me to allow those without escaping for non-admin.

    The path begins https.


    Robin W
    Moderator

    @robin-w

    ok, so path wise it counts.

    on the <source> issue, less certain how to resolve. the code above looks like it should work, but you might need to add source as a top level as well

    if you need help with that, give me the entire function above


    Chuckie
    Participant

    @ajtruckle

    This is the full function:

    
    add_filter( 'bbp_kses_allowed_tags', 'ntwb_bbpress_custom_kses_allowed_tags' );
    
    function ntwb_bbpress_custom_kses_allowed_tags() {
    	return array(
    
    		// Links
    		'a'          => array(
    			'class'    => true,
    			'href'     => true,
    			'title'    => true,
    			'rel'      => true,
    			'class'    => true,
    			'target'   => true,
    		),
    
    		// Quotes
    		'blockquote' => array(
    			'cite'     => true,
    		),
    		
    		// Div
    		'div' => array(
    			'class'     => true,
    		),
    		
    		// Span
    		'span'          => array(
    			'class'     => true,
    			'style'     => true,
    		),
    
    		// Paragraph
    		'p'          => array(
    			'dir'    => true,
    			'style'  => true,
    		),
    		
    		// Code
    		'code'       => array(),
    		'pre'        => array(
    		'class'      => true,
    		),
    
    		// Formatting
    		'em'         => array(),
    		'strong'     => array(),
    		'del'        => array(
    			'datetime' => true,
    		),
    
    		// Lists
    		'ul'         => array(),
    		'ol'         => array(
    			'start'    => true,
    		),
    		'li'         => array(),
    
    		// Images
    		'img'        => array(
    			'class'    => true,
    			'src'      => true,
    			'border'   => true,
    			'alt'      => true,
    			'height'   => true,
    			'width'    => true,
    		),
    
    		// Tables
    		'table'      => array(
    			'align'    => true,
    			'bgcolor'  => true,
    			'border'   => true,
    		),
    		'tbody'      => array(
    			'align'    => true,
    			'valign'   => true,
    		),
    		'td'         => array(
    			'align'    => true,
    			'valign'   => true,
    		),
    		'tfoot'      => array(
    			'align'    => true,
    			'valign'   => true,
    		),
    		'th'         => array(
    			'align'    => true,
    			'valign'   => true,
    		),
    		'thead'      => array(
    			'align'    => true,
    			'valign'   => true,
    		),
    		'tr'         => array(
    			'align'    => true,
    			'valign'   => true,
    		),
    		'video'      => array(
    			'controls' => true,
    			'width'    => true,
    			'height'   => true,
    			'source'     => array(
    				'src'    => true,
    				'type'	 => true
    			)
    		)
    	);
    } 
    

    if I introduce source into the top level then the source inside the video tag gets stripped completely from the output. So I can’t do that. I think bbPress needs tweaking to stop escaping the video tag content. Some how. For not admin.


    Robin W
    Moderator

    @robin-w

    so have you tried both, ie having it at top level and within the video ?


    Chuckie
    Participant

    @ajtruckle

    If I just have it top level, or top level and inside video at the same time, it strips the source tag and it’s contents from the video tag making it unusable.

    The only way I can get the source tag and its attributes / contents to remain is if they are inside the video as an inner array, and only there.


    Chuckie
    Participant

    @ajtruckle

    Shall I raise a trac ticket?


    Robin W
    Moderator

    @robin-w

    I cannot immediately see what is causing this, if you turn off moderation is the problem still there ?


    Chuckie
    Participant

    @ajtruckle

    I am afraid that the problem is still there. Moderation has now been switched off.


    Robin W
    Moderator

    @robin-w

    ok, so it is not that function.

    you could try just adding this to your child theme functions file

    remove_filter( 'bbp_new_reply_pre_content', 'bbp_filter_kses', 40 );

    let me know if that works


    Chuckie
    Participant

    @ajtruckle

    Thanks for the suggestion. I have added the code, and got into private browser mode. And the same results sadly.

Viewing 25 replies - 1 through 25 (of 32 total)
  • You must be logged in to reply to this topic.
Skip to toolbar