Skip to:
Content
Pages
Categories
Search
Top
Bottom

Need users to be able to posts without posts being approved


  • apena916
    Member

    @apena916

    I have the bbpress plugin installed in my custom theme and everything works great, except that I can’t get users to post topics and replies without me approving it all the time. I need some kind of control where if approved once there’s no need for approving every time. For some reason, I’m not getting that, i read a in a few places and seen that it could be done, but its not working for me. Everytime it says it’s pending and the admin needs to approve it. I changed the role to a user and tried even forum moderator and I’m able to moderate but when i create a new topic or reply using that role it’s still needs to be approved. I even used a plugin called bbPress Moderation and it still doesn’t do what it says. How can I change this?

Viewing 5 replies - 26 through 30 (of 30 total)

  • JoyrideK9
    Participant

    @joyridek9

    mgeer: I’m not sure if you’re asking me? I found the setting of forum posts going to moderation due to links:
    Settings –> Discussion Settings … scroll down… Comment Moderation:
    “Hold a comment in the queue if it contains __ or more links. (A common characteristic of comment spam is a large number of hyperlinks.)” I simply upped the number of links so the reply wasn’t held for approval.
    Note there is a category above this for “Before a comment appears” with a slightly different instruction to hold for approval.

    ajtruckle: I don’t know enough about adding information to .php instruction or manual plugin changes without fearing I will mess up something unintentionally. I’ve done it before but just not confident it will work so finding the ‘regular’ solution was good for me.

    For anyone else having this same problem my adjustment to up the number of links included before manually needing approval has worked. Posting has resumed as before.


    rngeer
    Participant

    @rngeer

    Thank you Joy, that was what I needed. Cannot believe it was so simple. Will see if it works for this person. I don’t think we will get spam as the site is locked down to comments. Thank you so much for the help.


    JoyrideK9
    Participant

    @joyridek9

    You’re welcome mgeer – it took several hours of hunting so I’m glad to have helped!


    theicebooky
    Participant

    @theicebooky

    Holy!!! @ajtruckle. You, my dude, have all the gratitude I can give. This is working now all because of you.

    I hope you have a great day.. no weeks… no have the greatest life anyone every lived!!!!!!!


    fullmetalmikey
    Participant

    @fullmetalmikey

    Ah – I did not have that check box marked for comments needing approval. BUT I believe the problem I’ve been having is due to the Comment Moderation if it contains links! We use links a lot so this is likely the culprit.

    Thanks joyridek9! After the recent bbpress and wordpress update I started experiencing this problem. Looks like some settings were reset. Mine were set to moderate if it contained two links or more. Set this number to 0 and poof, problem solved.

    (It should be noted that I have a protected forum hidden with bbgroups. If you have a public facing forum, setting this to zero could increase spam posts so tread carefully.)

Viewing 5 replies - 26 through 30 (of 30 total)
  • You must be logged in to reply to this topic.
Skip to toolbar