Skip to:

Re: Infinite Loops on posts and profiles with IIS


Hi Chris,

Appreciating your continued interest in this.

By “switched it over” I meant on the setting for Pretty permalink type:

The normal way to get this working in IIS is ‘none’ as it doesn’t like url rewrites, so when I switched it over I meant I temporarily turned the setting to ‘Name based’ purely to stop visitors setting the forum into an infinite loop and using a ton of bandwidth as this goes straight to a 404 page not a loop

So the loop occurs when the permalinks are set to ‘None” as can be seen here:

That is the query string format that normally works in IIS.

As for setting the permalinks to true or slugs specifically I’m not sure how to do that.

But I am not using the pretty permalinks normally, I only had it set to that when you visited yesterday so that my bandwidth wasn’t wasted.

That make sense?

Hope so…..

So if you visit right now:

It is set as it should be, complete with loops on topics….

Skip to toolbar