Rick Lewis (@rickdlewis)

Forum Replies Created

Viewing 25 replies - 1 through 25 (of 38 total)

  • Rick Lewis
    Member

    @rickdlewis

    As I recall when doing this long ago, none of the users will work. You have to have them reset their passwords for their accounts to work.

    On the keymaster account there was a trick to that which I do not recall at this moment. However, I do believe you can edit the database itself.

    I believe it changes the role to admin instead of keymaster and then you will have to also change the password to something else.

    Did you use the converter noted in this thread?

    The first link I posted was a very good step by step process that could also give you the info you need.

    If I find anything I will post here to further help out. Good luck.


    Rick Lewis
    Member

    @rickdlewis

    I just wanted to give some feedback on what I have experienced while trying to figure out the issues with links not working.

    first, you can not have group forums activated and use this at the same time. Atleast I couldn’t. The base for the group forums is FORUMS. Note the S so if you try and use Forums for your page and/or forum base you are not going to get the BBP forum.

    I had to turn the global group forum directory off and use forum as the base in order to get the links pasted the forum index page to work. Otherwise all links redirected to my homepage.

    Currently though I have this structure —

    index page – using shortcode

    http://crosseyedgaming.com/forum/

    the other links have a double forum/forum

    http://crosseyedgaming.com/forum/forum/welcome-committee/

    If I remove the forum slug it changes those links to

    http://crosseyedgaming.com/forum//welcome-committee/

    Outside that things seem to be working ok. Probably need to clean up the look a little.

    How do I get the widgets working on these pages so I can list recent posts and so on?

    One last question, is using the alternated page template and theme support a better option?

    I appreciate the help.


    Rick Lewis
    Member

    @rickdlewis

    I just wanted to note that the only way this works for me is to go into settings and add a forum base and check the include base before slugs box.

    If don’t check that box i end up at my homepage.

    When I do check that box and have the fields under it empty which it says will use defaults the urls come out like this –

    http://crosseyedgaming.com/forums//welcome-committee/

    Note the double // which creates a page not found.

    When I add slugs http://crosseyedgaming.com/forums/forum/welcome-committee/

    and they all go to the homepage.

    If I remove the check I can get to my subpages for the forum but the index page will not show. It goes to one of the created forums frontpage and in the title says – Crosseyed Gaming | Blog versus — Crosseyed Gaming | Forum

    It seems to me there is something going wrong within the settings for the slugs and rewrites either in the plug in , my site or both.


    Rick Lewis
    Member

    @rickdlewis

    The instructions r-a-y mentioned above worked.

    I had at one point removed the Forum Base blug altogether. Putting it back as forum and creating a forum page using the shortcode created the page for the index.

    Would like to know what other shortcode options there are??

    thanks for the help. Good to have a forum index now to start building on.

    http://crosseyedgaming.com/forum/


    Rick Lewis
    Member

    @rickdlewis

    ” Don’t move anything, don’t add anything, and use shortcodes and adjust your CSS as needed. “

    This is where I am at right now.

    I thought I would try [bbp-forum-index]. I created a page Forum and used that code. I still got the same page as I did all other ways. Goes directly to one of the forums and then list the other forums below it. Says Blog archive across the top.

    Now when I create /forums (note the s) that page goes to my home page and not a page at all.

    I did a re-save of the permalinks and so on but still not seeing a forum homepage of any kind.

    I can only guess that I have something crossed up somewhere beings others have this working.

    EDITING __ I did not see the above posts prior to posting this. Going to review and make a change on my site and see how it goes. Thank you for the help.


    Rick Lewis
    Member

    @rickdlewis

    yes I went through the process and when leaving it all be it wasn’t done properly so I started adding things back.

    No matter what I seem to do I am not getting the Forum index page to show as others are. Has to be me not doing it right.


    Rick Lewis
    Member

    @rickdlewis

    Ok well, I will probably go insane with this. I started from the beginning and have not moved anything or created a page.

    What I have is the following –

    http://crosseyedgaming.com/forum/

    That surely is not the correct forum homepage.

    Due to my theme should I be moving files or creating a page?

    Both?

    Something else?

    It’s a great thing but I can’t open it up and use it looking like that and no navigation to and from the other forums.


    Rick Lewis
    Member

    @rickdlewis

    @jjj you mentioned above that you don’t need to create a Forums page?

    From older posts I thought that was the only way to make this work and with that I also moved things around and added in the code you mention to my functions.php. While things seem to show up they do so just like CrownofMars with the Blog Archive thing.

    I too had the forums/forum thing and believe I killed that by deleting all the slugs listed in the settings and saving.

    My issue is I can’t get to my main Forum page at all. I keep getting either redirected to the stupid Group forum directory or the second forum I made and it’s noted a Blog Archive.

    I think I am going to back track a little and retry things without moving template files around and so on. Maybe that was needed in an earlier version?

    I would love to get my forum page looking like this http://archaudio.org/forums/. That one looks nice. I haven’t achieved that yet.


    Rick Lewis
    Member

    @rickdlewis

    yes copied. I am using a child theme. where do I add that code?


    Rick Lewis
    Member

    @rickdlewis

    i thought it was miller time but no dice. I moved the page template into my themes folder which I had not done and create a forum page.

    http://crosseyedgaming.com/forum/

    That gave me what looks more like a forum although I had that look within my theme at one point.

    So looks good and off I went clicking on one of the forums. None of the links work!

    I am sure this has to do with the setting as I believe I put forum or something in for the base. I notice though changing the slugs kills all the links???

    Is this real?

    That would suck to kill all the links in ones forum but it seems that is what happen. Please confirm if this is the case and if there is a fix.

    Thank you.


    Rick Lewis
    Member

    @rickdlewis

    @anointed it does not work with bp group forums. I learned this from testing and breaking everything twice. Then JJJ confirmed earlier in this post when iasked about it.

    I had setup groups with forums and integrated with bbpress. Work and looked nice. Converted by vbulletin sitr to phpbb the bbpress. Destroyed my integrated group forums and while all the data and users were there it looked terrible. No category structure at all. It also deleted all my WP users with the imported ones. Locked me out from admin as well. Not fun.

    Since that I did it two other times with minor changes in how I did it and knowing what was goint to happen. I got the groups back working which for me is something I want for the groups. The forum will be a seperate componet once I get a handle on how to modify the phpbb to bbpress converter. I need it ti not import users. Or do so without killing my wp users.

    Cleaning the forum data prio to import is also on the list. Once done I will use bbp to bbpress converter to make the final connection. That is where I am now with trying figure out the plugin and conversion process.

    I actually tried converting bbpress to bbp with the integrated group forums. Got a page of notices and errors that could fill a novel. Surely I didn’t do it correctly as well as various other factors.

    If we get a little guidance on the category and overall flow of things it will be helpful. I personally can wait to see this thing working on my site as some vbulletin reps were not very kind when I mentioned my move 6 months a go. They said you will never get your data moved and if you did it will never be as good.

    My site is not even close to being up to par but is already better thab it was.


    Rick Lewis
    Member

    @rickdlewis

    @Fartlek Our move comes based on BuddyPress and the issues within the company behind vbulletin. I ran a large (50,000 member) gaming community but was not part of the ownership there. After many years of frustration with their lack of doing anything for the gamers especially on their website I was going to just walk away. A friend asked about doing a new venture which was to be based on a social network for gamers. Not a new idea but there wasn’t and isn’t from what I see anything like the entire organization which we have. What I mean by that is, the ones out there are just housing for tons of gamers versus being a true social network and community with connections to those gamers direction on their platforms they play on. We also sponsor teams for PRO events as well as have classes for leadership to help train people to be good leaders of large groups of people.

    I am in fact a member at WPMUDEV and it’s also because of them that I decided to make the move. they have been very helpful and without their support I probably am sitting on a very ugly forum based vbulletin site wishing I had something better.

    It has been a learning experience for sure with making this move. It’s still not done and may never be perfect but as I learn the capabilities of WP, buddypress, BBPRess and everything else around them, it does get easier and close to that utopia we are trying to achieve.

    The support on this site and the other WP sites is also a great thing!


    Rick Lewis
    Member

    @rickdlewis

    @Fartlek Our move comes based on BuddyPress and the issues within the company behind vbulletin. I ran a large (50,000 member) gaming community but was not part of the ownership there. After many years of frustration with their lack of doing anything for the gamers especially on their website I was going to just walk away. A friend asked about doing a new venture which was to be based on a social network for gamers. Not a new idea but there wasn’t and isn’t from what I see anything like the entire organization which we have. What I mean by that is, the ones out there are just housing for tons of gamers versus being a true social network and community with connections to those gamers direction on their platforms they play on. We also sponsor teams for PRO events as well as have classes for leadership to help train people to be good leaders of large groups of people.

    I am in fact a member at WPMUDEV and it’s also because of them that I decided to make the move. they have been very helpful and without their support I probably am sitting on a very ugly forum based vbulletin site wishing I had something better.

    It has been a learning experience for sure with making this move. It’s still not done and may never be perfect but as I learn the capabilities of WP, buddypress, BBPRess and everything else around them, it does get easier and close to that utopia we are trying to achieve.

    The support on this site and the other WP sites is also a great thing!


    Rick Lewis
    Member

    @rickdlewis

    @JJJ yeah for sure something has gone a muck there. Going to back track a bit. I started by going through the posts here and I keep seeing mentioned of setting up a page using a specific template. I don’t have that option when I setup a page and was sure I saw also somewhere that it was no longer needed. I did setup a page – Forums but without a template for it I doubt it is going me any good.

    Also as James is asking above, I wouldn’t mind a little 411 on how the categories are suppose to work as well.

    Coming from Vbulletin world for many years I was thinking category would be above the forum such as — Community Forums – Gaming forums — General Forums and so on. Then you setup Forums under those which house the topics. Doesn’t seem like it flows that way though.

    Going to put some time into getting this corrected today as my users are finally making their way over from the old site and after years of having a forum many of them are lost.

    Thanks for all the help and support.


    Rick Lewis
    Member

    @rickdlewis

    @jjj thanks for that tip on the buddypress group forum thing. Was thinking of some wild paradise thing where I turned on the plug in and it pulled everything from everywhere and all was well in forum world. (yes I know that is a fantasy but one can dream).

    I just went in and created a forum. It showed up so I created a second and a third. I thought I would be smart and try using the category. That seemed to mess up the main forum page and at some point I had topics stacked on top of what should have been my top forums. I removed the categories altogether and now have a bunch of forums with some topics in it. The front page – http://crosseyedgaming.com/forum/ surely is not showing like it should be or like it did at one point.

    I have to be missing something as although it wasn’t super pretty there was a nicer looking main page then what I have now. Just don’t know how to get back to it. Note also those Forums all say edit this entry. I checked many times and re-saved them as Forum. I put one of them under another one to see if that would get it back and that is the one showing now at the top of the page.

    Now, I never moved any template files or created a forum page or anything like that. Actually I tried that forum page thing and it didn’t do a thing for me.

    What is it I am not doing correctly?


    Rick Lewis
    Member

    @rickdlewis

    ok so from there how would you get the group forums which is integrated with bbpress merged together? Plug in seems to work well though on its own. I have a custom theme and it seems ok with that.


    Rick Lewis
    Member

    @rickdlewis

    tooltrainer – I will trade you that for the 50 or so notices and errors I got trying to run the converter. lol… It’s probably my error though. I do have forums so the plug in is working but getting my group forums and bbpress stand alone going isn’t getting there yet.


    Rick Lewis
    Member

    @rickdlewis

    can you give me the dummy version of what I need to change in the two places you mentioned?

    I thought I did it correctly and tried running the script. What I got was a page of errors and notices. Referencing a few plugins and some other WP files. Way to long to paste here and probably irrelevant to the converter itself.

    Where is the file need to be saved and run from?

    And then the other changes to it prior to running?

    If I get this working I will write a novel on taking a vbulletin site to wordpress with bbpress. It will be long and partially a nightmare story with happy ending!

    Thank you for your help.


    Rick Lewis
    Member

    @rickdlewis

    can you give me the dummy version of what I need to change in the two places you mentioned?

    I thought I did it correctly and tried running the script. What I got was a page of errors and notices. Referencing a few plugins and some other WP files. Way to long to paste here and probably irrelevant to the converter itself.

    Where is the file need to be saved and run from?

    And then the other changes to it prior to running?

    If I get this working I will write a novel on taking a vbulletin site to wordpress with bbpress. It will be long and partially a nightmare story with happy ending!

    Thank you for your help.


    Rick Lewis
    Member

    @rickdlewis

    I am going to try and see if this works and need some guidance for the paths to input into the file.

    I do have WP in the root directory.

    I have bbpress standalone in /forums

    I do also have buddpress integrated into bbpress with the group forums working.

    First is that all going to cause me great pain or is this going to be a painless thing to run?

    I appreciate your hardwork and help.

    Thank you.


    Rick Lewis
    Member

    @rickdlewis

    I am going to try and see if this works and need some guidance for the paths to input into the file.

    I do have WP in the root directory.

    I have bbpress standalone in /forums

    I do also have buddpress integrated into bbpress with the group forums working.

    First is that all going to cause me great pain or is this going to be a painless thing to run?

    I appreciate your hardwork and help.

    Thank you.


    Rick Lewis
    Member

    @rickdlewis

    I am thinking I want to give this thing a whirl. I got the zip downloaded, change the name and uploaded the directory. Currently I have a standalone bbpress forum with the BP group forums integrated. I have activated the plugin and see my options in the admin panel. I added a forum which I only see the Title for at the /forum page. I know there was a converter from the stand alone but can’t recall where that thread is or what to do with it once I get it.

    Is there a quick what to do next somewhere or is it to early on to be asking for some help getting it setup?

    I will point out that I am come from the hell of vbulletin world and converted everything to phpbb then to bbpress on my tests sites and now looking to finish it all off with this plugin. Truly not something I want to ever have to do again!

    Thanks for all the help and support here and elsewehre on these forums.


    Rick Lewis
    Member

    @rickdlewis

    @Fartlek the crazy thing was my styling issues were only in the default themes. When I used another theme things seemed to fit properly. I have since added one or two and been messing around with them. The forum itself is not seen by anyone right now outside the built in forums with the groups. I am working on some other things to get data into the forums prior to linking it with the main site and of course also looking into the new plugin as an option.

    I am going to look up the site you mentioned for other themes. Thanks.


    Rick Lewis
    Member

    @rickdlewis

    @Fartlek the crazy thing was my styling issues were only in the default themes. When I used another theme things seemed to fit properly. I have since added one or two and been messing around with them. The forum itself is not seen by anyone right now outside the built in forums with the groups. I am working on some other things to get data into the forums prior to linking it with the main site and of course also looking into the new plugin as an option.

    I am going to look up the site you mentioned for other themes. Thanks.


    Rick Lewis
    Member

    @rickdlewis

    I am finally getting my forums back on track after a major issue with the group forums. I still need help with styling as the default theme does not seem to work for me unless it is suppose to look like crap. The link to my site is in the post above this one as I didn’t want to post it again. I can’t post an image of it or I would do that as well.

    Can someone help me get this thing looking the right way?

    Thanks.

Viewing 25 replies - 1 through 25 (of 38 total)