Michael Adams (mdawaffe) (@mdawaffe)

Forum Replies Created

Viewing 25 replies - 26 through 50 (of 335 total)
  • Miraploy, thanks!

    I’ve started a trac ticket to keep track of this bug.

    http://trac.bbpress.org/ticket/745

    I’ve started a trac ticket to keep track of this bug.

    http://trac.bbpress.org/ticket/745

    Miraploy,

    What works? Overwriting the files?

    From lasir’s config file, it looks like a common theme may be that the error message says:

    Access denied for user 'thechamp'@'localhost' (using password: NO)

    but the config file specifies a different user: thechamp_risal. (Can the others who are experiencing this problem please post the DB details of their setup as well?).

    This often indicates that the specified user doesn’t exist (or possibly doesn’t have access) in the specified database.

    Lasil, I’m not sure what this post is showing. Are you looking at users in the wrdp1 database or in thechamp_wrdp1?

    The other commonality here may be that all of you are using the mysqli extension. It could be that there’s a bug there that’s only now popping up since most people use the mysql extension.

    You can try overwriting /bb-includes/db-mysqli.php with /bb-includes/db.php (so that you have two copies of db.php) to see if that helps.

    They can be in the same database, and it won’t cause any problems. They can be in different databases too. bbPress will work in either situation, though it’s easier to set up if bbPress and WordPress share the same database.

    It sounds like like your WordPress tables are in a different database (with a different database name and password).

    bbPress can handle that situation too, but you need to help it a bit more. You need to define:

    USER_BBDB_NAME, USER_BBDB_USER, USER_BBDB_PASSWORD, and USER_BBDB_HOST.

    (with your WordPress database name, username, password, and host, respectively) just like you defined the regular BBDB_ database settings.

    The bb_users table will not be created automatically. You’d have to copy it and the user meta tables from the WP ones.

    The counts problem is strange, and not one I’ve heard of before. Do you any plugins installed?

    Thanks for letting us know about the bug. It will be fixed in the next release.

    http://trac.bbpress.org/ticket/741

    Done. It may take an hour or so for the changes to propagate. Let me know (by email, since I’ll be traveling) if it still doesn’t work by tomorrow.

    bbPress should be magic_quotes agnostic. I’ll do some tests to see If I can pin down the problem.

    Are you loading any other scripts at the same time (WordPress, anything else)? Any plugins?

    under_title looks like a pretty lame hook; I doubt you can trust it’s existence in every theme and it may get removed entirely in some later version of bbPress.

    If you need to add content to a topic page there, I’d just edit your custom theme.

    I want to be in the cool kids’ club too!

    Oops – forgot the addy (but I think you have it?)

    mikea TA turbonet TOD com

    You can use the script attached to that ticket: http://trac.bbpress.org/ticket/671

    It will only work once you upgrade to the next version of bbPress (it’s not out yet :) ) or if you’re running the “unstable” code in the repository.

    Follow the instructions in the last comment.

    Make a new file in your my-plugins/ directory with the following code in it. Then activate the plugin in your bbPress’ admin panels.

    <?php
    /*
    Plugin Name: No ?replies
    Description: Get rid of the ?replies=# ugliness in topic links
    Plugin URI: http://bbpress.org/forums/topic/getting-rid-of-replies
    Author: fel64
    Version: 1.0
    */

    remove_filter( 'get_topic_link', 'bb_add_replies_to_topic_link' );

    ?>

    What bbPress and WordPress plugins do you have installed?

    I haven’t been able to reproduce this on my machine (no plugins for either).

    Change it in your template.

    Find your theme’s logged-in.php file. Look for bb_profile_link() and change it to

    bb_profile_link( "Use my text instead" );

    (If you’re using the default theme, first copy the bb-templates/kakumei/ directory to a new directory called my-templates/my-theme/, activate that new theme from the Presentation admin panel and edit those files instead).

    Tickets 672, 673 and 674 (linked above) should be fixed in the next release.

    Thanks for reporting the bugs!

    Try removing line 27 and/or line 28 of

    http://pastebin.ca/582386

    The bozo field when editing a profile still is not a checkbox, but is otherwise fixed.

    If you go back to http://pastebin.ca/578041 as your main .htaccess file, do you still get Server Errors?

    quigley05,

    Try http://pastebin.ca/582386 as your main .htaccess file and delete the .htaccess file in the bbPress directory.

    To help us debug this can you please follow these steps?

    1. Go to Content -> Forums in your admin panels. Are the forums in a flat list or a hierarchical structure?
    2. Click “Edit Forum Order” button
    3. By dragging and dropping, make something a subforum of something else and move the top forum to the very bottom.
    4. Click “Save Forum Order” button.
    5. Go to some other admin page.
    6. Go to Content -> Forums again. Click to it. Do not hit your browser’s back button. Do the forums appear in a flat list or in a hierarchy? Is the forum you put at the bottom of the list still at the bottom of the list?
    7. Go to your site’s front page. Is there hierarchy? Is the forum you put at the bottom still at the bottom?
    8. Go to a topic. Go to the “Move this topic” dropdown box at the bottom of the page. When you open up the dropdown are the forums listed hierarchically? Is the forum you put at the bottom still at the bottom?

    Also, what browser are you using?

    I know that’s a lot, but it will help figure out the problem faster.

    EDIT: Make sure you change the order of things by dragging and dropping the little [drag] doohickeys. And remember to hit “Save Forum Order”

    Here’s a couple things to try.

    Disable all your plugins.

    Set $bb->mod_rewrite = false; in your bbPress’ config.php.

    After you changed the hierarchy in the admin section, did you click the “Save Forum Order” button?

    I don’t believe this is a plugin issue. It’s possible it’s a theme issue. You may have to change some of the markup and CSS of your theme to get it to work correctly. Check out (can probably just copy and paste) the markup in /bb-templates/kakumei/front-page.php:

    <?php if ( bb_forums() ) : ?>
    <h2><?php _e('Forums'); ?></h2>
    <table id="forumlist">

    <tr>
    <th><?php _e('Main Theme'); ?></th>
    <th><?php _e('Topics'); ?></th>
    <th><?php _e('Posts'); ?></th>
    </tr>
    <?php while ( bb_forum() ) : ?>
    <tr<?php bb_forum_class(); ?>>
    <td><?php bb_forum_pad( '<div class="nest">' ); ?><a href="<?php forum_link(); ?>"><?php forum_name(); ?></a><small><?php forum_description(); ?></small><?php bb_forum_pad( '</div>' ); ?></td>
    <td class="num"><?php forum_topics(); ?></td>
    <td class="num"><?php forum_posts(); ?></td>
    </tr>
    <?php endwhile; ?>
    </table>
    <?php endif; // bb_forums() ?>

    You’ll then need some CSS too:

    #forumlist tr td div.nest {
    padding-left: 2.5ex;
    }

    Also, the URLs will not look like example.com/forum/sub-forum; the URLs do not currently reflect the hierarchy.

Viewing 25 replies - 26 through 50 (of 335 total)