Skip to:

Hierachical forums do not seem to work.

  • rosebud


    Has anyone had any problems with the hierachical forums? I do not see all my forums listed in the “parent” dropdown. If I drag the particular forums I want to be child of some forum they seem to fit, however, when I see the frontpage, they are listed as if they were top level forums. They even appear as top level forums at the top: site >> forum. And not as intended: site >> forum >> sub-forum

    I will try deactivating some plugins (I have the private and restricted access plugins) in case they are related, and report back.

Viewing 17 replies - 1 through 17 (of 17 total)
  • After you changed the hierarchy in the admin section, did you click the “Save Forum Order” button?

    I don’t believe this is a plugin issue. It’s possible it’s a theme issue. You may have to change some of the markup and CSS of your theme to get it to work correctly. Check out (can probably just copy and paste) the markup in /bb-templates/kakumei/front-page.php:

    <?php if ( bb_forums() ) : ?>
    <h2><?php _e('Forums'); ?></h2>
    <table id="forumlist">

    <th><?php _e('Main Theme'); ?></th>
    <th><?php _e('Topics'); ?></th>
    <th><?php _e('Posts'); ?></th>
    <?php while ( bb_forum() ) : ?>
    <tr<?php bb_forum_class(); ?>>
    <td><?php bb_forum_pad( '<div class="nest">' ); ?><a href="<?php forum_link(); ?>"><?php forum_name(); ?></a><small><?php forum_description(); ?></small><?php bb_forum_pad( '</div>' ); ?></td>
    <td class="num"><?php forum_topics(); ?></td>
    <td class="num"><?php forum_posts(); ?></td>
    <?php endwhile; ?>
    <?php endif; // bb_forums() ?>

    You’ll then need some CSS too:

    #forumlist tr td div.nest {
    padding-left: 2.5ex;

    Also, the URLs will not look like; the URLs do not currently reflect the hierarchy.



    Having the same problem here, and it’s not a theme issue. I updated my front-page.php to no avail, and switching back to the kakumei theme has no effect. Have not played with any plugins yet (have Forum Restriction and a few others). Hopefully someone will have an answer before I have time to check this out further.

    To help us debug this can you please follow these steps?

    1. Go to Content -> Forums in your admin panels. Are the forums in a flat list or a hierarchical structure?
    2. Click “Edit Forum Order” button
    3. By dragging and dropping, make something a subforum of something else and move the top forum to the very bottom.
    4. Click “Save Forum Order” button.
    5. Go to some other admin page.
    6. Go to Content -> Forums again. Click to it. Do not hit your browser’s back button. Do the forums appear in a flat list or in a hierarchy? Is the forum you put at the bottom of the list still at the bottom of the list?
    7. Go to your site’s front page. Is there hierarchy? Is the forum you put at the bottom still at the bottom?
    8. Go to a topic. Go to the “Move this topic” dropdown box at the bottom of the page. When you open up the dropdown are the forums listed hierarchically? Is the forum you put at the bottom still at the bottom?

    Also, what browser are you using?

    I know that’s a lot, but it will help figure out the problem faster.

    EDIT: Make sure you change the order of things by dragging and dropping the little [drag] doohickeys. And remember to hit “Save Forum Order”



    Ran out of time to fuss around with it, but I did just run through your checklist, mdawaffe.

    1. flat

    2. clicked

    3. can’t make a subforum without anything in the dropdown list, but made a new forum instead

    4. saved

    5. wandered around the admin a bit

    6. clicked it, flat list still, and forum I moved to the bottom was still at the bottom

    7. forum I put at bottom is still at bottom

    8. “Move this topic” dropdown box filled only with the name of the current forum

    Using Firefox, but checked in IE7 with the same results

    After wandering around a bit I went back to it one last time to find one of my forums now appearing in the dropdown box in the admin. Something budged, so thanks for the steps! Will have to nudge things again tomorrow when I have time, and hopefully the rest will appear.



    Culprit – Forum Restriction plugin

    Ah. I just got an email notice from my private forum. The test forum I created to try and get some heirarchy going on is visible but creating a post did not seem to work and left me with a 0 post count (the posts appeared in one of my private forums instead).

    The Forum Restriction plugin doesn’t work with in that the forums are not visible but still exist in the database.

    I deactivated the plugin and deleted our sensitive posts. Voila, all the forums appear in the dropdown menus and the forum admin appears heirarchal.

    That’s it for me tonight, but at least I’m pretty sure that’s the source of the problem now.



    Well, this is what I’ve got…

    1. Are the forums in a flat list or a hierarchical structure? Yes, they are. The ones I’ve already dragged to be sub-forums.
    2. Already done
    3. Already done
    4. Already done
    5. Go to some other admin page. Yes.
    6. Go to Content -> Forums again. The forums still appear in a hierarchy. Everything is fine so far.
    7. Go to your site’s front page. Is there hierarchy? Nop. Is the forum you put at the bottom still at the bottom? Yes.

    At this point I thought this had something to do with the css because the xhtml structure (front-page.php) was indeed updated. I checked the css and I found I had forgotten to put the #forumlist tr td div.nest . Done that. Checked… but nothing. I refreshed, cleared cache and nothing.

    I then deactivated the Forum Restriction plugin and voilá. The forums where nested. In the admin section, in the “Forum Parent” dropdown now everything was fine. All the forums listed. It was strange since I have already deactivated the plugin before without results. In the front end it was explained by the missing css, but in the backend I really don’t know.

    Thanks mdawaffe for your time.

    ps: I tried activating the plugin again, and now I see the front page list of forums in hierachy. Weird. However, when I acces the parent forum, there is a table at the bottom with the name Subforums, but it is empty. When the plugin is deactivated the list is NOT empty. So it is apparently that plugin.



    Ok, guys. I got the same problem.

    For a new topic to appear in a drop-down list just click on “Forums” link to update current page and drop-down list will be updated. Hope, this issue will be resolved in next release.



    Forum Restriction plugin requires the Display Name plugin to work. Display Name plugin did not come with a plugin header, so add one and it will all function properly and heirarchy will return to normal.

    So, problem solved, save for Forum Restriction still not appearing in the admin so you can add/remove users.

    Look at the Forum Restriction plugin post for info on how to fix the admin page and the keymaster problem.


    Some more data points. I’m running a brand-new install with no plugins.

    – When creating a new forum, declaring an existing forum to be its parent does not automatically position it in the hierarchy. I have to go through the “Edit Forum Order” process to drag it into place.

    – New forums do not appear immediately in the “Forum parent” dropdown on the forum creation page, but if I go do other things and return, they get there eventually.

    – Most troubling: When I post a new topic directly in a top-level forum, it does not appear there, but rather in the last of its subforums. That is, if I have forum A with subforums A1 and A2, forum B with subforums B1 and B2, and forum C, and I try to post a new topic to top-level forum B, it will actually get posted to subforum B2.

    The last strikes me as a serious bug.

    Sam Bauers



    The first two problems are fixed with a refresh of the page, not ideal I realise, but it is merely a display issue. If you add this to Trac it will be addressed in time.

    Can anyone else confirm or deny the third issue that riddle has posted?

    Not repeatable for me. Topics made since .8.2 in my active forums on Linux / php 4.4.4 I think have been made by a direct call to bb_new_topic(), and under xampp topics made normally also do not have this problem.

    Riddle: do please add these to trac if you haven’t already. Login is the same as here.

    Okay, I posted my issues to Trac. I’m a Trac newbie, so please be gentle if I broke conventions somehow. Feel free to correct or add to my descriptions:

    Aha, more info about the post-to-subforum error. Details are in Trac at but it appears that Kakumei may be scribbling on a global $forum_id variable deep in the bowels of bb-templates/kakumei/forum.php.

    Fel64, when you couldn’t repeat the problem, were you using Kakumei?

    I’m such a bbPress newb that I don’t know whether Kakumei falls outside the purview of bugs we should be reporting through Trac. Suggestions welcome.

    No, to be fair I wasn’t. Looking deep into its bowels I can’t see anything that would set $forum_id, although that could be an oversight.

    Kakumei does go into main trac. :)

    Tickets 672, 673 and 674 (linked above) should be fixed in the next release.

    Thanks for reporting the bugs!

    Thanks, mdawaffe!

Viewing 17 replies - 1 through 17 (of 17 total)
  • You must be logged in to reply to this topic.
Skip to toolbar