Skip to:

Getting a Fatal Error When Viewing BP Group Forum Topic

  • I’m running the latest version of bbpress with a BP 1.5 installation. Love, love bbpress!!!

    I’m using a combination of bbpress central forums and BP group forums. I was having issues getting the BP group forums to work after installing/uninstalling bbpress, so I deactivated the BP group forums and planned on just using the bbpress forums. Then I saw a nifty little selection in bbpress to “let BP Groups have their own forums” so I turned that on and got group forums back for BP! Back on track and cooking with gas! (Or so I thought.)

    Everything works great on the bbpress forums side, except for Favoriting (yes new verb) and Subscribing to topics, (well they work if I right-click the links and open in a new tab or window–not a biggie right now).

    The two biggest issues I have are on the BP groups forums side. (1) I get the following error when trying to view a topic:

    “Fatal error: Call to undefined method stdClass::have_posts() in /home/content/46/7943846/html/wp-content/plugins/bbpress/bbp-includes/bbp-reply-template.php on line 168”. (Funny enough the Favorite and Subscribe options work really well on this broken screen.) I can post new topics just fine.

    (2) When I post a topic in a BP Group forum, it shows up in the main activity feed and in my personal activity feed, but not on the activity feed for the group.

    I’m using Suffusion along with the Suffusion BP and Suffusion bbpress Packs, but the issues persist even when I use the default BP theme. I deactivated my plugins one by one just to rule them out and no change in the result.

    Reactivating Group Forums on the BP side and selecting “use existing bbpress install” gives me 404 errors and no BP forums at all. Don’t know what to do. Well I could just not use the BP groups forums. OR I could sledgehammer the whole install and start from scratch. Would like to avoid either of those options if possible though. The site is and test user is username: *** password: ***

    • This topic was modified 11 years, 7 months ago by John James Jacoby. Reason: Posting login information is a bad idea
Viewing 2 replies - 1 through 2 (of 2 total)

  • Aron Prins


    Quoting JJJ:

    These errors have come up a few times here recently. It’s a regression in a way, but it’s also the themes doing-it-wrong, and using bbPress loops outside of their intended purposes. My fault for not documenting them more in-depth, or protecting the data from being used incorrectly.

    It’s most likely because of the themes using bbp_has_replies() outside of the main query loop. More helpful than the error itself would be the backtrace of what actually caused the error to occur.”

    Call to undefined method stdClass::have_posts()

    PS: Looks like a theming/functions.php issue to me 😉

    Thanks Aron!

    I could have sworn I tried to pull up those posts using the default BP theme and had the issue but I just tried again and had no issue. (my kid just rolled her eyes at me). Not a good move to lose one’s mind in front of witnesses–especially if they are the pint-sized, know-it-all type! 🙂

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.
Skip to toolbar