Skip to:

Call to undefined method stdClass::have_posts()

  • Jeff


    I am using:
    Wordpress Version 3.4.1
    bbPress Version 2.1
    BuddyPress Version 1.5.6
    Tersus Theme Version 1.3 (

    I created a new Group, and then posted a new topic in that group. This is where the error is being thrown.

    Here is a screenshot of what’s happening

    Error says:

    Fatal error: Call to undefined method stdClass::have_posts() in /home/…/…/wp-content/plugins/bbpress/bbp-includes/bbp-reply-template.php on line 168

    Notice also, that the page title being displayed is from one of the WordPress posts that came with auto-importing dummy data for the theme.

    I know a link to the site would help, but I am working with a client who’s not comfortable getting the link out before site-live time. So, sorry about that.

    I asked for help from WordPress Forum support, and was told that this was most probably a theme compatibility issue. So I went to the theme’s support forum.

    Last night, the theme’s author/s were helpful enough to guide me through what I assume are the usual stuff in troubleshooting this kind of stuff.

    Here are the things I’ve done so far:
    1. Disabled all plugins apart from bbPress – this resulted to the forum giving me a 404
    2. Enabled BuddyPress – this brought back the forums, but with the same issue
    3. Emptied all sidebar widgets that have to do with the theme.
    4. Used the other theme package (bbPress Twenty Ten).
    5. Deleted the function referenced in the error. Led to some new error. This was a desperate, illogical attempt on my part so i undid that.
    6. Deleted the wordpress post being shown in the page title. It just displayed the title of the next wordpress post in line.
    Note: every time i check to see if that fixed it, i do a clear-cache-reload, just so i’m sure nothing in cache was giving me this headache.

    I really hope someone could help out.. Has anyone seen this kind of error ever been documented elsewhere?

Viewing 5 replies - 1 through 5 (of 5 total)

  • briantoronto


    Had the same issue. I rolled back the plug-in to 2.0.3 and it fixed the issue for me.




    Unfortunately, I came upon this issue upon installation of bbp 2.1

    John James Jacoby


    These errors have come up a few times here recently. It’s a regression in a way, but it’s also the themes doing-it-wrong, and using bbPress loops outside of their intended purposes. My fault for not documenting them more in-depth, or protecting the data from being used incorrectly.

    It’s most likely because of the themes using bbp_has_replies() outside of the main query loop. More helpful than the error itself would be the backtrace of what actually caused the error to occur.



    I have the same issue.

    All i need to do is to show all forums with topics on main page. Here is my archive-forum.php

    When i try to use BB_Query i get error.
    When i try to use shortcode i get error.

    		<a href="" title="" rel="nofollow">
          //$forum_id = bbp_get_forum_id();
          //echo do_shortcode("[bbp-single-forum id=$forum_id]"); 
          if ( !bbp_is_forum_category() && bbp_has_topics() ) :  
            bbp_get_template_part( 'loop', 'topics-custom' );        



    And as you can see i can’t even post code part. I have tried PRE + your CODE button.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.
Skip to toolbar