Skip to:
Content
Pages
Categories
Search
Top
Bottom

Emails being sent to noreply@www.mysite.com for subscription emails


  • rossagrant
    Participant

    @rossagrant

    Hi guys,

    I’m not sure exactly why this is happening, but I’m guessing it’s due to the way subscription emails are sent out and the no-reply address grabbing the site info incorrectly.

    Am I right in assuming that when there are subscriptions to a forum/ topic, they now get sent out as one email with everyone Bcc’d?

    Anyway, when someone posts a new topic on my site – and I guess there are subscribers – I say guess, as I don’t think there is a way of us seeing subscriber numbers – an email must get generated to notify them.

    Well I’ve been getting non-deliverable emails back at me saying that one of these emails was sent to noreply@www.mywebsite.com and that the address doesn’t exist.

    Well with the www. in there it won’t exist.

    Why would BBPress be trying to send an email to a noreply address in the first place?

    Could someone explain – it’s probably obvious, so sorry in advance!

    Thanks so much for your time!

    Ross :)

Viewing 25 replies - 1 through 25 (of 27 total)

  • rossagrant
    Participant

    @rossagrant

    Anyone else seeing this folks?


    rossagrant
    Participant

    @rossagrant

    Just discovered that it looks like this is for the email alerts sent out when you are subscribed to an entire forum, not just a topic.

    I’ll post a TRAC ticket, see if you guys can recreate it.


    jgjh151
    Participant

    @jgjh151

    Having same issue. Was wondering what was filling up deferred mail log. noreply@www.domain.com. Should not even be sending to/from noreply@ by default.


    knowmoreit
    Participant

    @knowmoreit

    I have the same problem. Any solution to this?


    brhahlen
    Participant

    @brhahlen

    I’m seeing the exact same problem…
    Has there been any resolution to this?


    crazedsanity
    Participant

    @crazedsanity

    It looks like the code, by default, sends the message to “noreply@” followed by the domain, with all the intended recipients in the BCC field. I end up getting 3-6 bounces per message due to the “delayed” notifications. It thought it would go away after someone (else) had subscribed to the topic, but that is simply not the case.

    The code needs to be only slightly more sophisticated:
    1.) it should NOT send an email if there are no recipients (because… logic)
    2.) the “from” address should be “noreply@<domain>” or otherwise configurable

    I’ll see if I can work up a patch if I’ve got sufficient free time (unlikely, but I’ll try). Anybody know the who/how/where of it?


    jturet
    Participant

    @jturet

    I have the same issue.


    Matthias70
    Participant

    @matthias70

    You are not alone 😉
    I started a topic a few days ago, with the same problem.
    https://bbpress.org/forums/topic/noreplydomain-com/

    My problems started with one of the new bbpress versions.
    2.5.4 was working fine. 2.5.5 or 2.5.6 had the noreply error…


    Robkk
    Moderator

    @robkk

    @matthias70

    this should be fixed in latest bbPress unless you are using a plugin that is making the subscriptions have issues.

    go through the general troubleshooting steps for common issues in this link

    https://bbpress.org/forums/topic/before-posting/


    xenous
    Participant

    @xenous

    you can configure the noreply email simply with:

    
    add_filter('bbp_get_do_not_reply_address','my_bbp_no_reply_email');
    function no_reply_email(){
        $email = 'noreply@yourdomain.com';
        return $email;
    }

    bbPress uses BCC for sending subscription emails and the noreply email is used as to field. This is for better hardware (cpu and memory) usage as if you were to loop each user subscribed to content it would be troublesome.
    you can change that default to email address as well with :

    
    add_filter('bbp_subscription_to_email','my_bbp_subscription_to_email');
    function my_bbp_subscription_to_email(){
        $email = 'noreply@yourdomain.com'; // any email you want
        return $email;
    }

    I hope this helps.


    jturet
    Participant

    @jturet

    I have a new issue where emails are sent to noreply@domain.com and NOT BCC’d to the proper recipient. All notifications are simply sent to noreply.

    Also I am using Easy WP SMTP


    jturet
    Participant

    @jturet

    The only email header being set is the From name.


    jturet
    Participant

    @jturet

    After some more testing this only appears to be an issue when a single account is replying to a topic that they have created and/or are the only individual subscribed to it. I guess this makes sense because you would not want to receive an email notification of your own posts, however it does not make sense that an email is still being generated. It may be a worthy modification to prevent emails being sent to noreply if there is no bcc header set.


    Robkk
    Moderator

    @robkk

    @jturet

    Also I am using Easy WP SMTP

    see if disabling this plugin would fix the issue.


    jturet
    Participant

    @jturet

    Problem Seems to have resolved itself.


    Robkk
    Moderator

    @robkk

    @jturet

    did you disable the SMTP plugin or did it magically just work again??


    jturet
    Participant

    @jturet

    I messed with many things over the past couple of days. The SMTP plugin is still in use, I unfortunately cannot pinpoint what fixed the problem, but it does seem to be resolved. Sorry I could not be more helpful.


    RobbyMcCullough
    Participant

    @robbymccullough

    Hi all!

    I am having the same issue. I tried using the code snippets provided by xenous (thanks for those), but they didn’t work :(

    jturet, if you could explain anything you tried to resolve this issue, we’d really appreciate it. We’re a bit stumped and SMTP/Mail server issues are beyond any of our expertise here. Thanks!


    xenous
    Participant

    @xenous

    Hello,

    My solution will only work if your SMTP is working fine.

    I am using
    https://wordpress.org/plugins/wp-mail-smtp/
    with mandrill and my forums never has issues. I have 10k+ active members and no hiccups till now


    RobbyMcCullough
    Participant

    @robbymccullough

    Hey all. I wanted to follow up on this in case anyone finds this through searching..

    We found out it was the bbPress Private Replies plugin that was causing this on our setup. This plugin overrides the subscription emails, and it uses it’s own code (that doesn’t remove the www) to generate the noreply email address.

    I am planning to submit a pull request, but you can cowboy code it and fix with this change:

    In bbp-private-replies.php on line 250 use this code:

    $do_not_reply = '<' . bbp_get_do_not_reply_address() . '>';


    Robkk
    Moderator

    @robkk

    @robbymccullough

    if you havent already post this on their plugin support forums , to help other people that might be using the plugin.


    palmdoc
    Participant

    @palmdoc

    Been happening to me lately. Not sure why.
    I use WP Mail Bank for SMTP


    bsilverop
    Participant

    @bsilverop

    Having the same issue here. I just enabled SMTP Postman to fix problems with mail being marked spam or not delivered at all. It works great, but now all bbPress emails that used to work fine are being sent to “noreply@mydomain.com”. I don’t mind a bounce email, but they’re not being delivered to the actual users. Just a single email is being generated with noreply@mydomain.com in the To field and nothing else.


    ericnorthman1992
    Participant

    @ericnorthman1992

    Update corrects this problem by friends. Sen Benimsin izle


    jturet
    Participant

    @jturet

    Glad to hear it, another thing to consider should someone come across this in the future is that I discovered part of the reason some emails were not being sent is that they were being incorrectly filtered as spam by some mail servers.

Viewing 25 replies - 1 through 25 (of 27 total)
  • You must be logged in to reply to this topic.
Skip to toolbar