Skip to:
Content
Pages
Categories
Search
Top
Bottom

bbPress 2.3 now available!

Viewing 25 replies - 1 through 25 (of 80 total)

  • Stephen Edgar
    Moderator

    @netweb

    Congrats and Thanks to all who helped get bbPress 2.3 out the door… Yay :)


    realhood
    Participant

    @realhood

    :)


    premitheme
    Participant

    @premitheme

    I have a problem! Tested the latest official 2.3 version (and rc1) and cannot post topics or replies and always get “ERROR: Are you sure you wanted to do that?”. Creating forums is OK.

    This happened on a fresh localhost installation (MAMP) of WP 3.5.1 and bbp 2.3 using TwentyTwelve theme without any other plugins or themes installed. Attached a screenshot …

    Error when posting topic or reply on bbPress 2.3

    The search function is great BTW, well done! Just hope to find a fix for the mentioned problem as it makes 2.3 useless.


    themattman
    Participant

    @themattman

    I’m getting errors on converting vBulletin to bbPress where it won’t convert tags. Once I “repair”, it says that it fails on converting users, as well as no replies have converted.


    Nashwan Doaqan
    Participant

    @alex-ye

    Congratulations! I used the 2.3 version since a while and it’s a masterpiece :)
    Looking forward to 2.4 …


    AlexiousRahl
    Participant

    @alexiousrahl

    Hello and thanks for the help!

    Two questions for a noob, though: how to enable the search? Also, where is the statistics shortcode? I can’t find it here. http://codex.bbpress.org/shortcodes/

    Thanks again!


    Erlend Sogge Heggen
    Participant

    @sadr

    Thanks so much! Seems to have updated without a hitch (well, see below). Tested the forum search right away and it appears to be working fine, although I’m still aching for those search results to be presented as excerpts.

    I did also find that I had to resave permalinks in order to see posts again, or else I would end up with a “topic not found”. That gave me quite the scare!

    We’ll be checking out those improvements to code posting now.


    realhood
    Participant

    @realhood

    why my search function can’t work
    when I use it,it always jump to the home page.
    (sorry my bad english)


    docchewbacca
    Participant

    @docchewbacca

    Thank you for this update.

    The search function is welcome.

    From what I understand, the ability to set individual access rights to individual forums (discussed here) has not been added with 2.3. Any idea if this will actually come in a future release ? I understood it was not an easy feature, but since this is something I’m waiting to expand the use of forums on my site, I’d like to know if bbPress will include it in a not-too-far future.

    Thanks.


    hlwinkler
    Participant

    @hlwinkler

    Hi,

    The search bar only appears on the page with the /forums/ slug and it doesn’t return any results for strings known to have hundreds of results. Here are my search results for the string “openears” on my forum about the framework OpenEars:

    Search Results

    This is on a site with a Woo theme and WooCommerce FWIW.


    probablynot
    Participant

    @probablynot

    One, I would like to be able to turn off the search. Just hide it without having to muck around with making a theme for bbPress.

    Second, since upgrading, in the Admin area, I can no longer do anything for the forums. The menu over on the left side has no items under the Forums, Topics or Replies headings.


    wildomains
    Participant

    @wildomains

    After the update I couldn’t view topic content on my site but could see it when logged into the admin part for editing. Also, I had to make each topic ‘sticky’ to see it on the forum. I removed the plugin ‘bbPress moderation’ and it was OK after that. This means that I can’t use the moderation plugin so anyone can post a reply. I want to be able to moderate each reply. Is there a solution?

    Thanks


    jezza101
    Participant

    @jezza101

    Great, thanks for the new release. Always exciting to see new bbpress updates :)! Couple of comments from me.

    Search
    I’ve traditionally used Google search to search across my whole site, is there an easy way to switch the new form off? It appears to be forced upon the main forum list page.

    It is also not looking great on my sites main forum page, what’s the easiest way to style this, what can I add to my CSS file to change the look? See here.

    Stats
    For those looking, the Stats shortcode is [bbp-stats], there is also a widget. http://bbpress.trac.wordpress.org/ticket/2052

    Is it possible to style the output?
    Can I control which stats are shown? For example “empty tags” isn’t something I really want to boast about on my forum!


    trip62
    Participant

    @trip62

    Like @realhood, my search box always jumps back to the homepage when you query anything.

    What’s up with that?


    dpmcalister
    Participant

    @dpmcalister

    I have the same issue as @probablynot – his second issue:

    Second, since upgrading, in the Admin area, I can no longer do anything for the forums. The menu over on the left side has no items under the Forums, Topics or Replies headings.


    probablynot
    Participant

    @probablynot

    For people wanting to hide the new search box, add this to your theme’s CSS:
    `.bbp-search-form {
    display:none !important;
    }`

    For the admin area, after further investigation, the only reason I saw the Forums, Topics and Replies menus at all was because of my Post Calendar plugin. Once I disabled that, the Admin menus for bbPress disappeared entirely.

    And I’m with @wildomains, I had to disable ‘bbPress moderation’ to get to see the posts. I want to have that plugin, so hopefully either they will update, or whatever change in bbPress broke it can be changed back.


    Nashwan Doaqan
    Participant

    @alex-ye

    @realhood: It seems a strange proplem, every thing works fine for me :), can you give more informations…

    Which version you update from and what is the plugins you use?
    Did you try to update the permalinks settings from “Permalinks” admin screen ?


    cloudduster
    Participant

    @cloudduster

    I concur that bbpress moderation hides everything. Once deactivated, I’m seeing them just fine.

    I can’t seem to find the search function everyone’s talking. Is this enabled automatically or my theme is blocking it? Help.


    realhood
    Participant

    @realhood

    @trip62   @alex-ye

    when I check the codes of @jezza101 ‘s website ,I  find the problem 。

    so I try change the codes in the chrome app ,the Developer Tools,it works.

    like change http://127.0.0.1/search/ to   http://127.0.0.1/forums/search/

    my forum link is http://127.0.0.1/forums so add /forums before the/search/

    as like http://www.nxtab.co.uk/forum/search/

    so ask:how to solve this problem

    (Hope understand my Chinese English)



    realhood
    Participant

    @realhood

    @alex-ye wordpress +bbpress +Buddypress 


    premitheme
    Participant

    @premitheme

    Looks like I’m the only one with this issue …

    http://bbpress.org/forums/topic/bbpress-2-3-now-available/#post-133143

    Anybody?


    artmuns
    Participant

    @artmuns

    Having problems.

    Lost admin panel widget for “Forums, Topics and Replies”. Getting this cryptic message error “Cheatin’ uh?”. When trying to access Forums, Topics or Replies through “Right Now In Forums”.

    Where can I get 2.24 version?


    Alex
    Participant

    @aburi

    Once I updated to 2.3, the admin menus for Forums, Topics, and Replies disappeared from the backend. I upgrade across several installs and this happened to all of them, even on the clean install with no other plugins activated.

    Anyone else having this issue? and how to resolve?

    Thanks,
    Alex


    dpmcalister
    Participant

    @dpmcalister

    There’s a few of us with that issue. Just waiting on a fix.


    Alex
    Participant

    @aburi

    Thanks @dpmcalister. Does anyone know how long until the fix is released?

    I wonder why such a major bug wasn’t noticed during development of 2.3. Does it have something to do with our particular install?

Viewing 25 replies - 1 through 25 (of 80 total)

You must be logged in to reply to this topic.