Skip to:

Updated to Desmond But Theme Not Working

Viewing 25 replies - 1 through 25 (of 64 total)
  • Maybe clear your browser cache because I can see the default theme on your forums perfectly.


    I’m seeing an un-styled version of the forums.. using Firefox here..

    Did you upload files right? Chmod the folders and files right..? Delete all the old originals, and then upload new?


    It is unstyled when I view it in Firefox 2 and IE7. I have cleared the browser cache.

    I saved the config file, deleted everything, and copied up the new files. The folders are all set at 755.

    Viewing source I noticed this:


    You’re missing the second: / in the beginning of the URL:

    Check the config.php file would be my guess..


    Good work tracking that down!

    <link rel="stylesheet" href="http:/" type="text/css" />

    What really is strange for me is safari on Mac OS X shows the page correctly anyways. What a smart browser.

    Why that link is like that and the rest of the content is showing up right is strange though.


    I see what you are talking about when I view the source, but there are two slashes in the URL in the config.php file.

    [Takes a bow to the audience]… Thank you! Thank you! No really you shouldn’t! Haha.. nah, just kidding lol. =P

    I guess I’m just used to doing that stuff on the forums, I bring that awesomeness over here.. seems to work well I think.. ;) :)


    I am wondering if this is an error in TRAC. Seems to be related this this ticket that has a patch and plugin to fix it:


    Hmm, how about the .htaccess file? I’m trying to figure out where there’s a missing one, if it’s not in the config.php file.. then I’m not really sure.. =/


    Save this file as patch-to-URL.php and upload to /my-plugins/ directory:


    function fix_bb_path_to_url( $url ) {
    return preg_replace( '|:/([^/])|', '://$1', $url );

    add_filter( 'bb_path_to_url', 'fix_bb_path_to_url', 1, -1 );



    Ah.. Okay, I’m sure Trent’s reply contains the right answer .. ;) :)


    That worked. Thanks for the help!

    I am up way passed my bedtime. I should not attempt software updates just before bedtime.



    Awesome! Glad to hear it’s working now! :)

    I should not attempt software updates just before bedtime.

    LOL! I know how that is..




    So, let me add a new wrinkle – I’ve just installed Desmond, and the default theme works just fine. I’ve tried uploading a couple of other themes to the my-templates directory but all I’m getting are blank screenshots next to the word by in the Presentation menu. Heck, I’ve even applied the plugin solution that Trent supplied, still without any success. Any ideas on why these templates aren’t showing up?

    Let me understand this. The blank screenshot issue is because you have to take a screenshot of your template and add it to your theme folder. Double check the name of the default theme, but I think it works if you create a screenshot and call it screenshot.png.

    As for the by and name of the template, that is derived from the information at the top of your style.css. If you edit file in your theme directory, it will show up. If you don’t have a style.css in your theme and are using the default theme’s style.css, download it as is, change the information at the top and upload it to your theme directory.

    I think that is all the troubles you are having at first glance.




    Yeah, I just figured out that the problem originated from bad header information in the stylesheets. Once I fixed that, both templates showed up just fine.

    Good to hear!


    <link rel="stylesheet" href="http://chezmauricekusadasi.comyeniforum/bb-templates/kakumei/style.css" type="text/css" />

    This is the site

    Could it be the reason that i see my site unstyled on Firefox2 ? You can see the slashes arent arranged in order. Some of them head to left and some of them right ?



    Yes, that’s the reason your site is unstyled when vieweing in FF. If you check with IE, you will see that the stylesheet is found. Are they typed like ( ) that in the config.php or is this an issue with bbPress?



    Hello chrishajer,

    I’m definitely seeing the () error when I look at the source.

    I have installed the latest xampp, wordpress and bbpress locally for testing purposes. My config is as follows:

    $bb->wp_table_prefix = 'wp_';

    $bb->wp_home = 'http://localhost';

    $bb->wp_siteurl = 'http://localhost';

    I really don’t think I should be getting this error, so must I configure something else? Any help would be greatly appreciated. Thank you.



    The relevant section that would affect those slashes, in the config, is this part:

    // If your bbPress URL is , the examples would be correct.

    // Adjust the domain and path to suit your actual URL.

    // Just the domain name; no directories or path. There should be no trailing slash here.

    $bb->domain = ‘’; // Example: ‘’

    // There should be both a leading and trailing slash here. ‘/’ is fine if the site is in root.

    $bb->path = ‘/’; // Example: ‘/forums/’

    What do your slashes look like there?



    This fix is what chrishajer is referencing. The ticket is gone, but the fix is still there:


    I have created a directory named “my-plugins” in the bbpress root directory and put the file named “path-to-url.2.php” into that directory. I think i have to activate that plug-in but i dont know how to do it ? Could you please help me…

    Note: I checked config file and other files like it, there seems to be no problem with the slashes…

    Thanks for your help…

    You don’t have to activate plugins – you will have to do that with a later release, though (scheduled for version 1.0?)

    Maybe you can copy us what your slashes are?

Viewing 25 replies - 1 through 25 (of 64 total)
  • You must be logged in to reply to this topic.
Skip to toolbar