Skip to:

Import from 1.1 to 2 – hangs

  • Morgan Kay


    I have a WP 3.4.2 site, and I’m trying to import a forum from bbPress 1.1. I go to the import tool, enter in all the information, and it starts the import just fine. But it always hangs around topic 31000 (it’s a HUGE forum – it’s been very active for several years). I’ve tried several times with fresh copies of the site, and every time I get the same problem.

    Is there anything I can do about this?


Viewing 4 replies - 1 through 4 (of 4 total)
  • Did you run the bbPress 1.1 admin recount tools /bb-admin/tools-recount.php before importing?

    You can try importing again now and if that fixed it, good, if not onto phpMyAdmin:

    To check the integrity of the bbPress 1.1 database and repair/optimize any tables if needed. The instructions in following are written for WordPress but are the same for any database so follow the two steps ‘Optimization using phpMyAdmin’ and ‘How to Repair WordPress Tables’ here:

    Morgan Kay


    Thanks, Stephen!

    I tried those things, and it’s still hanging in the same place… Any other suggestions?

    There is this comment via @JJJ

    Try bumping the converter start (_bbp_converter_start) up 1 or 2, and see if it continues on.

    I am trying to wrap my head around this and this may or may not help 😉

    Once the import stops at that magic ~31000 number open up your WordPress `wp_options` table in phpMyAdmin and find the following three entries (or values similar):

    • `_bbp_converter_step | 6`
    • `_bbp_converter_start | 31100`
    • `_bbp_converter_query | SELECT convert(topics.topic_id USING “utf8…`

    These translate to ‘step’ is the step the conversion was up to (Importing forums, forum hierarchy, topics etc), ‘start’ is the last set of rows the converter was importing when it stopped from the current ‘step’ and ‘query’ was the last SQL query executed.

    I think from some calculated guesswork yours will be around step=6 & start=31000

    What you can now try is to change this ‘start’ value directly in the `wp_options` table and increase the value to hopefully allow the importer to skip the problem and finish importing the remaining topics and onto importing the replies.

    The default setting for the importer is to import 100 rows at a time as defined by ‘Rows Limit’ on the import options main import tool. Thus the importer could be failing on any of those 100 rows so if it was row 31000 that it stops on changing this to 31001 would continue on and finish the import. The reality is though that it could be any number from 31000 to 31099.

    I would suggest on the forum import settings change ‘Rows Limit’ to ‘1’ and in `wp_options` change `_bbp_converter_start` to 31001 and click start. This will resume the last import starting at the same ‘step’ it left off with and starting at row 31001 and then proceed 1 row at a time.

    If the import stops again you can look up the values in `wp_options` and increase by 1 again and resume the import again.

    Now with that said the import will continue to only import 1 row at a time for the remainder of the import process which with 30,000+ topics I expect you will have quite a few tens or hundreds of thousands of replies to also import and this will be much slower than importing 100 rows at a time.



    I just wanted to chime in and say I was hitting the exact same issue with importing a very old forum in and this got me over the hump. Thank you VERY much! I was just about to start translating out the insert queries and attacking it through mysql alone.

    This forums data has been for a ride over the years and manually about half the time (starting around 2000) ubb -> phpbb -> vbulletin -> smf -> phpbb -> vanilla -> bbpress

    So loving how much processes like this have improved over the years! Much appreciated!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.
Skip to toolbar