Skip to:

bbPress plugin 2.0-rc-1 large forum import failure

  • Doug Smith


    I’ve been attempting to import an existing standalone bbPress install into the plugin version without success. The existing forum is integrated with WordPress. According to the dashboard, it has 31 forums, 6,693 topics, 42,525 posts, 2,545 tags, and 2,711 users.

    I set up a test install on my local computer with MAMP Pro, and brought the database and files over. All bbPress plugins and all plugins in WordPress except bbPress are disabled. I bumped up the memory and time limits for PHP.

    It chugged through about half of the forums and their topics then just stopped without any error message. I thought this might be PHP timing out or running out of memory so I bumped max_execution_time and max_input_time to several hours and memory_limit to 2048M and tried again. It stopped at the same place with these settings.

    There are no relevant messages in my php, mysql, or apache error logs.

    I did a repair and optimize on the database tables then did a re-count of all items in the old bbPress forum and tried again. It was very close to the same result with only stopping a few posts sooner.

    I looked in the database and checked the message it stopped on and the next numerical topic id messages and didn’t see any odd characters in the post content or title.

    One other thing I noticed is that when I went back to the import screen it recognized that I had a partial import with the message “It looks like you attempted to convert your bbPress standalone previously and got interrupted.” I used the “Continue previous import” button but it started back at the beginning again. I’ve also tried the “Cancel & start a new import” button with not change in the results.

    Any ideas where else to look, things to try, or additional information I can supply? Thanks.

Viewing 1 replies (of 1 total)

  • Doug Smith


    I just wanted to add that I pulled down the latest from svn and there were some changes in the importer code. Still no luck, though.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.
Skip to toolbar