Skip to:

bbPress and 1.0-alpha-5 released

Viewing 25 replies - 26 through 50 (of 66 total)
  • sbouazza: I tried you ‘include’ trick and it only created more warnings. I guess bbpress is pretty much off-limits until someone comes up with a downloadable that can be successfully installed.

    wordpressfan, have you added the line above inside the <?php … ?> tag ? If you have added it at the beginning or the end of the file, then it’s normal if you get header related warnings .

    My bb-includes/backpress/functions.core.php begins with :

    include "functions.bp-options.php";
    // Last sync [WP9916]

    sbouazza: I added the include before the <?php. I’ll try as you’ve outlined.



    To remove the warnings when using PHP 4, until Sam fixes it, go into bb-settings.php and change the error_reporting line (line 51 in and line 29 in 1.0a5)


    // Modify error reporting levels
    error_reporting(E_ALL ^ E_NOTICE);



    Almost made it all the way through.

    I added the include line to the alpha 5 download and got to step 2 before this error:

    Warning: cannot yet handle MBCS in html_entity_decode()! in /home3/wifirepo/public_html/wpmatrix/forum/bb-includes/backpress/functions.core.php on line 389

    This is the same warning I get when trying to install 0.9.04.

    Okay, with 1.0-a-5 trunk I get the same old inactive user when I register via WP. No errors on the page or in the log, though.

    Also I got this error, which I fixed by flipping back to the old file:

    Call to undefined function  wp_check_invalid_utf8() in
    /home/XX/public_html/forums/bb-includes/functions.wp-core.php on line 60

    Ok. I downloaded the 1.0 alpha-5. I added the include to functions.core.php. I commented out the error message statement in bb-settings.php. I get through the first step.

    But at Step 2, I get this screen:

    Oh Dear!

    bbpress is already installed, but appears to require an upgrade.

    Perhaps you meant to run the upgrade script instead?

    How do I avoid this error screen?

    I commented-out the error_reporting line in the “stable” 0.9 download and still get this installation error:

    Warning: cannot yet handle MBCS in html_entity_decode()! in /xxx/xxx/xxx/xxx/forum/bb-includes/wp-functions.php on line 113

    Can someone put together a working version of bbpress for download?



    Okay instead of commenting it out, do this instead


    same result.

    Weird charset (MBCS) errors for PHP 4 users are now fixed in trunk.

    I have installed it this morning, it’s working fine for me now.

    Thanks to sambauers,



    Thanks for the fix Sam.

    What’s really scary is the code it replaced.

    I can’t believe what I was seeing – did they really build the $table on EACH and EVERY call instead of making it static? That’s some serious non-performance thinking.

    I mean just look at it, ugh:

    function htmlspecialchars_decode( $str, $quote_style = ENT_COMPAT ) {
    $table = array_flip( get_html_translation_table( HTML_SPECIALCHARS, $quote_style ) );
    $table = array_merge( array( ''' => "'" ), $table, array( '&' => "&", '&' => "&" ) );
    return strtr( $str, $table );

    on EVERY call it builds $table?

    Well it’s gone now so I guess that’s what counts.

    I hope the error catching routine doesn’t slow things down too much.

    Personally I am waiting for PHP 5.3 to finally “upgrade” from PHP 4

    It won’t be worth it until then.

    John James Jacoby


    Not sure if this is new since alpha5 or not, but on a fresh install the auth key seems to die when there is a quotation mark " in the key.

    Basically a WP key like

    define('SECURE_AUTH_KEY', '-"r642fed3E1d>}MdGFlh@tR!QPU%/!S_6;CjO0}^>6TclyZM9mEKqEn+ <?)3 U#*X;');

    Ended up like

    define('BB_SECURE_AUTH_KEY', '-');

    This actually messed up the installer at one point too, displaying part of the key inside an area where it wouldn’t normally.

    Should I trac this Sam?



    Personally, I would start a trac ticket. They can determine there if the issue is valid or not, and how to fix it. There have been problems with the WordPress API-generated keys in bbPress before, maybe something was reintroduced.

    John James Jacoby


    Speaking of reintroduced, I’m logged into my forum and WordPress, but for some reason I am listed as Inactive on my posts when viewing a topic. I thought this was fixed in alpha2?

    Why do I get the feeling that alpha5 was bolted on top of an outdated 1.0 version and things went cross eyed?

    Fixed my fatal call by re-uploading backpress. THAT was weird. And I show as ‘Site Admin’, jjj.

    When will the fix migrate to either the public “stable” or public “alpha” version, rather than remain closed to developers? I downloaded the “alpha” and the fatal error remains:

    “Fatal error: Call to undefined function: backpress_get_option() in /bb-includes/backpress/functions.core.php on line 412.”



    This seems a great time to mention a new hidden feature in bbPress 1.0 based on a suggestion I made: “Safe Mode”

    When you don’t know why something isn’t working, one quick and easy way to prove if it’s a plugin gone wrong or not is to temporarily try “Safe Mode”

    The way to activate safe mode is to edit bb-config.php and insert

    $bb->safemode = true;

    Then your forum will temporarily switch to the default theme (which you should never have tampered with) and disable all plugins, temporarily.

    When you are done testing, remove the line from bb-config.php

    This is far easier than deactivating 20+ plugins, one at a time and then having to activate them again.

    I’m having an installation error as well :(

    Warning: cannot yet handle MBCS in html_entity_decode()! in /home/content/b/r/i/xxxxxx/html/xxxxxx/support/bb-includes/wp-functions.php on line 113

    I’d say try the nightly build ( ) but I’m not really sure when that’s updated anymore…

    The SVN is open to be downloaded by anyone.

    The nightly build/ has the MBCS warning screens after step 1 of the installation.

    I created a new directory and copied the files from to it. I was able to install bbpress 1.0-alpha 4.

    However, there was no screen about creating a user or your first forum or any integration.

    Update: I was able to integrate bbpress 1.0 alpha 4 with wpmu 6.5 and buddypress beta.

Viewing 25 replies - 26 through 50 (of 66 total)
  • You must be logged in to reply to this topic.
Skip to toolbar