Skip to:

bbPress and 1.0-alpha-5 released

Viewing 25 replies - 1 through 25 (of 66 total)

  • John James Jacoby


    Looking forward to this Sam. Thanks again for the fast updates. Will check it out tonight and report back asap.



    Upgrading now



    I just received this error on the install screen just after it tells you it cannot find a config file. I changed my old one to config.old.php (received error) then to bb-config.old.php. (received error)

    Fatal error: Call to undefined function backpress_get_option() in /nfs/c03/h04/mnt/57391/domains/ on line 412

    I then just had a funny feeling so I just changed the file name back to bb-config.php and when I went to my forums it said I needed a update.. updated and all seems well.

    John James Jacoby


    When I renamed my old config file, I actually received the same error.

    Fatal error: Call to undefined function backpress_get_option() in /forum/bb-includes/backpress/functions.core.php on line 412

    So I renamed my config file back, visited the forum, and then it prompted me for upgrade.

    Is there a specific upgrade page to visit now rather than just hitting the root of the forum?

    Sam, it seems this only happens when I upgrade from alpha4 to alpha5. I was running a trunk version, and received no errors and wasn’t even prompted to upgrade from trunk to 5.

    Hi, just FYI, I’m getting the same fatal error on a fresh install out of SVN. No previous version of bbPress installed.


    John James Jacoby


    Also, when I register a new user through WordPress as per normal, that user is still not assigned a role in bbPress. Not when they login, not when they hit the forum for the first time. Not ever.

    My Steps:

    1. I used a Chrome browser window to register a new user through WordPress
    2. Logged in via WordPress
    3. Hit the forum
    4. User could not post, looks like has no role
    5. Logged out via WordPress
    6. Used FireFox to login as admin to check new user role
    7. No Role Assigned
    8. Used Chrome to login through bbPress
    9. Hit the forum
    10. User could not post, looks like has no role
    11. Used Firefox admin to edit Test user
    12. Received typical error message (noted below)

    Warning: array_key_exists() [function.array-key-exists]: The second argument should be either an array or an object in /forums/bb-includes/ on line 2009

    Basically it looks like the exact same error message as before, with the same circumstances.

    Round two using alpha 5 trunk from the SVN went exactly the same way, only this time when I logged in via bbPress, the above Warning went away, but that user is still marked as Inactive by default when they should be a Member according to the role map.

    When registering through bbPress, the new user still is not assigned a Role on the WordPress side either.

    Sam, can you explain to me what was supposed to be different in alpha5? Maybe I misunderstood…

    @Jeff: Same problem here.

    A little bit frustrating, installing BuddyPress, which needs bbpress. I guess we will have to wait for an fix.

    @segwayinfo: Last night was supposed to be “Install WPMU, BudyPress and bbPress” night for me. Oh well. :)

    @johnjamesjacoby, I get the exact same problem. I cannot get a role assigned to my users at all! And it’s really frustrating. I create a user in BBPress and no role assigned in WordPress. User created in WordPress and no role assigned in BBPress. I have the exact same problem as you.


    I upgraded to alpha5 (through svn) and no problem (except the login problem I have since a few releases : I can be logged in WP OR in BBpress but not in both at the same time, if I log in in one I’m logged out on the other..)

    Installation issue is fixed in trunk. Need some time to debug the auto-role-assignment issues.

    The upgrade page is generally only triggered when visiting the admin area, and only if the database needs upgrading (i.e. the db version number has changed)

    The PHP warning is also fixed in trunk.


    Do you have a role mapping setup in bbPress? It should at least work in one direction. Unless I broke it worse with the fix.

    John James Jacoby


    Yes I do have the role map setup in the bbPress admin area. I also installed the additional role map plugin you made just to see what it was for, and retried these steps with and without it active.

    I think this evening I’m going to retest this on stock installs of both to see if any of my plugins are conflicting. I am using the Register Plus plugin on the WP side, so I suppose it’s possible it could conflict (as far as I know it uses the stock WP registration and user activation methods to create them though.)

    About the “backpress_get_option” error : I don’t even know if it’s the best way, but you can edit functions.core.php and add this :

    include "functions.bp-options.php";

    It works for me :-)

    I can confirm that the install fatal error issue is fixed in trunk. Thanks Sam!



    my Wodpress version 2.7

    my bbPress version 1.0 Alpha 5

    Integrated wordpress. Use wordpress user table.


    User Name : admin then login bbPress.

    User Name : hasan then login bbPress.


    User Name : 123456 then cant login bbpress.

    Help me..!



    When you say trunk does that mean its fixed in the download link too?

    My roles don’t get assigned as I mentioned above, only this time I can go into the bbpress admin and change their role where I couldn’t do that before.

    I get this error: Warning: array_key_exists() [function.array-key-exists]: The second argument should be either an array or an object in /home/hfw/public_html/forums/bb-includes/ on line 2009

    But at least, this time, the pull-down works to change the role.

    Arg! I cannot install bbpress no matter what download link I use. The link for the stable version gives me this error when trying to install:

    Warning: cannot yet handle MBCS in html_entity_decode()! in /home3/wifirepo/public_html/wpmatrix/forum/bb-includes/wp-functions.php on line 113

    The download link for the unstable 1.0.5 alpha give me a fatal error that is said to be fixed in the “trunk” version, but there is no download link (only reference to an svp – no zip file.

    I want to install a working version of bbpress but all attempts have been thwarted.

    The fatal error is backpress_get_option related ?


    I got the same error Warning: cannot yet handle MBCS in html_entity_decode()! in …/bb-includes/wp-functions.php on line 113

    I switch from php4 to php5 and it works fine now. I’m hosted on MT GS.

    macron: My host (bluehost) is using php 5.2.8.

    sbouazza: yes, the bbpress 1.0 alpha 5 download link when installed, gives the backpress_get_option error. What is the solution, since there appears to be one?

Viewing 25 replies - 1 through 25 (of 66 total)
  • You must be logged in to reply to this topic.
Skip to toolbar