mica123 (@mica123)

Forum Replies Created

Viewing 25 replies - 1 through 25 (of 68 total)

  • mica123
    Participant

    @mica123

    @robkk thanks, that’s great. Will keep everything in mind.


    mica123
    Participant

    @mica123

    Many thanks @robkk for your clear and detailed explanation as always. For now I won’t change the name of the file.
    Just a question which has been mentioned elsewhere but as far as I can tell not satisfactorily explained or resolved. The official instruction for modifying bbpress files is to create a bbpress folder in the child theme and put the files there. However that doesn’t work at all. I had to take the bbpress files out of that folder in my child theme and put them directly in the root of the child theme for them to work. Just thought I’d mention it here.

    In reply to: bbPress 2.5.9

    mica123
    Participant

    @mica123

    Thanks @robkk, I will reply to your other reply. Yes, I will follow your instructions.

    In reply to: bbPress 2.5.9

    mica123
    Participant

    @mica123

    Before I upgrade to bbpress 2.5.9 I’d like to check on the following:

    1. I put some bbpress php files into my child theme ((bbpress.php – modified by @robkk; the following files were modified by me: feedback-no-forums.php, feedback-no-replies.php, feedback-no-search.php, feedback-no-topics.php, form-forum.php, form-reply.php, form-topic.php, loop-single-form.php) – will I have to do something after the upgrade?

    2. Should I worry about the text editor missing after the upgrade as reported in the post above?

    Thank you.

    In reply to: Image upload advice

    mica123
    Participant

    @mica123

    @robkk many thanks as always! It took me a while to work out that I had to disable the code for enabling the Tinymce in my own functions.php before the plugin started to work as expected.

    In reply to: Private Message

    mica123
    Participant

    @mica123

    @robkk,

    I finally set up the plugin you found. It is easy to use once
    I got the hang of it which took me a while. But the the author
    of the plugin is very helpful.
    Many thanks for your tip – it saved me a lot of bother.

    In reply to: Private Message

    mica123
    Participant

    @mica123

    Many, many thanks. I’ll try it out and let you know.


    mica123
    Participant

    @mica123

    Thanks @robkk – as always.


    mica123
    Participant

    @mica123

    Hello again,

    many apologies for causing a misunderstanding here. All the login/logout links work. I was only asking about the profile link after logout – this is also fine. My question can be ignored.

    Many apologies to @robkk. The profile link code is his – taken from How to add user profile link to specific menu

    Thanks.


    mica123
    Participant

    @mica123

    Hello,

    I hope you won’t mind if I come back to this topic. Everything works with the login and logout links – both redirecting to a certain page. I added the profile link to the menu which shows up after a user login (taken from Layout and functionality – Examples you can use as follows:

    function rk_bbp_menu_profile_link( $items, $args ) {
    
        if( is_user_logged_in() && $args->theme_location == 'sub-header-menu')  {
    
    		
    
    	$current_user = wp_get_current_user();
    
            $user = $current_user->user_nicename;
    
    	$profilelink = '<a href="/ihabbpress/tenant-forums/users/' . $user . '/">Your Profile</a>';
    
            $items .=  '<li>' . $profilelink .  '</li>';
    
    	}
    
        return $items;
    
    }

    This is fine except that when the user logs out, he/she stays on the same profile page
    he/she had been on before logging out. This is not good – users should be redirected to a specific page. I thought that this code would automatically inherit the redirection link from the Logout code. Many thanks.


    mica123
    Participant

    @mica123

    Please, let us know how you get on. Hope you’ll solve it.


    mica123
    Participant

    @mica123

    @gperez-tl
    You might like to know that I resolved my issue on the other topic. It may not be the same for you but at least it might be worth knowing. Here it is link


    mica123
    Participant

    @mica123

    This issue is now finally resolved. After a long battle, the web host came back to me to ask me to put the following code into .htaccess:

    FileETag None
    Header unset ETag
    Header set Cache-Control "max-age=0, no-cache, no-store, must-revalidate"
    Header set Pragma "no-cache"
    Header set Expires "Wed, 11 Jan 1984 05:00:00 GMT"

    They said the following: This should prevent my website from being cached by Apache and may help to solve this issue. The website is not currently sitting behind their caching
    server so this cannot be the cause of the issue but Apache itself can cache
    sites so perhaps this will help to resolve the issue.

    This may help others having similar problems.
    Last but not least, my heartfelt thanks to @robkk and @casiepa for their steadfast support without which I would have coped very badly. @robkk tirelessly tested every possible issue under the sun. Huge thanks again to both of them. All in all, everything pointed to a caching problem on the server side.


    mica123
    Participant

    @mica123

    I’ve just emailed you. I won’t be removing the line with the style-login.js – the script works flawlessly. I was only grasping at straws.


    mica123
    Participant

    @mica123

    Thank you. I will not do the header.php changes for now – I’ll try to battle it out with the provider – at least to get them to see what I mean.
    The only other thing I would like to check is that in my functions.php I have the following
    for the customised wp-login:

    `function my_login_stylesheet() {
    wp_enqueue_style( ‘custom-login’, get_stylesheet_directory_uri() . ‘/css/style-login.css’ );
    wp_enqueue_script( ‘custom-login’, get_stylesheet_directory_uri() . ‘/css/style-login.js’ );
    }
    add_action( ‘login_enqueue_scripts’, ‘my_login_stylesheet’ );

    Do I have to load style-login.js – if not, should I delete that part:
    wp_enqueue_script( ‘custom-login’, get_stylesheet_directory_uri() . ‘/css/style-login.js’ );


    mica123
    Participant

    @mica123

    Yes, I copied everything – www folder plus database to the other provider and used the same theme responsive. Not sure what you mean options? I just used everything that was copied over, so the same options must have been set. I’ll delete the test topics and the login.
    My provider doesn’t understand what I am talking about, so I am having a hard time to convince them that there is something wrong – so far I have not succeeded because they keep saying that they can create topics in some forums and some they can’t. I keep explaining to them that it depends on which page they saw before logging in. I am really desperate.
    What would be the meaning of ‘applicationcache’?
    Also, everything is normal on my local computer in xampp – I use exactly the same what I have on the live site.


    mica123
    Participant

    @mica123

    @robkk

    I did more network testing on my bad site via the web developer.
    All other pages display the following:
    Response header:
    main site url:
    Cache Control: max-age=3600
    bbpress:
    Cache-control:max-age=2592000

    Request headers:
    main site url:
    Cache-control: max-age=0
    bbpress:
    Cache-control:max-age=0

    After login:

    After login:
    wp.login:
    Cache-control:no-cache, must-revalidate, max-age=0

    Without refreshing the page
    bbpress:
    Cache-control: max-age=2592000 –

    On refreshing the page
    bbpress:
    max-age=2592000

    The information for bbpress does not change at all.

    This is different from the results gleaned from my good site as I reported earlier:
    bbpress
    cache control: max-age=2592000, public, proxy-revalidate, public, proxy-revalidate, must-revalidate
    Cache control: max-age=0

    After login:
    Response header:
    Cache control: no-cache, must-revalidate, max-age=0

    So would this indicate that all is not well on my webhost provider’s server
    regarding cache even if they say that it is not enabled?


    mica123
    Participant

    @mica123

    @casiepa

    info from both plugins now emailed to you.
    Thanks.


    mica123
    Participant

    @mica123

    @casiepa
    Yes, of course, I will do it. I can’t do it until tomorrow late afternoon.
    Is this just one plugin? You mention WP (Hyper, Super, W3 Total) Cache 0 (since wp2.5), Simplepie Cache 0 Age 0 seconds (since wp2.8).
    I will also do Send System Info.
    Many thanks.


    mica123
    Participant

    @mica123

    I really wouldn’t know how to do this in my case.
    All I can say is that I copied all of my WordPress and database to another site to test it there and I have absolutely no problems there. If I don’t get anywhere with my webhost, I’ll probably have to find another webhost – but I don’t really want to go down that route.


    mica123
    Participant

    @mica123

    Thanks for letting me know. I won’t attempt anything like that.
    Yes, reloading the page helps but it is not a solution for users who log in
    and then find they are not logged in unless they refresh the page.
    I am currently trying to convince my webhost that all is not well –
    they don’t seem to understand what I am talking about. Have you tried the
    Network tool for Response headers in Web developer on FireFox? It should
    show you if the page is really not cached. My test shows that the page
    is cached even if my webhost says that no caching is enabled.


    mica123
    Participant

    @mica123

    I can only hope my host will come back with something. So far they didn’t actually say that there is an issue, they are just replicating the issue to see what i am talking about.
    I’ll let you know.


    mica123
    Participant

    @mica123

    @casiepa, @robkk

    Just to let you know that my webhost seems to have acknowledged that there is a problem and is going to do something in WordPress itself. Hopefully this will be sorted.


    mica123
    Participant

    @mica123

    Hello @casiepa, @robkk

    I did more testing, this time I looked at response headers following instructions from this article. I am not sure if this is the right course of action but if you could bear with me could you perhaps have a look at the results below? The first part is from my good site and the second part is from the problematic site:

    My good site results:
    Response headers:
    cache control: max-age=0
    Request headers:
    cache control: “max-age=0”

    bbpress
    Response headers:
    cache control: max-age=2592000, public, proxy-revalidate, public, proxy-revalidate, must-revalidate
    Cache control: max-age=0

    After login:
    Response header:
    Cache control: no-cache, must-revalidate, max-age=0

    My bad site results:
    Response headers:
    Cache control: max-age=3600
    Request header:
    Cache control: max-age=0

    bbpress:
    Response headers:
    Cache control: max-age=2592000
    Request header:
    Cache control: max-age=0

    After successful login response header says:
    Cache control: no-cache, must-revalidate, max-age=0

    However, clicking on page that was viewed before login,
    response header says:
    Cache control: max-age=3600


    mica123
    Participant

    @mica123

    @gperez-tl

    As @casiepa told you, I am the one who is having dreadful problems as detailed on this
    link.

    My host says they have no caching enabled. I wonder which pages did you edit via FTP? When you say “edit”, did you actually edit them or just resaved them?

Viewing 25 replies - 1 through 25 (of 68 total)