Skip to:
Content
Pages
Categories
Search
Top
Bottom

bbPress forum BLANK pages


  • Zookey90
    Participant

    @zookey90

    Hi, I installed bbPress on my WordPress site, but when I add forums, and try to open one of them, I get blank page?

    How I can fix that?

Viewing 13 replies - 1 through 13 (of 13 total)

  • LabSecrets
    Participant

    @labsecrets

    URL of site?


    Zookey90
    Participant

    @zookey90

    This is url of forum, anyway site isn’t on english.

    http://216.172.171.90/~droidba/forums/


    LabSecrets
    Participant

    @labsecrets

    Zdravo!!

    Ok, that helps.

    First suggestion:

    What happens if you use shortcodes to create a forum index?  http://codex.bbpress.org/shortcodes/

    Take the shortcode of: [bbp-forum-index] and add it to a blank page.

    Does that create a visible forum index?

    If so, then¬† your problem imho is that your theme is hijacking the content area in a way that prevents the new bbPress code from working. As such, the solution would be found most likely in your theme’s page.php or similar, where the default archive pages are created. I don’t have access to the Gonzo theme since it is on ThemeForest ;-(

    but you can see in my recent post, we fixed a similar solution for Canvas 5 from WooThemes. http://bbpress.org/forums/topic/non-functional-index-page-when-bbpress-2-1rc4-is-used-with-woothemes-canvas-5-05/

    If not, then please share the link to the page where you posted the shortcode so I can see the underlying output.

    Hvala!

    Spence

     


    Zookey90
    Participant

    @zookey90

    Oh, God, I it works, when I add shortcode to a blank page.

    Hvala, mnogo. :)

    BTW. Where are you from? :)


    Zookey90
    Participant

    @zookey90

    I have one more question. Do I need all the time to add shortcodes?

    I mean, if I create 5 new forums, do I need to put this shortcode [bbp-single-forum id=$forum_id]?

    How I could know which is id of forums?


    LabSecrets
    Participant

    @labsecrets

    No,

    the solution is to fix the one page template in your parent theme spit doesn’t hijack the content area and force an excerpt to appear (because there is one with bbPress!)

    likely there is a conditional on the page.php template in that theme looking if page is single… See my other post link above.

     

    Im from Chicago, but many of my pals are Serbian :-)


    LabSecrets
    Participant

    @labsecrets

    Sorry iPad…”in your theme that doesn’t “


    lincolnthree
    Participant

    @lincolnthree

    Make sure you don’t have any pre-existing or duplicate pages called “Forums” or that use the same URL slug as your forums / bbpress installation. This will cause problems and BBPress may not display. Delete these posts and MAKE SURE TO EMPTY THE TRASH!

     

    :)


    enlightentogether
    Participant

    @enlightentogether

    Hello.

    I am having the same problem. Forums appear on my site at this link http://www.enlightentogether.com/forums

    But when clicking further there is a blank page. I added a topic which I am able to see when I insert the shortcode in a page so the problem may be the theme? I have heard other users say insert a shortcode into pages so the forum works properly but I am completely clueless on how to do this.

    Do you know of any video tutorials relating specifically to inserting shortcodes for forums or articles? I have seen tutorials for inserting shortcodes for all kinds of things but not bbpress.


    Daniel Lemes
    Participant

    @daniel_iceman

    @enlightentogether
    Easy: create a new page, name it anything and paste the shortcode [bbp-forum-index] on it.

    I did the same and it works, but there is a problem: the link to forum “main page” on breadcrumbs still pointing the blank “original” one. I noticed that you’re using Oxygen theme from AlienWP; i’m using Origin (same developer) and have the same problem. Unfortunately they don’t give support for these free themes (except we buy an Membership for 39 bucks…)


    benjik
    Participant

    @benjik

    I am having the same problem. When I install bbpress the index is showing up as a blank page. If I create a forum page and put the index short code on that page the permalinks to do allow the page to be /forums, It will rename it to /forums-2. I assume this is happening because the bbpress forum plugin is reserving the /forums. If I click view on a topic from the admin panel I am able to see that topic but as soon I click in the bread crumbs to the root forum I am brought back to the blank page. Help?


    LabSecrets
    Participant

    @labsecrets

    @benjik

    Sounds like the problem is that you actually “do” have a page called “forums” that is in the trash and you have to EMPTY the trash to get rid of it. Once you do, then you can create it again with the proper short codes and page slug of “forums” (instead of “/forums2″)

    Cheers!
    spence


    benjik
    Participant

    @benjik

    Thats what I thought but I looked in my trash and there are no pages by that name. I was thinking about uninstalling bbpress and also removing all the associated tables from the mysql database. My hope is that it would completely remove all bbperss information from the database and would allow for a clean installation.

Viewing 13 replies - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.