Skip to:

WP 2.7.1 with BBpress 1.0 rc1 integration problem

  • The forum is located in a subdirectory of the WP blog; bbpress/

    I`ve enabled the bbpress plugin in WordPress

    Ive added the lines to WP config and the BBpress lines to bb`s config

    It just doesnt seem to be working

    Have the same problem since 0.9.x

    A bit of help is appreciated!

Viewing 25 replies - 1 through 25 (of 25 total)

  • deadlyhifi


    Is the user-base being shared correctly?

    have you checked that the cookies correspond?

    the user list is shared correctly

    i think the problem lies in the cookies

    because if i login to the forum i need to relogin to the site

    and vice versa



    and the secret keys in both config files correspond?

    yep the secret keys in the configs match

    also got;

    define(‘WP_AUTH_COOKIE_VERSION’, 1);

    i`ve updated the integration plugin

    but it`s still not working

    I’ve got the exact same problem, and it’s driving me mad.

    I’ve tried to get this working on several fresh installs and it just ain’t happening!

    Update: Oh! Fixed! I went to wp-admin/options.php and changed the salts to something else (button mashed), and updated those in bbpress too, and now it works. Don’t quite understand why nobody mentions this in any of the tutorials… Never mind :)


    it seems i have no secure_auth_salt listed in options.php :S

    @byles; ive replaced all security codes a few times


    Hmm, frustrating isn’t it? I can’t offer anything else I’m afraid. Cleared your cookies and tried again? I guess that’s the obvious stuff…

    “secure_auth_salt” doesn’t show up unless you’ve configured WordPress for SSL stuffs (apparently).

    Sorry I can’t help anymore!

    i`ve changed the cookies several times

    the problem isn`t pc depended, tried it under Win/IE8 and Lin/FF3



    I have the exact same issue and in addition user base is not shared.

    Created a new topic for the issue Missing Users After Integration




    im glad my userbase does share


    i dont use buddypress and/or WPMU

    tried a fresh install of bbpress

    no success still

    John James Jacoby


    Sounds like you need to sync up all of your salts and keys, and check out the cookies that get dropped from both sides when logging in.

    Remember you will still need the bbPress Integration plugin on the WordPress side to drop the bbPress cookies.

    The way I do this, is to use Firefox, login through WordPress, and look at the cookies. Then delete them. Login through bbPress, look at the cookies. Which ones are missing from either side? Which information doesn’t match? That will be your clue to getting them synced up.

    Once you know what you’re looking at, this process shouldn’t take more than 20 minutes.

    I do have got my cookie salts set up properly;








    all set in WP

    and their BB variaties in bbPress

    and ive got the bbpress integration plugin up and running (and active …)

    John James Jacoby


    So what cookies do you see when you login through bbPress?

    What cookies do you see when you login through WordPress?

    What are the differences? Either you’re missing a hash, or your host is wrong, or the path is off. Something is missing.

    i think its got to do with the host using VHOSTs



    Ah….In what way re VHOSTs?

    @parallax view;

    my provider uses subdomain vhosts …

    i presume the problem is in cookies / vhosts + bbpress + wordpress



    “Remember you will still need the bbPress Integration plugin on the WordPress side to drop the bbPress cookies.”

    What is the bbPress Integration plugin on the WordPress side? I’m trying to set up user integration, but the cookie that gets generated on the WP side is wordpress_logged_in_ only, and not wordpress_logged_in_xxxxxxx, as I think it should be.




    Never mind. I got the plugin and installed it and now the cookies look like wordpress_logged_in_12341234…

    It’s still not working, but that’s progress.

    John James Jacoby


    vhosts works fine. Eraticdance, it has to be a mismatch in the paths and cookies somewhere. Might end up to be a trial and error process adding, removing, and modifying your -config.php files, but that’s all I can really suggest as different hosts and setups all require different settings.

    still haven`t found the solution :(

    Solved somehow

    i`ve updated to WP 2.8 rc 1

    and now it does work!



    I struggled with this beast until I hacked it into submission.

    Have a look here to see what I did:

    Hope it helps someone!

Viewing 25 replies - 1 through 25 (of 25 total)
  • You must be logged in to reply to this topic.
Skip to toolbar