Skip to:
Content
Pages
Categories
Search
Top
Bottom

Where is the forum main page?

Viewing 18 replies - 1 through 18 (of 18 total)

  • Jarret
    Participant

    @jarretc

    How are your permalinks setup in WordPress? Settings->Permalinks


    comerecommended
    Member

    @comerecommended

    I am having a similar problem. I’m using BuddyPress, and I want a sitewide forum (instead of forums tied to groups). I installed the bbpress it told me to (I guess it’s bbpress Community?), but I can’t figure out where the heck my forums are! I can’t seem to tie BuddyPress Forums to bbpress Community.


    Jarret
    Participant

    @jarretc

    comerecommended – did you activate the bbpress plugin? I tried visiting both

    http://comerecommended.com/community/forum

    http://comerecommended.com/community/forums

    and each time get an error saying the forums component isn’t setup yet.


    comerecommended
    Member

    @comerecommended

    I sure did. That’s part of the problem! (I meant to say that originally, sorry!)

    You can see a forum here: http://comerecommended.com/community/discussions/forum/social-media/


    rr03
    Member

    @rr03

    Jarret

    my permalinks set up is restinerest.com/the.title.of.page

    i refreshed permalinks sections after i set bbpress up as it is suggested.

    i managed to have the main bbpress page with creating a new page and writing a shortcode([bbp-forum-index] ) in it. but then i had this problem:

    i had two categories and each have two forums. at this new page it is shown

    http://www.restinerest.com/forumd/ this is the page.

    category1

    forum1(0,0) forum2 (0,0)

    category2

    forum3(0,0) forum4 (0,0)

    and i wanted that forums would be shown as one under the other one.

    so do i have the theme compatibility problem or any other thing?

    and why cant i reach restinerest.com/forumlar or restinerest.com/forumlar/forum even though i set the slugs up?

    any help will be appreciated.


    Skyforger
    Member

    @skyforger

    Same problem been trying to fix it in all possible ways.

    i do have in httpd.conf AllowOveride All

    permalinks are to “Post name http://localhost/sample-post/”

    Still cant get to forums

    just shows “The forums component has not been set up yet.”

    Im running out of ideas, will try to do a clean instal for the 10 time


    Skyforger
    Member

    @skyforger

    F this aint working i give up.


    arpnet
    Member

    @arpnet

    im about to go to phpbb


    rr03
    Member

    @rr03

    i am still at bbpress:) so anyone has any suggestions for the problem?


    Skyforger
    Member

    @skyforger

    I wonder why it works for some ppl, i seriously tried all the solutions i found on the web.


    rr03
    Member

    @rr03

    i start to build child theme now to copy the theme files of bbpress. hope that helps.

    did you try what i wrote skyforger?

    “i managed to have the main bbpress page with creating a new page and writing a shortcode([bbp-forum-index] ) in it.”


    Skyforger
    Member

    @skyforger

    thnx trying out now


    Skyforger
    Member

    @skyforger

    Worked thnx a lot !

    Such a simple solution wonder why it was not posted anywhere else.

    Ok i see the forum main page now, but when i go to the sections:

    http://localhost/forums/forum/general

    opens blank page, not even theme is loaded


    rr03
    Member

    @rr03

    dont know, i didnt see anywhere, too. just did it but i had this problem after which i mentioned before.

    all the forums under the categories seems like this

    category1

    forum1(0,0) forum2 (0,0)

    category2

    forum3(0,0) forum4 (0,0)

    i want to change them as

    category1

    forum1(0,0)

    forum2 (0,0)

    category2

    forum3(0,0)

    forum4 (0,0)

    do you have any idea?


    Skyforger
    Member

    @skyforger

    is that just a formatting issue u want it to be vertical listing instead of horizontal ?

    Also check this https://bbpress.org/forums/topic/how-do-i-set-up-bbpress-and-buddypress?replies=12#post-92559

    Dude is saying not to install bbpress throe buddypress but as separate from plugins list.


    rr03
    Member

    @rr03

    i dont use buddypress but i kinda had solved the problem when i moved bbpress theme files to inside my child theme.

    i still have a lot to figure out but i suggest instead of using shortcodes, move to theme files

    https://bbpress.org/forums/topic/bbpress-20-theme-compatibility in here it says how to do.

    now i have access to all links.


    comerecommended
    Member

    @comerecommended


    mikedonovan2011
    Member

    @mikedonovan2011

    I’m kinda stuck on this forum setup. I have a new install of WP and BP. At first I thought I really just want one forum linked from the home page that each registered member can participate in. I might call it a network-wide forum. Is this possible?

    (Now I’m starting to think that there should be group forums too. Otherwise what’s the point of groups? Perhaps I’ll try to get this going too. But one thing at a time.)

Viewing 18 replies - 1 through 18 (of 18 total)
  • You must be logged in to reply to this topic.
Skip to toolbar