Skip to:

vbulletin import…fails

  • alfio8788



    I am trying to import a vbulletin 4.2.2 installation into bbpress and it fails importing the replies without leaving me errors, it just hangs and keeps posting dashes (-) into the progress logs even after stopping it and resuming.

    Wordpress and bbpress versions are the latest available as of today 20th of March 2016.

    Our vbulletin database has around 11000 users, 600 sub-forums, 30000 threads and around 800000 posts

    As the work is being done in local before atempting it on the server i am unable to give links.

    If in need of more informations let me know

    Thanks in advance for the support


Viewing 12 replies - 1 through 12 (of 12 total)
  • First thing… can you try in bbPress 2.6 ? This version is almost going to be released and it offers better importing features.




    It is installed and importing, will let you know if the import fails or not.



    Sadly the import fails still, this time even sooner than before.

    With the 2.6 it can’t complete the thread imports while with the curent stable it reaches the replies.
    As a side note the import is slower on the new 2.6.

    Any idea what else could be tried to make the import succeed?

    When you say it ‘fails’, what do you get exactly ?
    Did you deactivate all plugins that you could to speed up the process ?

    If it seems to fail with timeout, it might be good to have a 2nd /wp-admin open to see if your site is still responsive.


    And don’t forget, if you relaunch the import, it should continue where it left off…



    When it hangs it says something like: Importing Discussions (x-y) then all of a sudden it just prints “-” every 5 seconds or so and nothing is being imported, even stopping and resuming the process does not help, from that point on all it does is print more – on the lower box used for the status.

    It is not a problem of timeouts or similars, it is a local copy of our live site running only the import.



    Small bump.

    Sorry but i need to fix this problem ASAP and we are running out of ideas to make it work.



    The import problem was solved by erasing the thread tags and subscriptions in vbulletin, for some reason mysql was refusing to execute queries on some tags / subscriptions (encoding?). The import tho has problems and i will open another thread for this.

    This thread can now be closed

    Thanks for the update !

    Thanks for this, I don’t think I have a copy of a vBulletin database so there might be some issues with the db schema here, I’ll try to hunt to a vB 4.2.2 database to test.



    When it hangs it says something like: Importing Discussions (x-y) then all of a sudden it just prints “-” every 5 seconds or so and nothing is being imported,

    Unfortunately this reply comes far too late to help the OP, but hopefully, this will help someone else down the road.

    First, before you begin your transfer of vBulletin, add the following lines to the top of your wp-config.php just below <?php

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    This will create a debug log of any errors you encounter, you can access the log by visiting

    keep in mind that if your wp install is within another folder, you’ll have to alter the path in the url to access the log.

    Next, once you’ve encountered an error, check your debug log, if the error isn’t listed, you can go to your MySQL tables.

    Hit STOP on the Importer. (Don’t navigate from the page, just hit the stop button).
    Go to the wp_options table (might be slightly different prefix depending on your own database settings) and do a search for %converter%

    You will find 3 rows within the wp_options table

    a. _bbp_converter_query
    b. _bbp_converter_start
    c. _bbp_converter_step

    The Step will show you which step # your install is hung up on. The Converter query will tell you precisely which line and the start is what tells the bbp_converter where you last left off.

    View the steps in your wp-content>plugins>bbpress>includes>admin>converter.php file

    Step 1 (about line 339)
    Step 2 about line 360, etc

    Most often the issue is due to character collation.

    Robin W


    @budget101 thanks for posting this – I hope it will help others and it’s great that you have detailed your experience

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.
Skip to toolbar