Skip to:

Upgrade problem 1.0.2 to 1.2

  • esck



    We’ve been using bbpress almost since the beginning, and we currently have a quite big forum.

    Site is this forum is here as you can see it’s also quite modded and customized.

    So upgrading was not something we did frequently, but a recent necessary php and mysql upgrade forced us to upgrade our wordpress and bbpress. WordPress upgrade went ok, but bbpress was a problem since we just learned it moved from being a standalone version to a plugin version.

    Since the problem we had was the the recent php and mysql brought some error like these:

    `Deprecated: Assigning the return value of new by reference is deprecated in /home/ifans/public_html/foro/bb-settings.php on line 186

    Deprecated: Assigning the return value of new by reference is deprecated in /home/ifans/public_html/foro/bb-includes/backpress/functions.wp-object-cache.php on line 108

    Deprecated: Assigning the return value of new by reference is deprecated in /home/ifans/public_html/foro/bb-includes/backpress/pomo/mo.php on line 171

    Deprecated: Assigning the return value of new by reference is deprecated in /home/ifans/public_html/foro/bb-includes/ on line 484

    Deprecated: Assigning the return value of new by reference is deprecated in /home/ifans/public_html/foro/bb-includes/backpress/class.wp-taxonomy.php on line 581`

    Import from 1.0.2 (our latest forum version) to latest bbpress was a nightmare (duplicated forums, topics, posts. Stalled conversions and so on). So looking for advice here ate bbpress forums found that it could be easier if I upgraded first from 1.0.2 to 1.2. I downloaded the legacy version, the backpress files (whatever they were) and the “pomo” folder (also don’t know what it is).

    We decided to try to upgrade to 1.2 as suggested. Everything went fine, uploaded files helped, the errors didn’t show in this version, next step was going to the admin panel and upgrade the database, clicked the “upgrade database” button and then another error.

    `Network Error (tcp_error)

    A communication error occurred: “Operation timed out”
    The Web Server may be down, too busy, or experiencing other problems preventing it from responding to requests. You may wish to try again at a later time.

    For assistance, contact your network support team.`

    I can’t tell what’s happening, I’ve tried to increase the maximum execution time, the php memory, nothing worked so far.

    What can I do? how can I upgrade the database without this timeout error? is it possible to do it through shell? Is a setting I need to move in my server?

    Please help!

Viewing 19 replies - 1 through 19 (of 19 total)
  • I started typing a reply with lots of in depth bits and pieces but knowing what your end goal is in the following regard will make things alot easier for both of us:

    Get bbPress 1.2 fully operational? OR fully upgrade to the bbPress 2.x plugin?

    FYI: BackPress’ is used for the SQL stuff and the ‘pomo’ is for language stuff.



    I got stucked in the last step “upgrading database” from 1.0.2 to 1.2 because of the error I mentioned above.

    I would like to have 2.2.4 if possible, but anything that works will be fine.

    What do you suggest?

    Thanks a lot for answering, I know it’s quite complicated with all those spam posts everywhere (f%$# the spammers)

    Also thanks for your FYI hehe

    Cool… I will try to focus everything else with bbPress as the goal and try not to break your current 1.2 site 😉

    First up presuming things might be easier than what is to follow, can you try again and fingers crossed in hope that error message was telling you the truth “… try again at a later time.” 😉

    I am pretty sure if it fails it will be around 600 seconds as there is a `set_time_limit` value of 600 set in /bb-admin/includes/

    You could try to increase this value and if that works then we can skip all the direct MySQL hacking that will follow in the next posts…



    Sure, I’ll try tho modify that set_time_limit and tell you what happens



    No luck I’ve tried to increase to 1200 the set_time_limit and then to 2400 but no luck. The odd thing is the error changed to this:


    The requested URL could not be retrieved

    While trying to retrieve the URL:

    The following error was encountered:

    Zero Sized Reply
    Squid did not receive any data for this request.

    Your cache administrator is webmaster. `


    While trying to retrieve the URL:

    That URL now works for me and I even have the option to click ‘Update the database’ (I didn’t).

    Not sure if this is because MySQL was still processing a query behind the scenes as the PHP timeout values differ from the MySQL timeouts.



    That’s odd I don’t know why is that happening.

    Well you can try to click it, you’ll see that it won’t work 🙁

    Done.. Clicked…

    Will post back once it finishes…. In the meantime in your `bb_meta` database table you should have a `meta_key` `bb_db_version` with a numerical `meta_value`. This value determines what SQL queries will be run when the database upgrade is performed (

    If you grab that value I can look at what SQL queries are ‘trying’ to be run and we can then manually run some of them and hopefully by pass the errors.

    Finished as soon as I clicked submit the post above and I think these are indeed differences in the timeouts between PHP & MySQL.



    the value you mentioned is: 2078

    OK…. Can you open the `bb_forums` table and then click ‘structure’ and it should list some indexes ‘PRIMARY’ & ‘Forum_Slug’

    Do you have any other indexes besides those two?



    I’ve got this:


    In that order

    Below that section should be an ‘Indexes’ section…



    Oh sorry, you are right. Indeed I only have the ones you mentioned

    PRIMARY BTREE Yes No forum_id 30 A No
    forum_slug BTREE No No forum_slug A No

    Cool… I am trying to find what previos DB upgrades have been done pre and post 1.02 and 1.2.

    Do you have IRC? If so jump into #bbpress-dev on FreeNode



    Sorry for the late response, I was out for a moment.

    It took me a while to join the channel (it’s been ages since I went to IRC) but at last I’m there 🙂



    Stephen, thanks for all the help, I’ve started the import process and everything started well, but it seems that the import topic process is stalled for quite a while, should I wait a bit more, or is it best to stop it, wait a moment and start it again?

    My turn… Was out for a bit… If it is still stalled click ‘Stop’ and wait a few minutes and click ‘Start’ again.

Viewing 19 replies - 1 through 19 (of 19 total)
  • You must be logged in to reply to this topic.
Skip to toolbar