Skip to:

“Theme not found. Default theme applied.”

  • Hello, I’ve upgraded to Desmond now, yay :D

    But i can’t get my theme to work, i’m getting the message “Theme not found. Default theme applied.” when i try to change theme to both my own and kakumei!

    I’m trying on my localhost and made a new fresh install into another directory, but i still can’t get it work :S

Viewing 8 replies - 1 through 8 (of 8 total)

  • Nate


    See this.

    i’ve tried that! Both of the solutions, but i still can’t use my own template!

    I can’t see the thumbnail of either my template or kakumeis.

    EDIT: I saw what maybe could be the problem. It uses doubleslashes to the link to both Kakumei and my template. Maybe it’s because of that i have my problem? Maybe this could help someone to help me too. (?)



    is there someone who can help me?

    Okey.. I tried to upload it to my internetserver and it works. You can’t try this on your own localhost.. Bad i think..

    When I read your post the first time I missed that you put localhost and that is the problem. Anything before 0.8 you cannot install it on a localhost because there are some issues with it.

    I would imagine you are running this on 0.8 though. The double slashes on the local server would be the issue. Maybe the address wrong on config.php or your setup? There are quite a few people with successful installs on localhost with 0.8.

    It must be a setup issue, but really glad to hear that it works where it is really important, on the web.



    Could you try on your localhost version two of the plugin you tried?

    (Download link at the bottom.)

    First delete the first version of the plugin you have installed.



    I have the same error on LOCALHOST, and also with windows. (my forum hosted on web works :) )

    (thierry is the name of my computer, and is synonyme of “localhost”)

    link I click on to activate my template is such : (there are 2 “”)


    I tried the “patch_to_url_2” in vain.

    a “brillant” idea made me change the themes.php :

    if ( !in_array($activetheme, $themes) ) {
    $activetheme = BBPATH . 'my-templates/2diabolos/'; // THIS LINE WAS 'bb-templates/kakumei/' ...
    bb_update_option( 'bb_active_theme', $activetheme );
    remove_action( 'bb_admin_notices', $theme_notice );
    bb_admin_notice( __('Theme not found. Default theme applied.'), 'error' );

    works well (hopefully)

    (after reflection, I think the following line don’t help)

    I tried to debug a little bit. I put in themes.php

    echo "<br>";
    echo "the theme you want to activate : " . $_GET['activated'] ;

    the result for the first line is good, the “$_GET ” is empty.

    I also am working in Windows via localhost. I also get the “Theme not found. Default theme applied.” error message that flaerpen does.

    After a few hours debugging, I got a fix:

    In themes.php, change the line:

    $activetheme = bb_get_option(‘bb_active_theme’);


    $activetheme = stripslashes(bb_get_option(‘bb_active_theme’));

    I believe that fixes the double slashes added by the webserver.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.
Skip to toolbar