Skip to:

phpbb import Stalled / Hangs

  • agMedia34


    Im trying to import phpbb forums and I know I have the correct database settings.

    I click “start” and it shows “starting conversion” with the little loading wheel and never changes. Load wheel spun from 11pm last night … still spinning at 9am this morning and no change … just “starting conversion”.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Seems a little weird, if you set the number of rows to 100 which is the default it should only take a few seconds before you see either “Converting forums” or “Converting Users”.

    I would double check your phpBB config.php file (it should be in the root folder of your phpBB install.


    // phpBB 3.0.x auto-generated configuration file
    // Do not change anything in this file!
    $dbms = 'mysqli';
    $dbhost = '';
    $dbport = '';
    $dbname = 'your_db_name';
    $dbuser = 'your_db_user_name';
    $dbpasswd = 'your_db_user_password';
    $table_prefix = 'phpbb_';
    $acm_type = 'file';
    $load_extensions = '';

    Make sure you use the correct table prefix.



    I double checked, and I do have the correct config file and correct information, including table prefix. Anything other ideas?

    Is the database on the same database server? Your trying to get a remote database are you?

    There is also a phpBB/WordPress plugin to bridge phpBB to WordPress, are you using that? If so this can be problematic due to modifications it does for phpBB members.



    Yes, it was a remote server and for some reason would not work with the IP … said “no forums found” or something like that.

    Then I moved it (wordpress) to the same server as phpbb because I needed it for the bridge (wp-united) … which I tried, but got mixed up on the MOD installation. Im not a phpbb guy, and know nothing about MODS – also did not want it bridged … but rather pulled over to bbpress.

    So I thought … well try the import now with localhost since it is now on the same server.

    The bridge plugin is deactivated and deleted.

    phpbb settings match exactly with the config file. Though in the database there is both phpbb_ and phpbb3_ for prefixes … phpbb3_ is the one listed in config. But I did try with both just to see and ended up with the same response of starting … but then nothing at all.

    Ive been working on this site now since February, back and forth to fine tune everything and the “very last” piece is to just get his current phpbb into bbpress for “1” platform / admin / user interface vs having 2 separate sites, users, logins, etc.

    Just need to get this wrapped up and find it impossible to get any of the import functions to work via the built in forum import, or the plugins I have tried.

    Argh! Both 😉

    Wherever you are testing all of this, the phpBB database must be on the same MySQL database server, not the same actual database, just the same server.

    I’m not entirely sure what the ‘wp-united’ does to the phpBB members table but there are a couple of topics here on about it.

    Lets skip trying to import phpBB members for a minute and just go with forums, topics and replies for starters. So try your import again without selecting to import “Users”, this should be a good test to make sure that you have a connection to the database and you are indeed using the correct prefix, I expect as you note it most likely should be phpbb3_ as per your phpBB config file.



    Thanks for your help.
    Yes, it is on the same server since I moved it. Just a different database name and user. Also have tried the import without users selected.

    Can you post a screenshot of what you see in the “yellow box” once you start an import, actually also include a screenshot of the settings you are using also please.





    I, too, have a phpbb conversion just stalling part-way through converting posts.

    @mrcupe I replied to the topic you started and is a completely different issue to this one so please reply in that topic only thanks :)

    @agmedia34 That is really weird, I haven’t seen anything like that and your settings seem correct.

    Could outline the software you are using please, e.g. XAMPP, MAMP or is this on a web hosting provider etc, primarily I’m wondering if your site is using a non-standard HTTP port, e.g. http://examplec.com5:8080



    Hosting cpanel is located at … :2083
    Not sure if that makes a difference.

    My client actually decided now to just start fresh with bbpress and archive the old phpbb. However – Im still very interested in sorting this out.

    Thanks again for your help.

    Thanks, the CPanel port won’t matter.

    I expect this is something idiosyncratic with your hosting setup, the best way to confirm this would be to try the import on either a different hosting provider or locally using XAMPP/MAMP.

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.
Skip to toolbar