Skip to:
Content
Pages
Categories
Search
Top
Bottom

Oops! That page can’t be found on Sub Forums with WordPress 4.4


  • KPDub
    Participant

    @kpdub

    Updated to WP 4.4 and sub forums are no longer accessible, getting the Ooops….message

    Tried deactivating all plugins, using a default template and still get the same error.

    IF I go into dashboard I can actually get to the topics from the backend, but its of no use to my site members

    Have asked for my hosting company to reinstall a backup from last 24 hours as my backup failed

    MODERATOR EDIT :

    There is a SUMMARY of this issue and what to do at the end of this thread (or near it) – to save newcomers having to read the whole thread

Viewing 25 replies - 1 through 25 (of 76 total)

  • schwarzkopf.club
    Participant

    @schwarzkopfclub

    i have the exact same problem.
    I tried the permalink solution without any luck and also deactivated all other plugins to be sure there is no conflict.

    Hope anybody can help


    Pascal Casier
    Moderator

    @casiepa

    Hi,
    What plugins are you using concerning user roles or for bbPress ? I know of at least 1 bbPress plugin that has issues with the new WP 4.4
    Pascal.


    schwarzkopf.club
    Participant

    @schwarzkopfclub

    I’m using Members from Justin Tadlock.

    Deactivating it has no effect. Still the same issue


    Pascal Casier
    Moderator

    @casiepa

    Did you copy any bbPress files into a child theme ?
    Are you using any GD tools ?

    (just putting some questions, trying to guess…)


    schwarzkopf.club
    Participant

    @schwarzkopfclub

    Nope and What are GD tools?


    schwarzkopf.club
    Participant

    @schwarzkopfclub

    sry for the double post

    so this is what i found:

    The problems seems to be that the links are generated wrong:

    how it is right now on my site

    http://www.website.com/forums/forum/newforum/

    but it should be

    http://www.website.com/forums/forum/category/newforum/

    so for some odd reason, bbpress is missing the link between the category and the new created forum


    schwarzkopf.club
    Participant

    @schwarzkopfclub

    since i cant edit, i will need to spam ^^

    anyway
    seems like there is an issue with the parent links with WP 4.4
    Hours of searching and trial and error for nothing.
    I just downgraded WP for now and wait till there is some progress.

    Downgrade tutorial by this video:


    timsilva_
    Participant

    @timsilva_

    I believe that am having the exact same issue as well after updating to WP 4.4

    In more detail, here is what is going on. My child board URLs used to link to:

    /forum/categories/parent/child/

    Now, the links point to:

    /forum/categories/child/ (which returns a 404 error, while the link above still works)

    It appears that for some reason the parent category isn’t being included when the URL is generated. The actual URLs all still work the same, but the links that are created are wrong.


    KPDub
    Participant

    @kpdub

    Yeah a rollback worked for me

    In regards to user permission mods, I’ve used a combination of the following (but all were deactivated) and still had the problem.

    Advanced Access Member by
    AG Custom Admin
    Restrict User Access
    User Role Editor

    However, didn’t test this on WP4.3 but my forums were originally created through buddypress, then added extra ones. The group with the subforums was private as were the forums. I was struggling to see them even after the rollback, but making them public solved the problem. This might be a solution here, although I think not as I’d of expected it to find the page but show nothing


    Ger
    Participant

    @lindt01

    Same here; have an automated update plugin istalled and after update to WP 4.4 subfiorums result in a 404-page. Downgraded to 4.3.1 and bbPress subforums are reachable again. When does bbPress come with a patch for this bug?

    Cheers
    Ger


    yo_golo
    Participant

    @yo_golo

    Same here, using the Kleo Theme. I’ve been struggling the past few days to find the issue and finally found out I was not alone.
    The problem is this is happening the same week we’re getting many, many new users and this is has a terrible effect (people thinking our forums are a prank and do not exist for real…)
    I’ll try the downgrade process but any hint/patch would be greatly appreciated from the BuddyPress/BBpress team.
    This bug is a real nightmare and should not happen on such a popular plugin.
    Please DO SOMETHING!


    yo_golo
    Participant

    @yo_golo

    Downgrading partially solved the issue.
    But as I toyed with many settings, I git another issue.
    Whenever I go to a private forum as a participant user, I do not display the posts but directly a post creation form with nothing else around. I have no clue if it’s related or not.
    Really angry about that all.

    Hi Guys,
    I know that people are testing in the background, but please keep your findings coming. I was unable to reproduce the issue myself, but others are busy investigating…
    Let’s hope to have a workaround soon.
    Pascal.


    schwarzkopf.club
    Participant

    @schwarzkopfclub

    Really angry about that all

    As long as you are not a paying customer you have nothing to be angry about. Better help the community to solve this issue instead of just being angry about it πŸ˜‰
    The guys behind this know what they are doing and will soon give us a solution, till then just stick with the previous version and wait πŸ™‚


    yo_golo
    Participant

    @yo_golo

    Very, very True @schwarzkopfclub: anger is useless and I just overreacted because I’ve spent so much time trying to fix this.
    I am conscious it’s a complicated task and that it’s hard to reproduce as all sites are different.
    I’m sure the guys @ BuddyPress will fix this and I’ll be patient. πŸ™‚

    What are your Settings > Permalinks Settings ?

    Any custom structure ?
    Anything in the optional ‘Category base’ or ‘Tag base’ ?
    EDIT: Anyone with buddypress ?

    Pascal.
    EDIT: PS. If you want buddypress to fix this, you’re in the wrong forum πŸ™‚


    KPDub
    Participant

    @kpdub

    Only way I found around that issue was to make the private forums public

    sorry, was meant to quote the issue about not showing private sub forums


    schwarzkopf.club
    Participant

    @schwarzkopfclub

    Permalinks: %postname%

    No Custom Structure or other custom options

    I’m with buddyPress and have there another issue where i’m not able to see any buddypress related links (profile view, notifactions, etc.)

    mad a topic on that in the forum: https://buddypress.org/support/topic/bp-allways-redirects-to-dashboard-broken-links/

    @kpdub
    @timsilva_
    @lindt01
    @yo_golo

    You all have BuddyPress installed ?


    Ger
    Participant

    @lindt01

    @casiepa

    Nope; just bbPress! As I said: downgrade to 4.3.1. worked for me!

    Cheers,
    Ger (lindt01)

    I don’t need to downgrade, mine still works. Trying to get extra information to feed to the team that is looking into the issue.
    thanks.
    Pascal.


    Robkk
    Moderator

    @robkk

    Guys some devs and I are having a hard time duplicating this issue.

    This is how I tested it and come across no issues.

    WordPress: 4.4
    bbPress: 2.5.8

    I tried these default WordPress themes

    2013, 2014, 2015 and 2016

    I tried these forum structures.

    Category > Forum > Forum
    Category > Forum > Private: Forum
    Category > Forum
    Category > Private: Forum
    Forum > Forum
    Forum > Private: Forum
    Category > Category > Category > Forum
    Category > Category > Category > Private: Forum
    Category > Category > Forum
    Category > Category > Private: Forum

    With the postname permalink structure (since it is most commonly used and I want to try to duplicate it)

    Other things I like to ask is if this is a theme side 404 message being outputted or the normal no topics/forums found here message bbPress outputs like the one below (it could be different if you are using a different language than English for bbPress of course).

    Oh bother! No topics were found here!

    If you guys can help ask a few questions like the ones that @casiepa asked and these additional ones.

    What is your bbPress version?
    Have you already tried troubleshooting for a possible plugin/theme conflict?
    Are you guys using BuddyPress groups for group forums?
    Are the issues only happening on private forums? (Like @kpdub has said)
    Did you try the postname permalink structure?

    Another thing I may suggest to help try to gather information for the developers, is to try to duplicate the issue yourself. Try to duplicate the issue again on a local installation on your computer. If you can tell us step by step to duplicate it.

    Creating a Test Site


    schwarzkopf.club
    Participant

    @schwarzkopfclub

    I have a fixed the issue with my buddypress by reinstalling WP.
    The issue with the forum still appears on 4.4
    I will later upload my files for you guys.
    And also will try to tell explicit what I have done to get this, even on a fresh installment


    timsilva_
    Participant

    @timsilva_

    Thanks for jumping on this everyone, it’s appreciated. πŸ™‚

    @casiepa I have WP 4.4 with BuddyPress, bbPress and WooCommerce in a local environment. No fancy permalink settings, except for the root forum slug set to “forum”. But to be sure, here is a screenshot of my forum’s permalink settings: https://i.imgur.com/X6jfnrQ.png

    I also should have mentioned before that all of my parent & child forums are set to private.

    @KPDub I tried the same thing that you did by turning the parent forum from private into public. That worked to solve the incorrectly generated URLs! It does require making the parent forum public though, which we obviously don’t want all users and guests to see. So it appears that the issue has some relationship to parent forums being set to private.

    Here is my actual structure that always works:
    /forum/categories/parent/child/

    After WP 4.4, if the “parent” forum is set to “Private”, then the forum links to:
    /forum/categories/child/ (which returns a 404 error, while the above link still works)

    After setting the “parent” forum to “Public”, the correct URL is made again:
    /forum/categories/parent/child/
    …but, the leaves the “parent” forum’s threads visible to everyone.

    @schwarzkopfclub If my information in this post doesn’t lead to replication of the bug, I will try to make it happen from a fresh setup. πŸ™‚

    @robkk My 404 error is my custom theme’s version (theme/404.php), not the “Oh bother” one that bbPress includes.


    tharsheblows
    Participant

    @tharsheblows

    Thanks. The issue was introduced in WordPress 4.4 and there’s a patch available now. Could you test it to see if it makes it work for you? https://core.trac.wordpress.org/ticket/35084

Viewing 25 replies - 1 through 25 (of 76 total)
  • You must be logged in to reply to this topic.
Skip to toolbar