Skip to:

No topics shown to forum participants

  • Hi,

    I installed bbPress 2.0.2 on WordPress 3.3.1. Embedded it in the site of a customer. There are some forums created. All are Forum, Open and Public. Some topics are added by an Administrator. So far everything ok.

    When a user with role Forum Participant logs in, it can access the forum, but no topics are shown:

    This forum contains 4 topics and 0 replies, and was last updated by xxx 1 min ago.

    Oh bother! No topics were found here!

    Administrators do see the topics. What is happening here?

Viewing 21 replies - 1 through 21 (of 21 total)

  • ernohannink


    Even changing the roles to “Forum moderator” and installing the “Members” plugin ( did not change anything (working on the same issue)




    – Forums are set to; Type: forum, Status: open, Visibility: Public

    – Topic are set; Status: Published, Visibility: Public

    Topics are shown when you set them to Sticky. However they are visible to guests also.

    Anyone? I reproduced the same behavior on another site which I am working on.

    Looks like a line in content-single-forum.php doesn’t return any results:

    <?php if ( !bbp_is_forum_category() && bbp_has_topics() ) : ?>

    However as an Administrator it shows the results. Any other role doesn’t.

    Hi, I’m having this issue too.

    I originally installed this plugin in September 2011 and it was all working fine.

    Today I upgraded to the latest version of WordPress, and also BBPress, and now only admins can view the topics, everyone else gets the ‘Oh bother!’ alert.

    I had an old backup of the old BBPress plugin so I replaced the new with the old, but no change.

    The site I’m using is a staging site, ie it’s not ‘in use’, and I’ve not touched it or tested it since September, so I can’t be certain that the error is due to the WordPress upgrade…though as I mentioned nothing has happened on the site since then so it’s surely not a coincidence.

    I installed everything new on a seperate domain with the same theme. Everything works there.

    I am curious if there is a way to debug the query of bbp_has_topics. Something must be wrong there.



    god, i am having the same issues. man i really like this forum, but it’s so buggy. there must be some way to fix this. anyone?



    Same here. Need help with it!

    Ronald Rogers


    Chipping in to reinforce that this is not an isolated issue.

    On my forum it happens intermittently with no real indication as to why, and goes on for what seems like several minutes. Its quite insidious.

    A user of mine reported that it started right after he posted a topic, so the problem may be related to topic creation. For some reason, it smacks of a recount issue to me.

    John James Jacoby


    None of it really makes any sense. When we have a moment to all dig in deeper, I’d like to access someone’s installation directly to look into it.



    John how do we contact you?



    This is still an issue for me? Any help here? This is an obvious bug.



    Noticed something new at composthere DOT com

    First tier? forum topics are visible. See About Compost Here and how it works

    bbPress shows that a topic is posted in

    Home › Forums › Compost Bin Available › Canada

    but in

    Home › Forums › Compost Bin Available › Canada › Vancouver, BC area

    the error message appears.

    Could that be a factor?



    I have installed bbPress 2.02, but I do not see any difference between using this application or not. Is there something wrong when I download and use this application?



    Same here. I Need help.

    I did all what read here but ther is nothing I ca do.



    Has a solution been found for this issue? I’m pretty much having the same issue.

    This forum contains 1 topic, and was last updated by Admin 12 hours, 7 minutes ago.

    Viewing topic 1 (of 1 total)

    After “viewing topic 1” no topic is shown. my theme is bbpress compatible, I’ve tried disabling all plugins except for bbpress. nothing seems to work. any insight?



    No, I have not found a solution.



    I have the same problem. My participants can’t see the topics, but when I change their permission to moderator, they can. But I don’t want them to be moderators.



    This just happened to one my sites today. Looking through the forum, I tried a few different methods of repairing or optimizing my database, but to no avail. Anyone have a better way to tackle this?



    @ecorey @basemaly

    Alright make sure both of you have gone through these troubleshooting steps.

    • Deactivate all plugins except bbPress.
    • Switch to a default theme
    • Flush permalinks by switching to default , save , next switch to your preferred structure then save again
    • Clear any cache
    • Go to Tools > Forums > Repair Forums then run each repair job one at a time.

    Does it Work??

    If it does work now, activate your plugins one at a time and make sure to spot the one that might have caused the issue.

    Not a plugin issue??

    You can try these plugins one at a time to see which one helps.

    bbpress wp4 fix2

    bbpress wp4 fix

    And hopefully it works after all that.

Viewing 21 replies - 1 through 21 (of 21 total)
  • You must be logged in to reply to this topic.
Skip to toolbar