Skip to:

No "bbPress – User Register" in template?!

  • archer09


    Hi, I’m trying to create a bbpress Registration page so that users can register and start posting on my website’s forum. I’ve read through the tutorials on how to do this but there’s a problem. After adding a new Page, under Page Attributes we are supposed to select “bbPress – User Register” as the template. But I don’t see this as an option on the dropdown menu at all.

    In fact, the dropdown menu has nothing related to bbPress at all. I’m starting to wonder if the plugin wasn’t installed properly, but the rest of it seems to work fine (eg. I can create forums/threads etc and these are showing up).

    Any help on this would be much appreciated! Thanks.

    FYI, I’m using bbPress 2.1.3, BuddyPress 1.6.1 and WP 3.4.2

    • This topic was modified 11 years, 7 months ago by archer09.
Viewing 8 replies - 1 through 8 (of 8 total)

  • lesliemb


    I’m having the same issue, and I’m wondering if anyone has found a solution. I’ve been browsing these forums (as well as other sites) for a couple of hours and haven’t yet found anything that works.

    I’m using WordPress 3.5, BuddyPress 1.6.2, and bbPress 2.2.3. I am using the BuddyPress Default theme.

    Thanks so much!

    Is it the shortcodes you are looking for?



    Unfortunately, shortcodes aren’t working for me, either.

    Any other leads?

    Thanks so much for your help.

    There are no known bugs regarding shortcodes so they should work on your site.

    • Create a new WordPress page via /wp-admin/post-new.php?post_type=page
    • Give the page a title
    • Add for example to login shortcode `[bbp-login]` to the page content
    • Click publish and view your new page



    When I add the shortcode and click to view the page it redirects me to the home page. Is there a setting somewhere that I am missing?

    No, it should just work.

    If you have links to your site this really helps us to see exactly what your issue might be.



    OK. . . The plot thickens. I just checked, and the register link is working at — but not when the URL has a www in front of it. redirects to the home page. I haven’t seen this problem on my other WordPress sites–the URL with or without WWW sends users to the same place.

    So. . . Is there some kind of setting I should be looking for at my webhost to fix this WWW/no WWW issue?

    Thanks again.




    Argh. Now the opposite is true– doesn’t work, and the other does. The change happened when I removed “www” from the WP and site URLs in Settings –> General, as described here:

    Any ideas?

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.
Skip to toolbar