Skip to:

Importing SMF

  • Theresap


    Thank you for the work on the importer!
    I’m using the latest of wp and bp – this is a fresh install.
    I’m still getting this error screenshot
    I’ve updated the file in the /converter file to the 5191 revision.

    I know I have the db info correct.

    Any ideas would be very appreciated. Thank you!

Viewing 7 replies - 1 through 7 (of 7 total)
  • It looks like you left out the table prefix, SMF typically uses smf_

    Double check by opening your SMF Settings.php file in the root folder of your SMF install:

    ########## Database Info ##########
    $db_type = 'mysql';
    $db_server = 'localhost';
    $db_name = 'db_name ';
    $db_user = 'db_user ';
    $db_passwd = 'db_passwd ';
    $ssi_db_user = '';
    $ssi_db_passwd = '';
    $db_prefix = 'smf_';
    $db_persist = 0;
    $db_error_send = 1;

    Also if you are going to use versions of the importer from the source repo you will need to ensure you also are using the matching the revision of converter.php.

    Also not quite sure how you landed on the r5191 revision, there are quite a few since then and a few before!



    Hi, thanks for the reply!
    I actually used this revision first, (smf.3) Is that correct? I tried the other afterwards thinking it was more recent. (I don’t think well after 9pm ha) In any case neither worked for me. :)
    I retried all the steps this morning. I checked the database info…
    I have the prefix right, it’s smf_; I had found your earlier post when someone posted the same issue, so I checked that before posting. For the revised converter, you mean once you upload the patch, pick the correct revised converter from the drop down…? I checked that too…deleted the previous and uploaded the new patch along in case it wasn’t overwriting.

    I’m out of ideas – could the database be too big? We have about 8K users.
    Thanks again, truly appreciate the help on the forum. Theresa

    Oh! The version included in bbPress 2.5.4 is the r5191 version, the smf3 you refer to is older than that, essentially there is no need to download any files from trac manually to replace the files that already exist in bbPress 2.5.x.

    That said “if” you do download any versions of the importers from trac, you need to match the main bbPress converter.php file, this is not the ‘dropdown’ you refer to.

    Looking closer at your original message, indeed you did use the smf_ prefix, my bad.

    Can you open up phpMyAdmin and open the smf_members table and post a screenshot like mine below (if there is sensitive data there then just the column headers would be fine)

    For some reason it appears your table is missing the member_name column and that is why the error occurs.

    What version of SMF are you trying to import?

    And lastly, no forum is to big for bbPress 😉



    Hi Stephen,
    Could the member column be missing the _ ? between the member and name? Mine doesn’t look like yours.

    The SMF version is 1.1.11.

    you need to match the main bbPress converter.php file, this is not the ‘dropdown’>>>>So, I would have needed to find a previous version of a converter..okay getting lost.

    Yes, so I did delete and reload bbpress, and tried without any patch, just fresh, still didn’t work.

    Ah… That’s the reason, bbPress only supports importing from SMF 2.x and your using 1.x.

    It looks like significant database schema changes so I’d take a look at upgrading your database to SMF 2.x first and once done then import to bbPress 2.x :)



    Yay!!! A glimmer of hope, I’ll try it!!

    Thanks so much again! Theresa

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.
Skip to toolbar