Skip to:
Content
Pages
Categories
Search
Top
Bottom

Import from phpBB comes back empty


  • muskratt
    Participant

    @muskratt

    I’m running WP 3.9.1 and the latest copy of the plugin on a very vanilla site with not much on it yet.

    phpBB 3.0.12, Tap-a-talk is the only mod it’s running
    Database size: 20MB, about 6000 posts total

    I’ve tried this twice using the remote server (after adding the WP server’s IP to the allowed remote MySQL connections) as well as on the same local server doing a sqldump from the remote into the local box. Both times, I get the scrolling of text showing nothing to import/convert and it finishes without error (aside from the fact nothing is imported).

    This forum was originally vBulletin 3.x and it was converted to phpBB about a year ago but I don’t believe this should have much to do with it since there is no other modification/customization running except Tap-a-talk.

    Where to go from here?

Viewing 9 replies - 1 through 9 (of 9 total)

  • Robin W
    Moderator

    @robin-w

    bumping in the hope that Stephen will see this :-)

    We are not supporting importing form a remote database at this stage, theoritically it shouldn’t be that difficult with the correct access in place, but not at this stage.

    It should work fine if you have a copy of your database locally though, most likely this is you didn’t select phpBB from the dropdown menu on the import screen.

    Robin: I had a horrid week last week and am still catching up, read through 1/2 of bbPress.org this arvo and I will write a heap of replies tomorrow 😉


    Robin W
    Moderator

    @robin-w

    @netweb – hey good to hear from you, your expertise was missed :-)


    muskratt
    Participant

    @muskratt

    I had phpBB selected and have tried it several times using the local copy of the database. Is there a debug option to see what is going on when the import is attempted?

    Server details:
    Ubuntu 14.04 LTS running Nginx with Apache on the back end. Database of course is MySQL.


    muskratt
    Participant

    @muskratt

    I ran the converter again and got the same results. Screenshot: http://postimg.org/image/p08kz21el/

    Suggestions?

    Thanks!

    I see you do not have a database table prefix in your settings?

    Check your phpBB database tables, most likely they have a prefix of phpbb_

    Here is a snip from my phpBB database, as you can see the database is named ntwb_phpbbv3 and all my tables have a prefix of phpbb_, check what your database prefix is and try adding that to your settings.


    muskratt
    Participant

    @muskratt

    I ran it again using the phpbb_ prefix as directed however still nothing is imported.

    So is there some type of a debug log that is generated that I can look at?

    Can you open up phpMyAdmin and post a screenshot similar to that of mine above showing the table names within your phpBB database please.

    As for a debug log, there kind of is one, if you right click e.g. “No topics to convert” and select inspect element you should see some SQL queries similar to the below screenshot (These are not phpBB in the screenshot, just what I have been working on)


    Peggy
    Participant

    @lpjjonine

    I’m having a problem importing a vbulletin forum into bbpress. It keeps telling “no forums to convert”, “no comments to convert” for every item “no ….. to convert”. I didn’t create the old site I am taking this from but when I got to page source, I see vBulletin 3.8.2 so I’m guessing that’s the version it is.

    Also the database doesn’t show any table prefixes, it just has “access” as the first one, “adminhelp” as the second and so on.

    The site is http://troianiwebdesign.com/gulfstar if you need that.

    Please help me figure out the problem so I can get this moved over!

    Thank you!

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.
Skip to toolbar