Skip to:
Content
Pages
Categories
Search
Top
Bottom

HELP: Editing post_parent directly in database not working.


  • Papat0k
    Participant

    @papat0k

    Hello,

    I am using WordPress 4.8 and bbPress 2.6-beta-2.

    I had to do a batch import of topics from csv, and all went well enough. The only aspect I was unable to cover was the parent forum field. I have found my parent forum id and used a mysql command to insert the forum ID (which is 290 in this case) into all rows where post_excerpt meets a condition. This all worked. For reference here is the mysql command:
    update wp_posts set post_parent=’290′ where post_excerpt=’CONDITION’;

    The issue I’m having is that although post_parent displays the correct parent forum ID within the database, on the frontend of my site none of these topics register as having a parent forum. Under “Topics” they still all say “No Forum,” and they are not listed on the forum page. Funny enough, the breadcrumbs show the correct path when looking at the individual topics (i.e., PARENT FORUM >> POST_TITLE).

    Any and all advice would be greatly appreciated. Thanks for your time.

Viewing 3 replies - 1 through 3 (of 3 total)

  • Robin W
    Moderator

    @robin-w

    I’d suggest you try a few repairs

    dashboard>tools>forums>repair and run one at a time


    Papat0k
    Participant

    @papat0k

    That’s a good suggestion. I’ll look into it. Thanks. In the interim I’ve been changing “post_type” to “post” and using bbP Move Topics to migrate one chunk of topics at a time. It’s not a “clean” way of doing things, but it’s solved the issue for now.


    Robin W
    Moderator

    @robin-w

    great – thanks for the update

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.
Skip to toolbar