Skip to:
Content
Pages
Categories
Search
Top
Bottom

Forums working great, but we cant log in S.O.S.

Viewing 8 replies - 1 through 8 (of 8 total)

  • chrishajer
    Participant

    @chrishajer

    The quick and easy solution is to turn off permalinks in the config until you get the rewrite rules sorted out.

    Would this solution that someone posted today be of use?

    https://bbpress.org/forums/topic/problems-with-navigation-to-profile-page-and-posting?replies=4#post-12589


    toxicshocktv
    Member

    @toxicshocktv

    I actually already tried that. Here’s my config as of now:

    <?php

    // ** MySQL settings ** //

    define(‘BBDB_NAME’, ‘toxicsho_bbpress’); // The name of the database

    define(‘BBDB_USER’, ‘toxicsho_****’); // Your MySQL username

    define(‘BBDB_PASSWORD’, ‘******’); // …and password

    define(‘BBDB_HOST’, ‘localhost’); // 99% chance you won’t need to change these last few

    define(‘BBDB_CHARSET’, ‘utf8′); // If you are *upgrading*, and your old config.php does

    define(‘BBDB_COLLATE’, ”); // not have these two contstants in them, DO NOT define them

    // If you are installing for the first time, leave them here

    // Change the prefix if you want to have multiple forums in a single database.

    $bb_table_prefix = ‘bb_'; // Only letters, numbers and underscores please!

    // The full URL of your bbPress install

    $bb->uri = ‘http://www.toxicshock.tv/board/';

    // What are you going to call me?

    $bb->name = ‘Toxic Shock TV Forum';

    // This must be set before you run the install script.

    $bb->admin_email = ‘toxicshocktv@gmail.com';

    // Set to true if you want pretty permalinks, set to ‘slugs’ if you want to use slug based pretty permalinks.

    $bb->mod_rewrite = ‘false';

    // The number of topics that show on each page.

    $bb->page_topics = 30;

    // A user can edit a post for this many minutes after submitting.

    $bb->edit_lock = 60;

    // Your timezone offset. Example: -7 for Pacific Daylight Time.

    $bb->gmt_offset = 0;

    // Change this to localize bbPress. A corresponding MO file for the

    // chosen language must be installed to bb-includes/languages.

    // For example, install de.mo to bb-includes/languages and set BBLANG to ‘de’

    // to enable German language support.

    define(‘BBLANG’, ”);

    // Your Akismet Key. You do not need a key to run bbPress, but if you want to take advantage

    // of Akismet’s powerful spam blocking, you’ll need one. You can get an Akismet key at

    // http://wordpress.com/api-keys/

    $bb->akismet_key = ”; // Example: ’64f1b30caafe’

    // The rest is only useful if you are integrating bbPress with WordPress.

    // If you’re not, just leave it as it is.

    $bb->wp_table_prefix = ”; // WordPress table prefix. Example: ‘wp_';

    $bb->wp_home = ”; // WordPress – Options->General: Blog address (URL) // Example: ‘http://example.com’

    $bb->wp_siteurl = ”; // WordPress – Options->General: WordPress address (URL) // Example: ‘http://example.com’

    /* Stop editing */

    if ( !defined(‘BBPATH’) )

    define(‘BBPATH’, dirname(__FILE__) . ‘/’ );

    require_once( BBPATH . ‘bb-settings.php’ );

    ?>

    Change the following:

    $bb->mod_rewrite = 'false';

    to:

    $bb->mod_rewrite = false;

    Trent


    Sam Bauers
    Participant

    @sambauers

    Trent’s right. The string ‘false’ equates to the boolean TRUE. Which means you have basic permalinks turned on.


    toxicshocktv
    Member

    @toxicshocktv

    Still a no go…. Tried with the false and it still isn’t working. I switched over to the old template, and it worked for a little while — until I logged off once, then it wouldn’t log back in.

    Logins and such are best used with default everything until you know they work. Try the default template again and report back any specific things you have going on there. As well, once you start fiddling with integrating with WP in the config.php it will use the WordPress members. Another thing if you don’t have Akismet setup would be to put:

    $bb->akismet_key = false;

    Trent


    toxicshocktv
    Member

    @toxicshocktv

    The template I’m using is totally stock (except the header color/image) that I added. Would that actually cause a problem?

    Also Tried the $bb->akismet_key = false;

    No luck yet – thanks for your help Trent.


    toxicshocktv
    Member

    @toxicshocktv

    I’m going to try a fresh reinstall and see if I can get it working, otherwise I’m off to Vbulletin. :(

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.
Skip to toolbar