Skip to:
Content
Pages
Categories
Search
Top
Bottom

Forums, Topics, and Replies not showing up on forum pages


  • jmulakala
    Participant

    @jmulakala

    I’ve been stuck on this problem for a while now. We recently migrated our website from Rackspace to AWS hosting. Reinstalled wordpress, bbpress, and was able to migrate most of the site. Now I’m having problems with the Forums, Topics, and Replies.

    On my forum page it shows the number of topic and replies, but when you click on it, it doesn’t show them, and on the topics you can click on, it won’t show the replies. I exported them using Tools>Export and exported Forums, Topics, and Replies, and imported them the same way, assigning them users. I can see every topic and reply in the wordpress panel, just not in my forums.

    My forums can be seen here http://freeskies.co/forums/forums/.

    This problem also affects new topics. When I create a new topic, it will remove all of these topics and posts and reset the count, even though i can still see them in the wordpress panel.

Viewing 6 replies - 1 through 6 (of 6 total)

  • Pascal Casier
    Moderator

    @casiepa

    Did you run the repair and recalculation tools ? That should normally fix it if the import was successful.
    Tools > Forums > Repair Forums
    Run one at a time.
    Pascal.


    jmulakala
    Participant

    @jmulakala

    I did. In fact, after I ran about 6 of them, one after the other, working my way down, it kills the blog completely, throwing a server 500 error. I’d have to reset bbpress and start the import again.


    Pascal Casier
    Moderator

    @casiepa

    For importing, did you try to do it in test on bbPress 2.6-alpha (https://downloads.wordpress.org/plugin/bbpress.zip) ?
    Importing has improved a lot in that version.

    Pascal.


    jmulakala
    Participant

    @jmulakala

    Tried out bbPress 2.6-alpha. Still didnt work.


    jmulakala
    Participant

    @jmulakala

    Now I’m getting 404 page errors from Google. Any help would greatly be appreciated!


    LevyImage
    Participant

    @levyimage

    I’m having the same problem, the source of which is because USER IDS aren’t matching between each installation. When importing new users, a new user ID is generated for each account on the new installation, so BBpress is not able to recalculate properly since author ID numbers for forums, topics, and replied do not match. It would be GREAT if BBpress had a recalculation method based on USER EMAIL instead of user ID. IDs change between installations but emails usually do not when transferring between wordpress installations. Very broken atm.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.
Skip to toolbar