Skip to:

first entry missing on single topic page // visible only for admin

  • 3.4.1 + 2.1 Hi, not sure if this is a bug or feature but when a user is creating a new topic the post does not show up aferwards … only for the admin. So this seems a right problem but I test it with all set to public. When the creator clicks on edit the post content shows up again … wired.

    UAM – user access manager plugin deactivated and problem gone but that is not a solution. Any idea how to fix it?

    Why is the topic body missing on the single topic view for all but the admin??? Please help.

    Thanks and cheers, alex

    • This topic was modified 11 years, 11 months ago by AlexJS.
    • This topic was modified 11 years, 11 months ago by AlexJS. Reason: UAM Problem
Viewing 12 replies - 1 through 12 (of 12 total)

  • John James Jacoby


    Sounds like your UAM plugin is misbehaving or is not configured correctly. Anyone with more experience able to chime in?

    I wonder if it has anything to do with administrator privileges vs. subscriber privileges. I am having a similar issue, however the only UAM type plugin I have is Magic Members. I am not sure what privilige I have to give the subscriber to be able to view the topic post?

    Here’s the list of bbPress User Roles and Capabilities if that helps:

    I checked the privileges of the what my subscribers have vs. what bbpress users have, and it matches. I am not sure what the issue is.

    We are having this same problem and I need your help!

    wp 3.4.1, bbpress 2.1.2, Elegant Themes

    When I’m logged in as admin, I can see all topics and all replies in the forum.

    When I’m logged into the website (front-end) as a user of the website, I can ONLY see the second and on replies – the original entry/post is missing.

    We have s2member, but this problem used to NOT exist, and there haven’t been any updates to s2member. I think the only thing I’ve done is update bbpress from 2.? to 2.1.1. I updated 2.1.1 to 2.1.2 today to see if it’d help and it didn’t. I hate that I can’t be more specific.

    But basically, it seems to be when I’m logged in as a user of the website, I can only see replies and not the original post.
    I’d greatly appreciate any help, I’m quit unsure what to try next!

    I’ve at least found a work around although I don’t understand the cause.

    s2member has an option of “Alternative View Protection”. When I work with this option, the original post displays. I definitely don’t understand the relationship between s2m and bbpress on this (why this option hides the original post), but I’m glad the original posts are showing!
    Do share any thoughts!



    I’m having the exact same issue, but I am using “Advanced Access Manager”. This is driving me crazy, its even effecting public posts, but I run a few forums that are private and/or hidden. Anyone figure anything out here?



    I’ve got the same issues, but in addition the “Add New Topic / Reply” is missing from the Dashboard for everyone except the administrator. I’ve matched the user rights in UAM to match bbPress User Roles and Capabilities. But nothing changes.

    Any ideas?



    Hi! I found the problem, but not the solution,

    I realized that if I check the option in the UAM to “Hide Potst” completely it also hides the first topic; if i unchecked it, the first topic is shown again.

    Maybe it could help for anyone who understand the mechanisms of those plug-ins.

    -Sorry for my english, i’m spanish and i’m using the spanish translation, so i can’t say exactly the option to check or uncheck, but it’s the first one in the Adjusts/Options for UAM-



    OK Guys,

    I worked this out it is definitely linked to the memberships plugins being used. I found that for non members they were not seeing the first post. I then disabled the membership plugin and found that the non members could now see the first post.

    I re-enabled the membership plugin (Paid Membership Pro) and looked for a setting which might be causing this behaviour. I found it in PMPro – Membership>Filter searches and archives? I set this option to “No – Non-members will see restricted post/pages in searches and archives”. and tada it is now working.

    This setting’s description is a little misleading on first glance but I assure you non-members will not see restricted forums or topics.

    I know other people have has similar success in their chosen membership plugin so look for that elusive setting and test it out.




    Camo that’s not a solution [at least for me], in UAM you can make the same, here are my results with your option:
    If I select “No-Non-members…”
    No-Non-member selected

    Then The first message is shown, but I can also see the other (hidden) posts [look at left column] [although i can’t see the info in them, because it’s hidden, I see them, so they are not secret]
    First message shown but also the hidden posts

    If I select “Yes – Only members…”
    Yes - Only Members...

    Then the first message is hidden, but also the posts [what I’m looking for]
    Hidden posts, AND first message

    So, this is not a solution if you [as me] want to show the first message, but hide the rest of posts.



    This fixed the problem for me. I’m not sure why, really, but hey, it worked.


Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.
Skip to toolbar