Skip to:

Error You dont have permission to create new topic

  • sumitimmortal


    I am using WordPress Version 3.5.1
    along with bbPress 2.3.2 and buddy press Version 1.7.1
    I have encountered a problem when I try to add post. It gives me a error message – “You dont have permission to create new topic”
    Website Link:
    whenever I try to post a topic on forum as An Administrator or Keymaster.
    But when I try to post with Moderator rank or any other The post gets added.

    Can anyone please hep me on this.

Viewing 3 replies - 1 through 3 (of 3 total)

  • mangtimo


    Encountered the same issue a couple of days ago.
    I was able to fix this by going to Tools > Forums.
    and try this option – Remap existing users to default forum roles
    Although I actually did every option before checking if everything was working, I’m suspecting that one fixed the issue.



    @mangtimo thanks for the reply..
    My forum is live and public forum, and I dont want to loose any of my users post or database.
    I am ready to try what you are suggesting but are you sure this step will not affect my forum posts and database of users..?
    Once again Thank you 🙂



    Fixed the issue I was having with this same error.

    Whew… after lots of searching and turning plugins on and off, I found the conflict and it was actually just settings that were defaulted incorrectly the Ultimate Member plugin with it’s add-on Extension for BBPress (premium plugin from Ultimate Member extensions bundle).

    The Ultimate Member BBPress extension has settings for every user role in the Ultimate Member > User Roles section, and in those settings it has permissions for BBPress that override BBPress settings. In those settings there are checkboxes for each permission, including posting replies, posting topics, etc. Customer roles, admin roles, and a bunch of other roles were for some reason defaulted to not allow these types of posts.

    To fix Ultimate Member permission settings, go into each role and enable the features / permissions accordingly.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.
Skip to toolbar