Skip to:

ERROR: Are you sure you wanted to do that?

  • april


    I’m having some issues with this plugin. Hopefully someone here can help.

    I’ve installed on a local installation, using Instant WordPress.

    I’ve read everything on here about this error and it’s all about ports but I do not know how to make a change to a) Instant WordPress or b) bbpress to fix the issue.

    My error is ERROR: Are you sure you wanted to do that?

    Yes. Yes I am.

    Can anyone offer some insight? Explain it like I’m 5, because the existing answers do not seem to work for me.

    I have the most recent versions of WordPress and bbpress installed. I can create forums and topics with the WordPress dashboard, but not replies. I cannot create forums, topics or replies using the plugin at all.

    Thank you!

Viewing 18 replies - 1 through 18 (of 18 total)

  • enewsdigest


    Dear April,

    I am having the same issue. I also am deploying and testing in Instant WordPress. Have the same problem. Pity no one has come to rescue till now.



    I think this has to do with the fact that we are developing on a local machine and not on an actual server. I have seen multiple issues opened because of this error, but no one seems to want to resolve this issue at all. I resolved it by just uploading it to an actual server and working from there. Yes it’s more tedious, but until someone comes forward with how to fully resolve this issue on local machines, you’re stuck with that solution. For styling, I ended up doing the above, throwing in a lot of replies and topics, then dumped the html into a stand-alone html file. Then styled from there on the local machine and re-uploaded the css afterwards. It more than triples the time and work, but it works. If you have a client, just let them know that is the only way as for now. As for why you’re getting the error, I understand it that bbPress logs the ip from the user each creation of a topic/reply and does not recognize or localhost as valid ip’s (which is what most MAMP/WAMP installs use). WordPress is fine with it, but not bbPress, or so I understand it.

    Bumped into this while developing locally, a solution is to filter the requested url in bbp_verify_nonce_request:

    add_filter( 'bbp_verify_nonce_request_url', 'my_bbp_verify_nonce_request_url', 999, 1 );
    function my_bbp_verify_nonce_request_url( $requested_url )
        return 'http://localhost:8888' . $_SERVER['REQUEST_URI'];

    Robin W


    @donutz – thanks for sharing that, I’ll add it to the codex when I get a moment !



    Where do I have to add that code? I just tried adding it in my functions.php, but that doesn’t seem to work. I’m also working locally, using Bitnami.



    Hello, same question here… Where should we add the code shown in Peter J. Herrel’s post? I searched and couldn’t find a reference to this in the codex. Thanks!



    thanks @Peter J. Herrel worked a treat.

    @roodigi you add it to your functions file.



    Many thanks to all on this post.
    Adding the filter to the functions.php file as in this solution worked for me.



    Thanks for sharing



    Whenever that’s happened to me it’s because I’ve had the page open too long, or opened in another window (often on another computer). The page changed elsewhere and I’m trying to make changes to an old draft. Not sure that’s the case here, but it did just happen yesterday for that very reason. Refreshing the page and then making edits always fixes for me.



    @donutz Hy Peter, where can I Insert the code you wrote?

    My site is in a internal server, and i didnt understand where I insert this code.




    I found the solution… the fix for this was in the function.php of another theme, and I changed it.
    Now I inserted the cde on the bp-custom.php and its safe no more loose this fix.

    Thank you guys



    Thanks for sharing :)



    hey guys. thanks so much for this fix on localhost. Works perfectly



    i have problem error are you sure you wanted to do that on xampp. please help me.. thanks guys



    I’m running a local host with xampp and getting this error when trying to run a test forum. I have done all the forum repairs and still have the same issue.

    Can anyone explain on what line exactly this function code should be applied and how it should look. Screen shot perhaps? I have no experience in php but doing everything I can to learn as much as possible.



    You add the php code snippet to your child themes functions.php or in a functionality plugin that can hold custom code snippets to fix this issue if you have a port number in the urls while using xampp server.



    Added it in functions.php and it works, saving me to get nuts!


Viewing 18 replies - 1 through 18 (of 18 total)
  • You must be logged in to reply to this topic.
Skip to toolbar