Skip to:

Editing Plugin files for Plugin Browser Installed Plugins?

  • Hello all,

    I’m using the Plugin Browser by SamBauers.

    I have a few plugins that I was using, and installed through this plugin (great stuff, btw) that I had modified the files on slightly. Main example here is the Page Links plugin- I had changed the page icon graphic to be different colors. I would like to overwrite the file in the Plugin Browser installation of the file, however it tells me I don’t have permissions to overwrite the file- or change permissions on the folder or files inside it.

    Is there an easy work around for this, or should I just go back to the non Plugin Browser version? :) Thanks!

Viewing 5 replies - 1 through 5 (of 5 total)

  • Sam Bauers


    The files and folders need to be writable by the webserver user. You may have changed the permissions when you edited the files that exist there already.

    The easiest approach (but insecure on shared hosting services) is to chmod the files.

    chmod -R 777 bbpress-root/my-plugins


    Or you can change ownership on those files to the webserver user, usually “www” or “apache” depending on the setup.

    chown -R www:www bbpress-root/my-plugins


    Remember that the upgrade facility of the plugin browser won’t maintain your manual changes to the plugins. You will need to re-edit the new versions.

    Plugins that are installed normally will happily co-exist with those installed by the plugin-browser. Just keep them outside of the pb–xxxx folder structure.

    Hi Sam! Thanks for the reply.

    I’ve already tried to chmod the files- I get a “you do not have permission to modify these files” on all the files, no matter what permission level I tried. I’ve got pretty extensive web experience, so that was the first thing I tried.

    I guess for now I’ll go back to the non plugin install- I was just curious if there was something written into the Plugin Manager that caused the file permission settings to be locked. Seems odd that I can’t even overwrite a .gif file!

    Thanks for the overview and clarification. :)

    Sam Bauers


    Did the “you do not have permission” message occur on the command line? If the user you login as on the server doesn’t own the files you will need to do the chmod-ing as root. If you don’t have root access, then I have no idea how you edited the files in the first place.

    The plugin doesn’t do any checking to determine whether the files are writable. It probably fails quite horribly if you have set PHP to write errors to the screen.

    How odd… I don’t have any problem editing ANY other files on my server- just the files your plugin installed. Really strange.

    I’m using an FTP program, not the command line- that may yield different results. I can’t be root, that’s for sure- on a shared host.

    I’ll see what I can figure out- thanks Sam. that’s what I needed to know.

    I’ve reverted to the non plugin installed version (couldn’t even delete the plugin via FTP program, I had to do it through the Plugin Manager interface.) and made my changes.

    For now, I’m just keeping the plugins I don’t need to tweak installed through plugin manager- it cuts back on checking for updates at least, so thanks! I’m puzzled as to the cause, since it only seems to be the files created by your plugin effected. It may be something my host has done, I’m unsure.

    Thanks for the thoughts!

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.
Skip to toolbar