Skip to:

Can’t post. Topic turns yellow. Can’t delete.

  • Nola1974


    I just got finished posting a whole bunch of posts a little while ago. Worked on my theme a bit.. added this to the header, that’s it:

    function w3l_tl_pages($before = '', $after = '', $between = ' ') {
    global $wpdb;
    $query = "SELECT ID, post_title FROM $wpdb->posts WHERE (post_type = 'page' AND post_status = 'publish' AND post_parent = 0) ORDER BY menu_order";
    $pages = $wpdb->get_results($query, ARRAY_A);
    $temp_pages = array();
    foreach ($pages as $page) {
    $temp_pages[] = $before . '<a href="' . get_bloginfo('url') . '/' . get_page_uri($page['ID']) . '">' . $page['post_title'] . '</a> ' . $after;
    echo implode($between, $temp_pages);

    This is to get the menu of pages from my install.

    Now, whenever I try to post, after I submit a new topic, it turns yellow and doesn’t not then appear in the discussions list.

    I can’t delete ANY posts. Not even old ones.

    THe new topics appear in the dashboard under “Recently Moderated” and says this:

    Topic titled test post started by bb_get_user needs a numeric ID

Viewing 25 replies - 1 through 25 (of 25 total)

  • Nola1974


    Does anyone have any ideas? I’m tearing my hair out here. I was able to create a new user and it appeared in wpmu. It was able to post just fine, the post apears and everything. If I log back in as admin, I cant delete his posts. On front-page.php the admin’s name appears, but when in dashboard it sill comes up as bb_get_user needs a numeric ID

    When in the admin account, I promoted the new user to Key Master.. when i log out of the admin account I get the following error:

    bbPress database error: [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'LIMIT 1' at line 1]
    SELECT * FROM bb_online WHERE user_id = LIMIT 1

    The new account, which i made Key Master is also unable to delete any posts – but can post new ones.

    The new account cannot see the posts the admin account made, that were showing up in yellow.

    Anyone reading this? :)


    RewriteEngine On
    RewriteBase /

    # www is soooo deprecated
    RewriteCond %{HTTP_HOST} ^$ [NC]
    RewriteRule ^(.*)$$1 [R=301,L]

    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*.php)$ $2 [L]
    RewriteRule . index.php [L]


    // ** MySQL settings ** //
    define('BBDB_NAME', '
    '); // The name of the database
    define('BBDB_USER', '
    '); // Your MySQL username
    define('BBDB_PASSWORD', '
    '); // ...and password
    define('BBDB_HOST', 'localhost'); // 99% chance you won't need to change this value

    // Change the prefix if you want to have multiple forums in a single database.
    $bb_table_prefix = 'bb_'; // Only letters, numbers and underscores please!

    $bb->domain = ''; // Example:
    $bb->path = '/forums/';

    //bb->mod_rewrite = true;

    // What are you going to call me?
    $bb->name = 'BLOG NOLA forums';

    // This must be set before running the install script.
    $bb->admin_email = '';

    // Set to true if you want pretty permalinks.
    $bb->mod_rewrite = true;

    // The number of topics that show on each page.
    $bb->page_topics = 30;

    // A user can edit a post for this many minutes after submitting.
    $bb->edit_lock = 60;

    // Your timezone offset. Example: -7 for Pacific Daylight Time.
    $bb->gmt_offset = -6;

    $bb->cookiepath = '/';
    $bb->usercookie = 'wordpressuser';
    $bb->passcookie = 'wordpresspass';

    // Change this to localize bbPress. A corresponding MO file for the
    // chosen language must be installed to bb-includes/languages.
    // For example, install to bb-includes/languages and set BBLANG to 'de'
    // to enable German language support.
    define('BBLANG', '');

    // Your Akismet Key. You do not need a key to run bbPress, but if you want to take advantage
    // of Akismet's powerful spam blocking, you'll need one. You can get an Akismet key at
    $bb->akismet_key = ''; // Example: '0123456789ab'

    // The rest is only useful if you are integrating bbPress with WordPress.
    // If you're not, just leave the rest as it is.

    $bb->wp_table_prefix = 'wp_'; // WordPress table prefix. Example: 'wp_';
    $bb->wp_home = '';
    $bb->wp_siteurl = '';

    /* Stop editing */

    if ( !defined('BBPATH') )
    define('BBPATH', dirname(__FILE__) . '/' );
    require_once( BBPATH . 'bb-settings.php' );




    What version bbPress are you using?

    Does this same problem happen when you use the stock theme rather your customized theme?

    What plugins are you using? Looks like simple online list or online list with that SQL error with bb_online? Can you disable the plugins temporarily and try it like that?

    Basically, determine if the problem happens on your server with a stock install, then add things back in one at a time and see where the problem comes in. Take a systematic approach, one thing at a time.

    Sounds like a bozo problem…? Open the profile of the troubled account, go to the “Edit” page, and see if there’s a 1 in the bozo field. If there is, you need the fix-bbPress plugin.

    I might have the wrong end of the stick entirely though.

    By the way, Nola, any chance you could help me with some .htaccess code? I’ve been having trouble making it work with WP and got no help on their forums.



    chrishajer: Yes, it does it with just the stock theme and even when I completely remove the bb-plugins directory. That was my first though, except I had finished adding about 5 posts a little while before this started happening, and I hadn’t added any plugins in that time.

    The site isn’t that active so I guess I’ll have to wipe it and reinstall.. but it makes me nervous that this will happen again.

    It’s like.. none of my KeyMasters have admit rights and my #1 user can’t even post without it going into moderation, but it cant be modereated because there’s no user ID, but there’s only no user ID in the Moderation Queue list.

    I’m so confused.



    Ok, i uploaded and overwrote all of my files with a fresh archive and I’m still getting the same behavior. This makes me think it’s something that’s already in the database…

    fel64: Well, after I removed the fix-bbpress.php I have “1” in the Bozo field for all of my accounts, INCLUDING the quotes. Should I change these to 0’s or delete the “1” before I install the fix?

    Also, I dont know much about .htaccess.. that’s pretty much the standard wpmu file.

    What does this line mean:

    Topic titled test post started by bb_get_user needs a numeric ID

    That stands out to me as if something is fubared in my database. But wpmu is working just dandy. Some sort of integration problem?



    You should install the bbpress-fix plugin, then change the field to 0 (no quotes) and save. This will hopefully fix things. The plugin only prevents you being marked as bozo, but it won’t unmark you (which is why you have to do that yourself).

    Don’t reinstall yet. :)

    Sam Bauers


    The SQL error indicates that this is a problem with a plugin, the bb_online table is part of the simple-onlinelist plugin. De-activate or remove it and see if the problem is still there.



    fel64: I’ve done that. I have the fix-bbpress plugin in and the “1” are no longer apearing. I then went through each account and put a 0 in the field and saved it. When I reload that page, it’s blank. (No 0)

    Still having this problem.

    SamBauers: I’ve completely deleted the bb-plugins directory and I still get the error. Could simple-onlinelist have put something int he database and corrupted it? I’ve had this plugin installed for a week. Don’t know why all of a sudden it would do this.

    I looked in the database and all of the offending topics/posts were bozoed. But the authors are not. I don’t understand why whenever I try to delete ANY post (even ones from 2 weeks ago) I get “You do not have permission to do that.”

    From wp_metadata:

    User              table                   value
    1 bb_capabilities a:1:{s:9:"keymaster";b:1;}

    From bb_topicmeta:

    Edit    Delete        meta_id 	topic_id 	meta_key 	meta_value
    Edit Delete 19 15 deleted_posts 1
    Edit Delete 20 15 bozos a:1:{i:1;i:1;}
    Edit Delete 18 14 bozos a:1:{i:1;i:1;}
    Edit Delete 17 14 deleted_posts 1
    Edit Delete 15 13 deleted_posts 1
    Edit Delete 16 13 bozos a:1:{i:1;i:1;}

    Can someone decypher this? (The bozo parts)



    OK, I deleted all offending posts out of the database manually and I can now post a topic without it being bozod immediately – however I still cannot delete any topics or posts.

    Can this be a cookies issue? (I’ve deleted both my cookies and my cache often throughout all of this.)

    I don’t think it’s a problem with the database for the posts – because I can’t delete older ones as well… some sort of permissions error? How can I be certain I have permissions set correctly?

    I can edit posts fine though.



    I’m so frustrated I’m about to cry. Really. I’m a wuss like that.

    I just completely reinstalled bbpress, using new tables (kept the old ones) and it’s STILL GIVING ME THE ERROR.

    “You do not have permission to do that.”

    This has to be something with the users table or usermeta or cookies. I’m going crazy here.

    I’m starting to feel like a tree that fell in the forest. lol

    Sam Bauers


    No idea…

    I honestly don’t know enough about how bozoing and/or wordpress integration works to help you.

    Few people would be running WordPress mu either.

    But a new install + new database….. are you still using the old user tables? Does a standalone install not work either? Have you tried different browsers?



    Tried it all Sam.

    All of a sudden, I can delete the entire topic, but not individual posts. Weirdness.

    Sam Bauers


    No joke, have you tried a different server?



    No. Also, I’ve noticed weird things in my WordPressMU installation. I can’t edit create new categories (“You do not have permission to do that.”) with the stock category editor… but when I down load a Category Manager Plugin, I can. However, none of the other users can – even with the plugin.

    To top it all off… I CAN create new categories when logged in as them.. but they can’t.

    Im beginning to think bbpress did something to my user tables.

    Sam Bauers


    > Im beginning to think bbpress did something to my user tables.

    That seems kind of unlikely, but I wouldn’t rule it out. There may be something more fundamentally wrong with your setup, but I couldn’t say exactly what.



    wouldn’t know what it is. I’ve re-uploaded both wpmu and bbpress. I’ve took out all plugins and it’s still doing it. Perhaps something to do with my config files…. but they look OK.

    Maybe the permissions/nonces are screwed up? If bbPress is set to use WP functions it might be worth reuploading those.



    Reupload what though? I have completely reuploaded the full BBPress and WPMU packages twice. I’ve re-installed BBPress from scratch once, using all new tables (except for the current wp_users table…)

    I can create new posts, I can edit posts.

    I can delete entire TOPICS, but not individual posts.

    However, I just noticed that after a post is saved (without tags) I can add a (1) tag, but not delete it. I cannot create additional tags on a post after that first one.

    This is really getting on my nerves now. I would think it HAS to be something to do with permissions, but I can’t tell what the are in the database… what tables should I look at??

    Sam Bauers


    It has to be the wp user table that is causing problems. You also need to specify the new wp user_meta table in your bb config I believe.

    The meta table is where the user capabilities are stored I think



    I dont see anything in the docs about wp user_meta table having to be specified.

    Uhg, Im about to give up. really. It’s been 3 days and it’s just getting worse and worse. Granted, I only have 3 users and 2 blogs right now.. but I’ll be damned if this happens once I start getting ‘real’ users instead of a few friends. No responses on the wordpressMU forum at all so I guess no one there knows what’s going on.

    It’s even doing it on newly created users and blogs… so it’s not like the permissions are corrupted.. cause wouldn’t it be brand new and not corrupt when i created a new user?

    I’ve tried removing users from blogs and re-adding them, thinking maybe it’d re-write the permissions in the meta-tags. No go.



    Oh my god, this is just getting weirder and weirder. I’m now using the original installation of MUWP and trying to troubleshoot the category issue.

    I have two categories “updates” and “Blogroll.”

    In the Create New Category Form, where is asks for a possible Parent Category there are THREE options…. all of which are a combination of the two current categories: “updates Blogroll”


    Is my WUWP freakin’ haunted or something??



    Oh. My. Lord. This thread has basically just been a blog. lol

    But, the good news is that my host figured out the cause… I forget the name of the module, but PHP was encrypting the cookies. As soon as he turned that off – everything works peachy.

    What little hair I had left is gone now though. :)

    I resolved this problem by deactivating the plugin “Use Display Name”, ver 0.7.2 by Michael Adams.

    I had this problem too. Couldn’t create a new forum. Couldn’t delete stuff. Everything broken. I deactivated the Use Display Name plugin (0.7.2) and it’s all fine now.

Viewing 25 replies - 1 through 25 (of 25 total)
  • You must be logged in to reply to this topic.
Skip to toolbar