Skip to:

Can not get into admin panel

Viewing 9 replies - 1 through 9 (of 9 total)
  • Is it integrated with this WP blog?

    If something isn’t correct in the WP integration settings, you are logged in bbPress if you are logged in WP, but a click on the “Admin” link on your forums (“Admin” in English, don’t know any word Chinese) will send you back to the forum’s front page.

    A typical symptom of that problem is: After you clicked the link “Log Out” and made a new login in bbPress (not in WordPress), you can access the bbPress dashboard.

    It still didn’t work.

    I tried many times, but never seen any “Admin” link beside the login name.

    The next possible problem is a failure in the mapping of WP user roles to bbPress user roles in a user table integration — this kind of problem is a harder one, it may require doing some SQL to add the bbPress capabilities for a user. So I leave this for the serious experts here…



    have you tried adding “bb-admin” to the end of your bbpress forum url? It might be that you’re using a custom bbpress theme that hasn’t got that option enabled on the theme.

    try adding “bb-admin” and see if your wordpress login works.

    tuluto, try logging out of WordPress and logging in through bbPress. Did it help?

    I’ve hit the same snag. I tried logging out of my WordPress admin and now I can’t login to the BBpress install or WordPress install.

    When I click the login button on both WordPress and BBPress it simply sits on the same page or reloads the page. It’s as if the Login buttons are broken.

    I’ve tried changing the force_ssl_admin to true as mentioned here:

    function force_ssl_admin($force = ‘true’) {

    I’ve updated all my auth keys in both WP config and BP config as mentioned here:


    And I’ve added define( ‘COOKIEPATH’, ‘/’ ); to my WP and BP config files as well.

    Still no luck.

    Any help would be appreciated. If nothing else I may start searching for the uninstall thread.

    I may have found a solution.

    I deleted all the bbPress files from my server.

    Deleted all the tables from my database in MySql that began with the bb_ prefix.

    Then started the process all over again.

    However, this time I left the SECURE_AUTH_SALT field blank since it doesn’t show in my wp-admin/options.php page (even though it’s in my wp-config file).

    Either the full reinstall or simply leaving that field blank worked.

    Also, once I uninstalled bbPress I added the bbPress Integration plugin ( to my WordPress install (don’t know if that’s made a difference either) but it said to add a couple lines to my wp-config.php file as well.

    define( ‘COOKIE_DOMAIN’, ‘’ );

    define( ‘COOKIEPATH’, ‘/’ );

    Thanks, guys.

    If you can see the Admin link but can’t get in, this is a cookie problem and if you can’t even see the admin link, then you don’t have the privilege, fix it here –

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.
Skip to toolbar