Skip to:

bbPress is working, but now I can’t log into WordPress

Viewing 9 replies - 1 through 9 (of 9 total)
  • What versions of bbPress and WordPress are you using?

    And what techniques/plugins did you use to integrate the signins?


    WordPress 2.7.1

    I just followed the automated installer to integrate the two. At first I had issues because I’d mistakenly installed WordPress in the wrong database. So, I wiped the bbPress from my database, exported/imported the WP information to the correct database, made sure WP was working properly, then installed bbPress again. Everything worked fine for bbPress (and it still does) but now WP isn’t working.

    I checked the forums a bit and looked at my database using phpMyAdmin to see if there was some setting on my user name that had been tweaked, but honestly I don’t know it well enough to tell at a glance if it’s okay. But, like I said, bbPress is working fine and the *front end* of WordPress is working fine…just not the users.


    I just realized that my account isn’t working properly on either site. I can log into bbPress but now I don’t have full. I wanted to install a plugin but there’s no option to do so (even though there was one a few minutes ago). It says I’m listed as an Administrator, but not the Key Master.

    I checked phpMyAdmin and these seem to be the most relevant fields…

    dharmaguild_capabilities a:1:{s:13:”administrator”;b:1;}

    dharmaguild_user_level 10

    Ah those two versions of bbPress and WordPress are not cookie compatible, without some extra plugins. Either of these two should work – one upgrades your bbPress cookie, and the other one downgrades your WordPress cookie.

    Sometimes bbPress will lose keymaster access during reverse integration – try this to fix that:

    First of all, thanks for your help so far…

    I can’t use the WP plug-in because I can’t even log in to activate it.

    I’ve also tried the fix-admin-access plugin but it doesn’t work for me. I get administrator access back but not keymaster access (which means I can’t even see the plugins link in the admin panel). I would edit the database directly if I knew what to change the values to, but so far every time I mess with that it just resets me to “member.”

    I tried the freshly baked cookies plug-in, but I don’t know how to make it work. The notes say that I’m supposed to set my LOGGED_IN_SALT and AUTH_SALT, but they’re both in the WP admin options, and since I can’t log in, I can’t find them.

    At this point I’m willing to just uninstall bbPress and wait until a more stable version comes out, but that won’t solve my main problem, which is my inability to log into WordPress. :o(

    Try deleting all your cookies or using another browser to log in & see if it lets you.

    I’m also having this problem with WordPress 2.7.1 and BBPress 1.0-rc-1 using integrated database and with BBPress in a subdir.

    I’ve had WordPress installed for a while. Installed BBPress 0.9 using Simple Scripts, but it didn’t work, so I deleted the BBPress files. Then I had an “Error establishing a database connection.” Fixed that by restoring my database and making a new admin user for the database.

    Reinstalled using 1.0-rc-1. Now, my WordPress/BBPress admin user can only log into BBPress. When the admin tries to log into WordPress, I get “You do not have sufficient permissions to access this page.” This only affects the admin user. All other users can login. New users can register.

    Logging out of one site logs the user out of the other site, but logging into one site does not log the user into the other site.


    [UPDATE] I have kind of fixed my problem – I logged onto phpMyAdmin and went to wp_usermeta for my admin account and changed the wp_capabilitoes meta_key back to a:1:{s:13:”administrator”;b:1;} from a:1:{s:9:”keymaster”;b:1;}. Now, my BBPress admin of course does not have keymaster privileges, but that’s ok right now. Still haven’t sorted out cookies.

    [UPDATE] I fixed my problem by uninstalling my bbpress and rolling back my wp database to an earlier version and then just installing again. Install works fine now. I think where I went wrong was changing the bb_ prefix to wp_ and not including define(‘WP_AUTH_COOKIE_VERSION’, 1); in bbconfig!

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.
Skip to toolbar