Skip to:
Content
Pages
Categories
Search
Top
Bottom

BBpress disapeared from WP-Admin


  • Weaper
    Participant

    @weaper

    Hi,
    I’ve installed bbpress and created forums and topics but now I just saw that all trace of bbpress disapeared from WP-Admin.
    The forum is still live and works flawlessly but I no longer have any means of creating new forums or other admin tools.

    I saw some hints of solutions that tells to repear through the forum in Tools but even there it’s unavailable.

    Any idea ?

Viewing 6 replies - 1 through 6 (of 6 total)

  • Robkk
    Moderator

    @robkk

    Do you have the Keymaster forum role in Users > All Users??


    Weaper
    Participant

    @weaper

    yes


    Pascal Casier
    Moderator

    @casiepa

    Hi,
    First check is always to see if another keymaster can still see the bbPress parts. If so, ask him/her to demote and promote you again as keymaster. If you are the only keymaster, create a new account, make keymaster and try the operation from there.

    If that didn’t help then try these actions:

    If you have already deac­ti­ved all plugins except bbPress and swit­ched to a default theme and you still do not see ‘Forums’, ‘Topics’ and/or ‘Replies’, then please try this in Settings > Forums (check after every step if you find the options back on your dash­board):
    – ‘Set­tings > Forums’ : (de)acti­vate ‘Ano­ny­mous post­ing’, save, (de)acti­vate it again to get back to your origi­nal setting, save
    – ‘Set­tings > Forums’ : (de)acti­vate ‘Auto role’, save, (de)acti­vate it again to get back to your origi­nal setting, save
    – Deac­ti­vate the bbPress plugin, then reac­tive the bbPress plugin
    – ‘Tools > Forums > Repair Forums’ : Remap exis­ting users to default forum roles, click ‘Repair Items’ (WARNING: Make sure to have multiple admins in case the keymas­ter role would disap­pear from one account)

    Pascal.


    Weaper
    Participant

    @weaper

    Hi Pascal, thanks for the extensive help.

    #1 : none of my keymaster can see the forum’s item in the admin panel. I still tried the demote/promote manipulation and it didn’t change anything.

    #2 : I didn’t do it earlier so I deactived all the plugins aside from bbpress (I only tried a theme switch) and it reappeared as if by magic! I don’t know what was the initial cause…

    #3 : wouldn’t have worked as there was no Forums setting

    anyways, thanks a LOT! take care


    Robkk
    Moderator

    @robkk

    What plugin caused the issue?? Knowing could help others. Did you really just reactivate everything and it just worked??


    Weaper
    Participant

    @weaper

    Well, that’s the thing. I have no idea as the issue didn’t repeat itself on e I had reactivated all the plugins.

    The only ones I had recently used/added were WP-optimize, FooGallery and FooBar…

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.
Skip to toolbar