Skip to:

bbPress released

  • Finally it is here.

    More info is on the blog post here.

    Found a bug? Tell us about it here.

    UPDATE: we found a bug and squashed it, thus is born. Sorry to all those very early adopters.

Viewing 8 replies - 26 through 33 (of 33 total)
  • hello, there seems to be a stylesheet error on the admin page. when you visit the admin forum section the edit/delete items are both offset from the actual forum line and each one cascades in diagnally making it almost impossible to use. This is using Firefox and the standard theme.

    I have a new wordpress site which is the new 2.5. I’ve uploaded the new bbpress but when I go to install by visiting the url I get redirected to xxx/bb-admin/install.php/ which comes up as page not found (which ends up at the wordpress 2.5 home page).

    I notice that install.php is now in the plug-in folder so tried


    and get:

    Warning: main(../bb-load.php): failed to open stream: No such file or directory

    Fatal error: main(): Failed opening required ‘../bb-load.php’ (include_path=’.:/usr/local/PEAR’)

    both on line 9

    Suggestions, some little thing I’m doing wrong?


    @ retrospec

    I can’t replicate that error on FireFox2 on Mac – perhaps try re-uploading the stylesheet.


    Your WordPress rewrite rules (in .htaccess) are getting in the way of accessing bbPress by the sounds of things. Also, the installer is at bb-admin/install.php, not where you said. You should probably delete bbPress and start again.

    Thanks, seems I had a bad copy, downloaded and installed a fresh copy.

    Seems to be working with wordpress, I was already logged into wordpress and I’m the forums shows me that I’m logged in. Now to test and customize.

    It did show minor errors:

    Incorrect table definition; there can be only one auto column and it must be defined as a key

    Key column ‘post_id’ doesn’t exist in table

    Duplicate key name ‘user_nicename’

    >>> User tables will already exist when performing a database integrated installation.

    Anything I should be concerned about?

    Thanks again.

    I need to find a way to fix the errors, not so minor, getting data base errors for posts.

    bbPress database error: [Unknown column ‘post_id’ in ‘where clause’]

    SELECT * FROM wp_posts WHERE post_id = 0

    Looks like you got the $bb_table_prefix wrong when you installed, it should have been different to the wordpress prefix.

    Change $bb_table_prefix from “wp_” to “bb_” in bb-config.php then rename you bbPress tables thusly:

    wp_forums -> bb_forums
    wp_tagged -> bb_tagged
    wp_tags -> bb_tags
    wp_topicmeta -> bb_topicmeta
    wp_topics -> bb_topics


    Do not rename wp_posts, wp_users or wp_usermeta!

    This will still leave you without a bb_posts table. So if you have a way to browse your database (e.g. phpMyAdmin) then go into the bb_topicmeta table and look for the row with a meta_key of bb_db_version. Change the meta_value of that row from 1234 to 1233. Login to your bbPress (hopefully it works) then go to the admin section. You will be asked to upgrade, do so and check the log. You should see a log entry where your bb_posts table is created.

    That should do it.

    Posts work now.

    No longer have the admin option, I went to


    clicked upgrade, posts in forum now work

    I no longer have admin privileges

    Listed as member

    Thanks, getting closer.

    So when integrating with wordpress we use bb, not wp.

    I also lost admin priv. in wordpress

    I get: You do not have sufficient permissions to access this page. Doesn’t even give me choice to log in. I had no problem logging in as admin either place before changing the tables, etc

    I did use the wordpress secret key phrase.

    Used downloaded fresh copy yesterday

    Working now. As this was a new data base with no content yet, I dropped the database, made a new one, installed wordpress, then bbpress. All seems to be working correctly. I must have put wp_ in step 1 the first time instead of leaving it at bb_. No problems with logging in like I had when I tried the upgrade. Thanks.

Viewing 8 replies - 26 through 33 (of 33 total)
  • You must be logged in to reply to this topic.
Skip to toolbar