Skip to:

After update Wp 3.4.1

  • I get this ugly error:

    Fatal error: Call to undefined method stdClass::have_posts() in /home/jorjette/public_html/wp-content/plugins/bbpress/bbp-includes/bbp-reply-template.php on line 168

    I`m not able to see any single thread! Can someone help me with that? I am the only one who get the bbp-reply-template.php error?

Viewing 8 replies - 1 through 8 (of 8 total)

  • John James Jacoby


    That’s a bit odd, since that’s a core WordPress WP_Query method.

    Can you confirm that your update went smoothly? Maybe try reinstalling bbPress manually.

    Also, what theme are you using? It’s possible there’s a conflict, or something else weird is going on.

    Thanks for helping.

    Similar error when using 2.1 themeing since updating. In my custom archive-forum.php a call to Is returning the error Fatal error: Call to undefined method stdClass::have_posts() in /wp-content/plugins/bbpress/bbp-includes/bbp-forum-template.php on line 109

    I just upgraded to bbPress 2.1 and WP 3.4.1 (at the same time) and now I’m getting the exact same error as the original poster: line 168 in bbp_reply_template. I’m using custom templates.



    Do you still get this error if you switch to the twenty ten theme and disable all plugins?

    This lets you hunt down if it is a bbpress bug or a theme conflict or a plugin conflict!

    Thanks for the suggestion. Switching to the twenty ten theme (for bbPress) resolved the error. I didn’t need to disable any plugins. Of course, this isn’t a solution for me but it’s a start toward tracking down the issue. Thanks again!

    It seems this error was happening because I was using bbPress 2.1 with the bbPress 2.0 template files. Once I copied the theme-compat files into the bbPress directory in my WP theme, the errors went away. Thanks again for the help!

    2.1 is looking great. 🙂



    Switching to a default theme is a good place to start when trying to track down errors!

    Glad you got it sorted 🙂



    I wonder if the OP ever got the issue resolved? I wish I’ve seen this before I posted a new topic that seems to be the exact same thing, but that’s that..

    I am using Tersus, and I think it’s an awesome theme.. I have also tried jczerwonka’s method of replacing the bbpress theme files from within my theme’s folder in /wp-content/themes/Tersus/bbpress, but to no avail.. hope someone could help.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.
Skip to toolbar