Skip to:
Content
Pages
Categories
Search
Top
Bottom

404 errors on forum and topic views due to possible bug


  • jkw217
    Participant

    @jkw217

    I am experiencing 404 errors on forum and topic views. It appears to be at random and not all the time.

    Got error 'PHP message: PHP Notice: Undefined offset: 0 in /wp-content/plugins/bbpress/includes/topics/capabilities.php on line 80\nPHP message: PHP Notice: Undefined offset: 0 in /wp-content/plugins/bbpress/includes/replies/capabilities.php on line 62

    I have re-saved permalinks, changed->saved then changed-back->saved and still have the 404 errors occasionally.

    I googled this error and found:
    https://wordpress.org/support/topic/capabilities-undefined-offset-error-with-bbpress/

    I tried updating the capabilities.php file as discussed but still having issues.

    Does anyone have any experience with this problem and have a fix?

Viewing 6 replies - 1 through 6 (of 6 total)

  • Pascal Casier
    Moderator

    @casiepa

    @jkw217,
    I have no idea about this error but can you please provide the version of bbPress and WordPress that you are using?


    jkw217
    Participant

    @jkw217

    @casiepa,
    I am using bbPress Version 2.5.14.


    jkw217
    Participant

    @jkw217

    WordPress v5.2.2


    Pascal Casier
    Moderator

    @casiepa

    @jkw217 thanks. I’m double-checking because it seems to be solved in v2.6 of bbPress.


    jkw217
    Participant

    @jkw217

    @casiepa, it is rather strange that this just recently started happening. I thought it was a plugin conflict at first until I saw the logs and googled the error to have found it might be a bug. Do you think v2.6 is stable enough to upgrade?


    jkw217
    Participant

    @jkw217

    Has anyone else resolved this by chance?

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.
Skip to toolbar