Skip to:
Content
Pages
Categories
Search
Top
Bottom

Fatal Error: Unable to create forum from buddypress group


  • prikid
    Participant

    @prikid

    Good day!

    I’m unable to create group forum from the buddypress group admin page. Below it says “Fatal error: Using $this when not in object context in /home/stigafnx/public_html/wp-content/plugins/bbpress/includes/extend/buddypress/group.php on line 308″

    I have disabled buddypress own forum, and also choosen Group Forums Parent.

    Can you please advice?

    Thank you

Viewing 25 replies - 1 through 25 (of 38 total)

  • prikid
    Participant

    @prikid

    any one please?


    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Huh. That’s interesting. I’ll need to investigate this. Anything unique to your setup that would be helpful for testing?


    prikid
    Participant

    @prikid

    Thanks a lot for your reply John! Nothing really unique, only it’s translated t Russian and have he activity plus plugin.

    I’m not familiar with PHP, but i have a feeling this problem is coming from 1.8 Buddypress. I will today install fresh copy of WP, BBpress and buddypress and see if the problem appears. also want to try the previous version of buddypress.

    I’ll let you know asap.

    Thanks!


    prikid
    Participant

    @prikid

    just noticed: when creating new group and 3rd setup where need to create a group again error appears “Fatal error: Using $this when not in object context in /home/stigafnx/public_html/wp-content/plugins/bbpress/includes/extend/buddypress/group.php on line 461″


    prikid
    Participant

    @prikid

    just installed fresh copy and have same issue. You can check on: http://ersi.stig.al/wp/
    login & pass: test

    Wordpress is in Russian, but the plugins are in English


    prikid
    Participant

    @prikid

    I don’t think this issue is related to bbpress, this seems to be a buddpress problem


    Hugo
    Participant

    @hnla

    Had this issue for a while too. Checked once again with no plugins running, BP bleeding and bp-default theme, issue persists.


    samuel.hautcoeur
    Participant

    @samuelhautcoeur

    Same problem here! Happens both without any additional plugin and with BuddyPress Docs enabled.


    MissFiction
    Participant

    @missfiction

    I’m also having the same problem..

    Fatal error: Using $this when not in object context in public_html/wp-content/plugins/bbpress/includes/extend/buddypress/group.php on line 461.


    mkocher
    Participant

    @mkocher

    I am also facing this same issue. :(


    mkocher
    Participant

    @mkocher

    Sadly, I’m also having this same problem


    bearkiter
    Participant

    @bearkiter

    Exactly the same issue here, no answers anywhere..


    mkocher
    Participant

    @mkocher

    I found a fix! Take previous version of buddypress (1.7.3), find the groups folder and upload that replacing the new one with the old one. Now everything works great.


    Craig
    Participant

    @craigheyworth

    same issue here suddenly:
    Fatal error: Using $this when not in object context in /wp-content/plugins/bbpress/includes/extend/buddypress/group.php on line 461

    Anyone a link to an old version of buddypress?


    Derroah
    Participant

    @derroah

    Mkocher, do you know where I could find copy of the buddypress 1.7.3 download? I can’t only find the most recent version. I am having the same issues with the errors. fatal error on line 461


    Craig
    Participant

    @craigheyworth


    Derroah
    Participant

    @derroah

    Worked! Thanks so much!


    Craig
    Participant

    @craigheyworth

    and I can confirm that it solves the problem :)


    mkocher
    Participant

    @mkocher


    MissFiction
    Participant

    @missfiction

    Thanks so much, Mkocher. That completely solved the problem :)


    samuel.hautcoeur
    Participant

    @samuelhautcoeur

    The BuddyPress team did an extensive rewrite of BP_Group_Extension… That’s why it’s breaking like this.

    Reverting to the previous version of the groups folder in your BuddyPress installation ain’t even close to a permanent fix, and will cause other issues down the road.

    We managed to fix it by changing a few lines in /includes/extend/buddypress: http://pastebin.com/nfYvigz4 (look for “Fix for BP 1.8″, lines 459 and 489)

    Not a permanent fix either, but at least it’s a starting point!


    prikid
    Participant

    @prikid

    Samul thanks for the info. Can you please advice which code i should replace? Im not good at all with php

    Many thanks!


    prikid
    Participant

    @prikid

    Can someone please advice? By replacing group folder other issues appears


    fmpweb
    Participant

    @fmpweb

    Hi – I’m having the same problem on a fresh install using Headway Themes: public_html/wp-content/plugins/bbpress/includes/extend/buddypress/group.php on line 308

    I created a new parent so that group forums aren’t added to the Forum Root.

    This is using bbPress 2.3.2, Buddypress 1.8, Headway 3.5.5 and WordPress 3.5.2.

    Thanks.


    samuel.hautcoeur
    Participant

    @samuelhautcoeur

    @prikid: the file is includes/extend/buddypress/group.php in your bbPress plugin directory.

Viewing 25 replies - 1 through 25 (of 38 total)

You must be logged in to reply to this topic.