Skip to:
Content
Pages
Categories
Search
Top
Bottom

404 errors for logged in users 2.2.3


  • Prometheus Fire
    Participant

    @prometheus-fire

    There were a few people who were reporting 404 errors for some logged in users, myself included, in the announcement thread here http://bbpress.org/forums/topic/bbpress-2-2-3-released/

    Instead of clogging up that thread with that problem, I’m starting a new one. To summarize, admins can access the forums, but some logged in users cannot. On my site I’ve been getting reports daily that some members cannot access the forums. I have two testing account on my site, one can access and another, newly created cannot. It receives the 404 error.

    Logged out users can load all the forums with no problem, as can admins. Resetting permalinks doesn’t fix it, and neither does re-installing the plugin. I even went so far as to delete all the _bbp_ options from the wp-options table of the database and that didn’t help either.

    I also downgraded to 2.2.2 and that didn’t fix it, so I don’t think the issue is with the latest version, but something else that may have introduced with the new user roles (which I think came in with 2.2), but I only recently started having the issue with version 2.2.3.

    One user has rebuilt his database and beat the problem, this may work for some, but I’m not in a position to do that since I’m running mine on multisite and my database is over 2gb with thousands of tables. For me to do that for this when everything else is working fine is a major job.

    Any one having this issue should post in this thread and hopefully we can find the problem and solution. As it stands right now for me, about a third of my users are getting the error.

Viewing 4 replies - 1 through 4 (of 4 total)

  • Prometheus Fire
    Participant

    @prometheus-fire

    To update this thread, I downgraded to version 2.1.3 as suggested here and the problem was resolved. 2.1.3 is before the new user role setup in BBPress. The folks in the thread linked above were all having issues with Member plugins and user roles that had been edited.

    I’m not using a user role editor of any kind on the main site, but I have used on 3 (out of 100) subsites on the multisite network. The role editor plugin has never been activated on the main site, and BBpress has never been activated on the subsites.

    For now, I’m stuck on 2.1.3 until a fix or a better understanding can be found.


    Dobbelsoft
    Participant

    @dobbelsoft

    same here!


    dprundle
    Participant

    @dprundle

    I hope this is related: I’m also unable to access any of my member profiles. [www.mysite.com/members/] I simply get the result you would expect if you typed in http://www.anywebsitethatdoesn‘texist.com


    achalupka
    Participant

    @achalupka

    You may want to check your database table wp_options for the entry with the option_key of “wp_user_roles”.

    When I had this problem, it was because that entry had become corrupt and didn’t have all the user roles (with their respective permissions) listed in it.

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.