Skip to:
Content
Pages
Categories
Search
Top
Bottom

Unable to Edit or Merge topics or replies on front end


  • Grant Palin
    Participant

    @grantpalin

    I’m running the current versions of WordPress and bbPress on a dev site. Mostly OK, have been able to get some people to test the forum functionality. However, I and another user (both keymasters) are unable to use the Edit or Merge buttons above topics and replies. The other buttons – delete, spam, close, stick, etc – do work, strangely. Yet I have no trouble doing edits from the backend.

    I tried the usual routine of disabling all plugins save bbPress, yet the issue remained. We’re not using exotic plugins – ACF, Pods, NavXT, PageNavi and about 10 others. We are building out a custom theme – I also tried switching to Twenty Twelve to no avail.

    If it matters, I have set up a custom permalink structure in the bbPress settings. I can’t imagine that being the issue if only two functions fail to work while the others are fine.

    Any Suggestions?

Viewing 4 replies - 1 through 4 (of 4 total)

  • Stephen Edgar
    Keymaster

    @netweb

    Try the ‘Remap existing users to default forum roles’ repair tool

    https://codex.bbpress.org/repair-forums/

    Also try resaving your permalink structure.


    Grant Palin
    Participant

    @grantpalin

    I’ve run the repair tool with the recommended option, and resaved the permalinks. No change – both the edit and merge links go to a ‘page not found’ error. Both are going through the [topic slug]/edit/ path – [topic slug]/edit/?action=merge for the merge link.

    Something else I’ve tries is to create a dummy account at the moderator level, and attempted editing and merging topics. Same issue, both at the moderator and keymaster levels. Same problem with the edit link on replies too.

    If it would help any, I can provide a link to the forum in question.


    Grant Palin
    Participant

    @grantpalin

    I resorted to resetting the bbPress data to nil, uninstalling and reinstalling the plugin, and the functionality is now working as expected. I’m not bothered about losing the forum content as there wasn’t much there anyway. I had one other issue with bbPress which seems to be due to a seemingly unrelated plugin. I’ve deactivated that plugin and filed a report with the developer. bbPress is now working like it should.


    Stephen Edgar
    Keymaster

    @netweb

    Thanks for the follow up.

    You can backup your forums, topics and replies via the WordPress Export if you ever need to back these up 😉 http://example.com/wp-admin/export.php

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.
Skip to toolbar