Skip to:

Topics only visible to Administrators

  • dezrok


    Hi there, I’m hoping someone might be able to give me some advice on a fix for the following:

    bbPress is working fine for Administrators, however, users with any other Site Role can’t read the Topics (even if they are a Forum Moderator or Keymaster).

    For non-Administrators, the Topics index works fine and when you select a Topic you can read any Replies that have been made, as well as having the ability to post a reply (as long as your Forum Role is sufficient), all that is missing is the original Topic itself.

    If a previous reply has quoted the Topic, then you can read the quoted topic within the reply.
    The Topic exists, the original just isn’t visible to non-Administrators.

    I’ve deactivated all plugins and the problem persists.
    I’ve tried it with the theme Twenty Twelve and the problem persists.

    Changing the Forum Role doesn’t affect the problem.
    Only users with the Site Role “Administrator” can read Topics.
    Obviously I can’t make everyone an Administrator and have run out of ideas on how to go about fixing this.

    Wordpress 4.9.4; bbPress 2.5.14
    Forum Link:

    NB: The forums are part of a private membership site that is still under development. I have made one of the forums (which contains some test Topics and Replies) publicly accessible via the above link. Access to the site is controlled using Membership 2 and the Groups plugins, although these don’t appear to affect the problem.

Viewing 3 replies - 1 through 3 (of 3 total)

  • dezrok


    I’ve discovered it is a conflict with the Membership2 plugin (I wasn’t clearing the cache on previous plugin tests).

    I would be interested to hear if anyone has been able to get bbPress working with the Membership2 plugin without this problem as they are supposed to be integrated but I can’t find any settings that might be causing this problem.

    Robin W


    given this is a paid theme that claims to protect your site, it is really one to raise with them.

    I don’t have their plugin to be able to test



    Thanks Robin.

    I am using the free version of the plugin (which is available here, but yes, now that I have narrowed the problem down to a conflict with this plugin I will follow up with them.

    Was just hoping someone here might be using the Membership2, had the same issue and had already worked out how to resolve it.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.
Skip to toolbar