Skip to:

Topics not displaying properly

  • Tanya


    Hey there, I’ve installed bbPress on a site for one of my clients who is running a membership and I’ve run into an unusual glitch that I will try to clearly explain.

    When logged in as an Admin/Keymaster:
    1. I am able to see the Community Forums page that lists the different Forums that we’ve created.
    2. When I click on a forum I am able to see the list of Topics that we’ve created within that forum.
    3. When I click on a Topic I’m able to see the description for that Topic that we added when we created the topic.
    4. When I click on a Topic I’m also able to see the replies posted on this topic.

    When logged in as a Subscriber/Participant:
    #3 from above doesn’t work – the other pieces work fine.
    So when a subscriber clicks on a Topic they don’t see any of the detail for that topic. Also, when they submit a topic, it shows up in the list under the specific Forum, but no other members can see the details – only the title of the topic.

    The Topics aren’t showing as “hidden” or anything like that. They are visible as a list – it’s the “description” piece that doesn’t show up when you go in to the topic (even the box for the description and whole posted it is missing once inside the topic).

    I’ve tried playing with the public and private settings. The site is protected using WishList member. I’ve tried it with protection turned off and on. I’m pretty stumped right now.

    As I said, it displays perfectly correct for the Admins/Keymasters – but is simply missing that one piece when logged in as a Subscriber/Participant.

    I’m really hoping that someone else has run into this and knows a quick fix… too idealistic? lol fingers crossed.

    My client is launching this site to his members in less than 8 hours from now (Wednesday, October 25, 2017, 3pm EST). (Don’t we love it when clients ask for last minute add-ons with no notice and expect everything to work perfectly haha.)

    Thanks in advance for your help!

    (I can provide screenshots later if that would help, can’t grab them from the computer I’m currently at.)

Viewing 2 replies - 1 through 2 (of 2 total)

  • sanjayrath


    I have had similar problems when I used ‘Wishlist Member’. Basically I had added custom post types into this and had configured it for all – forums, topics and replies. Then when it was changed to only control ‘Forums’ (custom post i.e. removed Topics and Replies), it worked fine. Thats an immediate solution.
    Basically its a permission issue.

    Also do one thing. Deactivate all other plugins except bbPress. Now activate them one at a time and you will know the culprit (using a browser, say Firefox). It takes a few seconds when you reload the forums page logged in as a subscriber/user from another browser (say Edge).



    Thank you for responding @sanjayrath. Yes I did confirm that WLM is the culprit, but nothing I do fixes it. I’ve tried what you suggested, along with changing user roles, permissions, opening everything up… nothing I try will get that first post inside a topic to display for anyone other than admin/keymaster. Do you know if the Wishlist bbPress integration plugin perhaps fixes the problem?

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.
Skip to toolbar