Skip to:
Content
Pages
Categories
Search
Top
Bottom

There’s a space sign before usernames in bbpress

  • Hi people,

    look here.

    I noticed that’s there one space in front of “Admin” here:

    This forum contains 2 topics and 2 replies, and was last updated by Admin 9 hours, 17 minutes ago.

    You can also see it on the right hand side under “Latest forum posts”.

    Best regards.

Viewing 10 replies - 1 through 10 (of 10 total)

  • Robin W
    Moderator

    @robin-w

    The space is where the site is trying to show your avatar

    <a href="http://logicbenchmarks.com/forums/users/logicbenchmarks/" title="View Admin's profile" class="bbp-author-avatar" rel="nofollow"></a>

    which is somehow not showing – no idea why, but suspect you have code doing this

    I didn’t change or modify any core. Just installed the plugin as is. But I did disable avatars. Apparently it keeps the space, even if you don’t have avatars?

    And isn’t it weird that you’d have a space for an Avatar in this text that is displayed in very small font?

    This forum contains 2 topics and 2 replies, and was last updated by Admin 2 days, 4 hours ago.

    This doesn’t look like a place where you would display an avatar.


    Robin W
    Moderator

    @robin-w

    how did you disable avatars?

    In the WordPress settings under “Discussion”. I guess this affects the Avatars on the forum as well.


    JJJ
    Keymaster

    @johnjamesjacoby

    I guess this affects the Avatars on the forum as well.

    Yep! That’s a site setting that bbPress is going to obey.

    That sounds good. 🙂 But I still hope there’s a way in the future to remove that space! (The clean way)

    Hello again! That space is bugging me, is there no way to remove it?

    When you look at the code on the site itself it looks like it is this sign here which is causing spaces:

    "

    It also does that in other places. Can someone tell me why? And there’s no way to hide it through CSS either, because it has no class or id, so you can’t add display: none: to it.


    Robin W
    Moderator

    @robin-w

    put this in your functions file or in code snippets

    add_filter( 'bbp_suppress_private_author_link', 'rew_remove_author_space' ) ;
    
    function rew_remove_author_space ($author_link ){
    	$author_link = str_replace( '&nbsp;', '',  $author_link );
    return $author_link;
    }

    Code Snippets

    @robin-w

    It worked! Thanks to all you guys helping us out. 🙂


    Robin W
    Moderator

    @robin-w

    great – glad you’re fixed !

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.
Skip to toolbar