Skip to:

Site crashes after activating bbPress

  • I just downloaded and installed bbPress 2.0-beta-2.3 so that I may use it’s forum capabilities in BuddyPress (downloaded the latest version today). However after activating the bbPress I can not access my website – I get the message as follows :

    Fatal error: Call to undefined function is_post_type_archive() in /home/bodyw/public_html/healthworks/wp-content/plugins/bbpress/bbp-includes/bbp-core-compatibility.php on line 446

    Does anyone have the slightest idea of what this may mean ? I have tried deactivating all my other plugins to make sure there is no clash but same result. i am using WordPress 3.1.3

    Any help would be greatly appreciated



Viewing 6 replies - 1 through 6 (of 6 total)

  • Steve D


    I believe that BuddyPress has it’s own version of bbPress within itself. Have you tried un-installing the bbPress, then a re-install through the BuddyPress admin menu option?

    Just trying to help if I can. Though I’m having fits getting my own configuration worked out, I thought I’d pitch in my 2 cents.

    John James Jacoby


    @zhonghao – What version of WordPress are you using? Sounds like you’re using 3.0.


    was introduced in 3.1, so it should be available.

    That error won’t happen as a result of a BuddyPress conflict. Matter of fact, the two plugins should play nicely together. They have been both activated and running at for some time now, with no issues.

    Hi John,

    I’m having the same problem. Was wondering if you figured it out.

    I’ve set up BBPress and configured it for integration with my Word Press Blog.

    Then installed the plugin in WP. Now I’m getting the same error and can’t access my website.

    Here’s the error text

    Fatal error: Call to undefined function is_post_type_archive() in /home2/premarit/public_html/blog/wp-content/plugins/bbpress/bbp-includes/bbp-common_template.php on line 90.

    I’ve tried locating this function is-post-type-archive but have not yet found it.

    Any ideas?

    Ok. I did come up with a solution. Apparently is_post_type_archive has been deprecated and the current function is is_archive().

    So I substituted the is_archive for each error I got (about four instants) the initial error and it seems to process ok.

    The original function and the new function are located in wp-includes/query.php.

    John James Jacoby


    @dehicks – Incorrect. is_post_type_archive() is new in 3.1 and not deprecated at all.

    Hi John,

    You’re exactly right. I updated my Word Press after writing you and doing my changes and low and behold, the two functions that were missing are now in place. Thanks for commenting.


Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.
Skip to toolbar